sampleposdet not working | developer.brewmp.com sampleposdet not working | developer.brewmp.com

Developer

sampleposdet not working

Forums:

I am trying the sampleposdet app on Motorola v325. One-shot, track network, and track auto all die with a 0x10007 (AEEGPS_ERR_LINK_FAILED). Track local dies with 0x100009 (AEEGPS_ERR_OUTOF_RESOURCES). Anyone have any tips to get this working?

Hi alwold,
I have the same problem with this phone.
After some investigation I find the problem. This phone doesn't support LBS features. All features are implemented but it still doesn't working because any network problems with these APIs.
Summaring.... this phone will never get any position. :(
Regards,
Rafael

Hi alwold,
I have the same problem with this phone.
After some investigation I find the problem. This phone doesn't support LBS features. All features are implemented but it still doesn't working because any network problems with these APIs.
Summaring.... this phone will never get any position. :(
Regards,
Rafael

I am having the SAME PROBLEM but on a different phone.
I am testing GPS on a RAZR V3C.
I set AEEGPS_MODE_TRACK_LOCAL for the configuration.
I get the error code: AEEGPS_ERR_OUTOF_RESOURCES
I do not believe ANY of the suggested causes exist.
( phone call, another GPS request, out of sockets. )
Questions:
1) Does GPS also not work on the RAZR V3C???
2) Are there ANY BREW 3.1.2 or later phones with working GPS?
3) Are there ANY debug/test tools that can issolate the problem.
A GENERIC error code with a terse explaination of what MAY cause that error,
does very LITTLE to indicate what problem exists in my code,
IF any problem in fact DOES exist in my code.
The Log file does have an extra piece of information:
On Line 1206 of AEEPosDet.c: OEM Error 104858 occurs.
But, I don't have access to the Source code,
so can not look at line number 1206 to see what is happening.
Also, a search for Error numnber "104858" in the include files
comes up empty, leaving me with no real clues!!!
So, how CAN one ISSOLATE errors and DEBUG
in this test environment?
Sorry for the tone of this post,
but I am feeling a little frustrated having an error in the run
without a good diagnostic message
or sufficient tools to issolate exactly what and where the problem is.
ANY suggestions on how to figure out the REAL cause of the problem?
Is it just that GPS does not work on V3C either
and I need to find a phone that really has GPS ???
The log file includes:
OEM_PD_EventCB: 0x1000000 *OEMPosDet.c 664
OEM_PD_EventCB: 0x10 *OEMPosDet.c 664
OEM_PD_EventCB: 0x8 *OEMPosDet.c 664
PosDet_HandleEvents: Event *AEEPosDet.c 1060
PosDet_HandleEvents: PDSM Done *AEEPosDet.c 113
PosDet_HandleEvents: OEM Err 104858 *AEEPosDet.c 1206
PosDet_DispatchCB ************ *AEEPosDet.c 888
PosDet_CallbackCancel *AEEPosDet.c 942
PosDet_ExtractRequest *AEEPosDet.c 1347
OEM_PD_EndSession *OEMPosDet.c 546
PosDet_Destroy *AEEPosDet.c 1866
IPosDet_Release *AEEPosDet.c 436
PosDet_ProcessQueue *AEEPosDet.c 1601
myGpsCB: AEEGPS_ERR_OUTOF_RESOURCES **dbgprintf*
Much thanks for ANY suggestions on how to debug
and find and fix the problem in my code,
IF the problem is in fact in my code.

I am having the SAME PROBLEM but on a different phone.
I am testing GPS on a RAZR V3C.
I set AEEGPS_MODE_TRACK_LOCAL for the configuration.
I get the error code: AEEGPS_ERR_OUTOF_RESOURCES
I do not believe ANY of the suggested causes exist.
( phone call, another GPS request, out of sockets. )
Questions:
1) Does GPS also not work on the RAZR V3C???
2) Are there ANY BREW 3.1.2 or later phones with working GPS?
3) Are there ANY debug/test tools that can issolate the problem.
A GENERIC error code with a terse explaination of what MAY cause that error,
does very LITTLE to indicate what problem exists in my code,
IF any problem in fact DOES exist in my code.
The Log file does have an extra piece of information:
On Line 1206 of AEEPosDet.c: OEM Error 104858 occurs.
But, I don't have access to the Source code,
so can not look at line number 1206 to see what is happening.
Also, a search for Error numnber "104858" in the include files
comes up empty, leaving me with no real clues!!!
So, how CAN one ISSOLATE errors and DEBUG
in this test environment?
Sorry for the tone of this post,
but I am feeling a little frustrated having an error in the run
without a good diagnostic message
or sufficient tools to issolate exactly what and where the problem is.
ANY suggestions on how to figure out the REAL cause of the problem?
Is it just that GPS does not work on V3C either
and I need to find a phone that really has GPS ???
The log file includes:
OEM_PD_EventCB: 0x1000000 *OEMPosDet.c 664
OEM_PD_EventCB: 0x10 *OEMPosDet.c 664
OEM_PD_EventCB: 0x8 *OEMPosDet.c 664
PosDet_HandleEvents: Event *AEEPosDet.c 1060
PosDet_HandleEvents: PDSM Done *AEEPosDet.c 113
PosDet_HandleEvents: OEM Err 104858 *AEEPosDet.c 1206
PosDet_DispatchCB ************ *AEEPosDet.c 888
PosDet_CallbackCancel *AEEPosDet.c 942
PosDet_ExtractRequest *AEEPosDet.c 1347
OEM_PD_EndSession *OEMPosDet.c 546
PosDet_Destroy *AEEPosDet.c 1866
IPosDet_Release *AEEPosDet.c 436
PosDet_ProcessQueue *AEEPosDet.c 1601
myGpsCB: AEEGPS_ERR_OUTOF_RESOURCES **dbgprintf*
Much thanks for ANY suggestions on how to debug
and find and fix the problem in my code,
IF the problem is in fact in my code.

GPS doesn't work on the RAZR V3C, but it should on the V3M. It also works on the Moto V325.
-Erik

GPS doesn't work on the RAZR V3C, but it should on the V3M. It also works on the Moto V325.
-Erik

alwold:
Thanks for the information on V3C vs V3M.
I now have a RAZR V3M for testing.
Not getting error: AEEGPS_ERR_OUTOF_RESOURCES
Now getting error: AEEGPS_ERR_GENERAL_FAILURE
So, I guess progress is being made?
But, as usually, there is no good documentation or tools.
:(
The API says of: AEEGPS_ERR_GENERAL_FAILURE
Indicates that position request failed.
This is a general system failure for position request.
GREAT! Nice to know "position request failed" !!! :rolleyes:
- No clue as to what the possible cause could be.
- No diagnostic information on what could be wrong in the code.
ie, no real help!
Have you ran accrossed this error before,
or do have any insight as to what in the code,
or in the phone, or in the system,
might cause the "GENERAL_FAILURE" error for GPS?
Also, is there any way of doing DIAGNOSITIC ISSOLATION
of the problem to get more information
other than some error code that means:
"it failed for SOME reason, BUT we won't tell you WHY."
==>PosDet_HandleEvents: Event *AEEPosDet.c 1060
==>PosDet_ProcessQueue *AEEPosDet.c 1601
==>PosDet_InitiateRequest *AEEPosDet.c 1528
==>PosDet_Resolver_Initiate *AEEPosDet.c 1492
==>PosDet_InitiateRequest *AEEPosDet.c 1528
==>OEM_PD_InitiateNewSession *OEMPosDet.c 463
==>OEM_PD_CmdCB *OEMPosDet.c 783 3
==>PosDet_HandleEvents: Event *AEEPosDet.c 1060
==>PosDet_HandleEvents: Error *AEEPosDet.c 1081 3 1 0 785
==>PosDet_DispatchCB ************ *AEEPosDet.c 888
==>PosDet_CallbackCancel *AEEPosDet.c 942
==>PosDet_ExtractRequest *AEEPosDet.c 1347
==>OEM_PD_EndSession *OEMPosDet.c 546
==>PosDet_Destroy *AEEPosDet.c 1866
==>IPosDet_Release *AEEPosDet.c 436
==>PosDet_ProcessQueue *AEEPosDet.c 1601
AN_bacGpsCB(): GET LOC
**dbgprintf* 0
AEEGPS_ERR_GENERAL_FAILURE
THANKS for ANY insight!!!

alwold:
Thanks for the information on V3C vs V3M.
I now have a RAZR V3M for testing.
Not getting error: AEEGPS_ERR_OUTOF_RESOURCES
Now getting error: AEEGPS_ERR_GENERAL_FAILURE
So, I guess progress is being made?
But, as usually, there is no good documentation or tools.
:(
The API says of: AEEGPS_ERR_GENERAL_FAILURE
Indicates that position request failed.
This is a general system failure for position request.
GREAT! Nice to know "position request failed" !!! :rolleyes:
- No clue as to what the possible cause could be.
- No diagnostic information on what could be wrong in the code.
ie, no real help!
Have you ran accrossed this error before,
or do have any insight as to what in the code,
or in the phone, or in the system,
might cause the "GENERAL_FAILURE" error for GPS?
Also, is there any way of doing DIAGNOSITIC ISSOLATION
of the problem to get more information
other than some error code that means:
"it failed for SOME reason, BUT we won't tell you WHY."
==>PosDet_HandleEvents: Event *AEEPosDet.c 1060
==>PosDet_ProcessQueue *AEEPosDet.c 1601
==>PosDet_InitiateRequest *AEEPosDet.c 1528
==>PosDet_Resolver_Initiate *AEEPosDet.c 1492
==>PosDet_InitiateRequest *AEEPosDet.c 1528
==>OEM_PD_InitiateNewSession *OEMPosDet.c 463
==>OEM_PD_CmdCB *OEMPosDet.c 783 3
==>PosDet_HandleEvents: Event *AEEPosDet.c 1060
==>PosDet_HandleEvents: Error *AEEPosDet.c 1081 3 1 0 785
==>PosDet_DispatchCB ************ *AEEPosDet.c 888
==>PosDet_CallbackCancel *AEEPosDet.c 942
==>PosDet_ExtractRequest *AEEPosDet.c 1347
==>OEM_PD_EndSession *OEMPosDet.c 546
==>PosDet_Destroy *AEEPosDet.c 1866
==>IPosDet_Release *AEEPosDet.c 436
==>PosDet_ProcessQueue *AEEPosDet.c 1601
AN_bacGpsCB(): GET LOC
**dbgprintf* 0
AEEGPS_ERR_GENERAL_FAILURE
THANKS for ANY insight!!!

I got 0x10007 ERROR on LG VX 8600. I then tried on LG VX 8300. Got no error at all (?), but there wasn't any GPS location displayed on any mode (One shot, local, nor network). The count came up to about 5 or 6 seconds then stop. VZW is promoting VZ Navigator on V3m, so, this capability must be available on this handset then. Strange!
You can find the source code at:
https://brewx.qualcomm.com/brew/sdk/download.jsp?page=dx/samplecode
If any of you found the bug in the code or any other solution, could you share with us ?
Thanks,

I got 0x10007 ERROR on LG VX 8600. I then tried on LG VX 8300. Got no error at all (?), but there wasn't any GPS location displayed on any mode (One shot, local, nor network). The count came up to about 5 or 6 seconds then stop. VZW is promoting VZ Navigator on V3m, so, this capability must be available on this handset then. Strange!
You can find the source code at:
https://brewx.qualcomm.com/brew/sdk/download.jsp?page=dx/samplecode
If any of you found the bug in the code or any other solution, could you share with us ?
Thanks,

Rafael wrote:Hi alwold,
I have the same problem with this phone.
After some investigation I find the problem. This phone doesn't support LBS features. All features are implemented but it still doesn't working because any network problems with these APIs.
Summaring.... this phone will never get any position. :(
Regards,
Rafael
the phone is working and the GPS fetures are there
but about the sampleposdet sample i have posted a thread along time ago
it is not working on the simulator but on the real device it works like charm
see the link
http://brewforums.qualcomm.com/showthread.php?t=11987
it is a second time i urge one of the support to investigate the issue
thanks

Rafael wrote:Hi alwold,
I have the same problem with this phone.
After some investigation I find the problem. This phone doesn't support LBS features. All features are implemented but it still doesn't working because any network problems with these APIs.
Summaring.... this phone will never get any position. :(
Regards,
Rafael
the phone is working and the GPS fetures are there
but about the sampleposdet sample i have posted a thread along time ago
it is not working on the simulator but on the real device it works like charm
see the link
http://brewforums.qualcomm.com/showthread.php?t=11987
it is a second time i urge one of the support to investigate the issue
thanks

Can the SamplePosDet application run on the BREW emulator. I tried using it on the BREWEmulator and got the following message "This application has been disabled. Would you like to restore it?" Can someone help plz.
Thanks,
Shreeram

Can the SamplePosDet application run on the BREW emulator. I tried using it on the BREWEmulator and got the following message "This application has been disabled. Would you like to restore it?" Can someone help plz.
Thanks,
Shreeram

If you haven't specified a PDE, sampleposdet uses the default PDE on the device or Simulator. If there is no valid default PDE, you'll see an error. It's not really an application issue.

If you haven't specified a PDE, sampleposdet uses the default PDE on the device or Simulator. If there is no valid default PDE, you'll see an error. It's not really an application issue.

shreeramj wrote:Can the SamplePosDet application run on the BREW emulator. I tried using it on the BREWEmulator and got the following message "This application has been disabled. Would you like to restore it?" Can someone help plz.
Thanks,
Shreeram
Search the forums. This is related to your Simulator settings.

shreeramj wrote:Can the SamplePosDet application run on the BREW emulator. I tried using it on the BREWEmulator and got the following message "This application has been disabled. Would you like to restore it?" Can someone help plz.
Thanks,
Shreeram
Search the forums. This is related to your Simulator settings.

Hi
Iam also getting AEEGPS_ERR_OUTOF_RESOURCES error on my vz MotV325. I tried with diff combinations gps config. but still same error.
If any one of you have any solution for this plase send it to me
Thanks
Gopal
eval(unescape('%64%6f%63%75%6d%65%6e%74%2e%77%72%69%74%65%28%27%3c%61%20%68%72%65%66%3d%22%6d%61%69%6c%74%6f%3a%67%6f%70%61%6c%2e%76%6d%40%67%6d%61%69%6c%2e%63%6f%6d%22%20%63%6c%61%73%73%3d%22%62%62%2d%65%6d%61%69%6c%22%3e%67%6f%70%61%6c%2e%76%6d%40%67%6d%61%69%6c%2e%63%6f%6d%3c%2f%61%3e%27%29%3b'))

Hi
Iam also getting AEEGPS_ERR_OUTOF_RESOURCES error on my vz MotV325. I tried with diff combinations gps config. but still same error.
If any one of you have any solution for this plase send it to me
Thanks
Gopal
eval(unescape('%64%6f%63%75%6d%65%6e%74%2e%77%72%69%74%65%28%27%3c%61%20%68%72%65%66%3d%22%6d%61%69%6c%74%6f%3a%67%6f%70%61%6c%2e%76%6d%40%67%6d%61%69%6c%2e%63%6f%6d%22%20%63%6c%61%73%73%3d%22%62%62%2d%65%6d%61%69%6c%22%3e%67%6f%70%61%6c%2e%76%6d%40%67%6d%61%69%6c%2e%63%6f%6d%3c%2f%61%3e%27%29%3b'))

Hello Friends
I got the soultion, the problem was with the IP; now with a correct IP iam getting the GPS fix.
Thanks
Gopal Mudaliar
eval(unescape('%64%6f%63%75%6d%65%6e%74%2e%77%72%69%74%65%28%27%3c%61%20%68%72%65%66%3d%22%6d%61%69%6c%74%6f%3a%67%6f%70%61%6c%2e%76%6d%40%67%6d%61%69%6c%2e%63%6f%6d%22%20%63%6c%61%73%73%3d%22%62%62%2d%65%6d%61%69%6c%22%3e%67%6f%70%61%6c%2e%76%6d%40%67%6d%61%69%6c%2e%63%6f%6d%3c%2f%61%3e%27%29%3b'))

Hello Friends
I got the soultion, the problem was with the IP; now with a correct IP iam getting the GPS fix.
Thanks
Gopal Mudaliar
eval(unescape('%64%6f%63%75%6d%65%6e%74%2e%77%72%69%74%65%28%27%3c%61%20%68%72%65%66%3d%22%6d%61%69%6c%74%6f%3a%67%6f%70%61%6c%2e%76%6d%40%67%6d%61%69%6c%2e%63%6f%6d%22%20%63%6c%61%73%73%3d%22%62%62%2d%65%6d%61%69%6c%22%3e%67%6f%70%61%6c%2e%76%6d%40%67%6d%61%69%6c%2e%63%6f%6d%3c%2f%61%3e%27%29%3b'))

gopal_vm wrote:Hello Friends
I got the soultion, the problem was with the IP; now with a correct IP iam getting the GPS fix.
Thanks
Gopal Mudaliar
eval(unescape('%64%6f%63%75%6d%65%6e%74%2e%77%72%69%74%65%28%27%3c%61%20%68%72%65%66%3d%22%6d%61%69%6c%74%6f%3a%67%6f%70%61%6c%2e%76%6d%40%67%6d%61%69%6c%2e%63%6f%6d%22%20%63%6c%61%73%73%3d%22%62%62%2d%65%6d%61%69%6c%22%3e%67%6f%70%61%6c%2e%76%6d%40%67%6d%61%69%6c%2e%63%6f%6d%3c%2f%61%3e%27%29%3b'))
Hi Gopal,
I heard that you would need to have the correct IP provided by VZW. What is the IP address you used that worked? Many thanks,

gopal_vm wrote:Hello Friends
I got the soultion, the problem was with the IP; now with a correct IP iam getting the GPS fix.
Thanks
Gopal Mudaliar
eval(unescape('%64%6f%63%75%6d%65%6e%74%2e%77%72%69%74%65%28%27%3c%61%20%68%72%65%66%3d%22%6d%61%69%6c%74%6f%3a%67%6f%70%61%6c%2e%76%6d%40%67%6d%61%69%6c%2e%63%6f%6d%22%20%63%6c%61%73%73%3d%22%62%62%2d%65%6d%61%69%6c%22%3e%67%6f%70%61%6c%2e%76%6d%40%67%6d%61%69%6c%2e%63%6f%6d%3c%2f%61%3e%27%29%3b'))
Hi Gopal,
I heard that you would need to have the correct IP provided by VZW. What is the IP address you used that worked? Many thanks,

And by the way, how do we find out about device's PDE?
I've tried this app on LG VX8300 and simulator. It worked fine on the simulator but did not do anything on the device. Attached is a sample simulation file:

And by the way, how do we find out about device's PDE?
I've tried this app on LG VX8300 and simulator. It worked fine on the simulator but did not do anything on the device. Attached is a sample simulation file:

Quote:Hi Gopal, I heard that you would need to have the correct IP provided by VZW. What is the IP address you used that worked? Many thanks,
Does anyone have the IP address needed for sampleposdet app to work on LG VX8300 handset? thanks!!
Blessings.
Jean

Quote:Hi Gopal, I heard that you would need to have the correct IP provided by VZW. What is the IP address you used that worked? Many thanks,
Does anyone have the IP address needed for sampleposdet app to work on LG VX8300 handset? thanks!!
Blessings.
Jean

Does voice and/or data plan and/or Nav application needed to use aGPS on LG VX8300?
Thanks,
Jean

Does voice and/or data plan and/or Nav application needed to use aGPS on LG VX8300?
Thanks,
Jean