HTTPS in 3.x | developer.brewmp.com HTTPS in 3.x | developer.brewmp.com

Developer

HTTPS in 3.x

Forums:

hi all....

I am working on a contacts sync app....we connect over HTTPS to our servers....the problem is that we are able to connect over HTTPS in 2.x without any problems...but when we're trying to do the same in Brew 3.x...app crashes after calling IWEB_GetresponseV....and before going to the Callback method...:(..the same thing is happening on all 3.x devices...i checked with Moto-Razr V3c, V325 ....

has any one faced the same problem...do we have add any more options in Webopts for 3.x for HTTPS ??...i need to fix this very urgently...so guyz can you help me out??

thanks in adv.
Srinivas.

if you use Motorola v3c, then it has no support for BREW 3.x and you should use BREW SDK of earlier version. In my opinion, problem is in BREW SDK versions incompatibility.

if you use Motorola v3c, then it has no support for BREW 3.x and you should use BREW SDK of earlier version. In my opinion, problem is in BREW SDK versions incompatibility.

Hello Brewee,
But according to DDS the V3C is BREW 3.x Device ?? :confused:

Hello Brewee,
But according to DDS the V3C is BREW 3.x Device ?? :confused:

RAZR V3C is BREW 3.1.2 device.
We didn't have any problem with HTTPS in Razr phones, including V3C and the same code successfully run on BREW 2.1.3 devices.
I would imagine that the problem may be in your code. Did you check in BREW 3.1.4 simulator?

RAZR V3C is BREW 3.1.2 device.
We didn't have any problem with HTTPS in Razr phones, including V3C and the same code successfully run on BREW 2.1.3 devices.
I would imagine that the problem may be in your code. Did you check in BREW 3.1.4 simulator?

I have used IWEB_GetResponse() with https in 3.x handsets and works great. You can rewrite WEBOPT options without a vector.
#######################
BTW - does any body know why am I getting the PPP closed in LG8500 - chocolate. The scenario is I use IWEB_GetResponse, https. I do get response back from the server but out of 11 loop of data retrieval, I get 7 time at first, then PPP closed, after 4min again restart to get remaining 4 loop of data. This is constant for any amount of data.
Here is the debug info. Also if somebody can tell me how to fix and I would like to enable the debug mode using pound (but forgot the keystroke), so that I can see more logs.
10/25/06 4:23:04 PM inside ReadAtCallBack##########
10/25/06 4:23:10 PM =>Call 0x5 Event 0x103
10/25/06 4:23:10 PM ==> AEETAPI_cbPhoneStatus
10/25/06 4:23:10 PM ==> AEETAPI_cbCallEvent
10/25/06 4:23:10 PM =>Call 0x5 Done.
10/25/06 4:23:10 PM # 54295664 (Net)
10/25/06 4:23:10 PM # 54295664 from OPEN to ASLEEP
10/25/06 4:23:10 PM # 66706512 (Net)
10/25/06 4:23:10 PM # 66706512 from OPEN to ASLEEP
10/25/06 4:23:23 PM 54295664 LINGER - timer fired
10/25/06 4:23:23 PM 54295664 LINGER - (activity) reset for
10/25/06 4:23:23 PM 66706512 LINGER - timer fired
10/25/06 4:23:23 PM 66706512 LINGER - (activity) reset for
10/25/06 4:23:34 PM 54295664 LINGER - timer fired
10/25/06 4:23:34 PM 54295664 LINGER - releasing PPP
10/25/06 4:23:34 PM 54295664 closing PPP
10/25/06 4:23:34 PM 54295664 PPP - Closed
10/25/06 4:23:34 PM # 54295664 (Net)
10/25/06 4:23:34 PM # 54295664 from ASLEEP to CLOSED
10/25/06 4:23:34 PM 54295664 PPP - Closed
10/25/06 4:23:34 PM 66706512 LINGER - timer fired
10/25/06 4:23:34 PM 66706512 LINGER - releasing PPP
10/25/06 4:23:34 PM 66706512 closing PPP
10/25/06 4:23:34 PM 66706512 ClosePPP - ActiveSockets!
10/25/06 4:27:03 PM =>Call 0x6 Event 0x104
10/25/06 4:27:03 PM =>CCall_Incoming 0x6
10/25/06 4:27:03 PM =>Call 0x6 Event 0x102
10/25/06 4:27:03 PM =>Call 0x6 Event 0x105
10/25/06 4:27:03 PM ==> AEETAPI_cbPhoneStatus
10/25/06 4:27:03 PM ==> AEETAPI_cbCallEvent
10/25/06 4:27:03 PM # 66706512 (Net)
10/25/06 4:27:03 PM # 66706512 from ASLEEP to OPEN
10/25/06 4:27:03 PM 66706512 LINGER - set for 30000
10/25/06 4:27:03 PM inside ReadAtCallBack##########
###################################
Thanks
BRU

I have used IWEB_GetResponse() with https in 3.x handsets and works great. You can rewrite WEBOPT options without a vector.
#######################
BTW - does any body know why am I getting the PPP closed in LG8500 - chocolate. The scenario is I use IWEB_GetResponse, https. I do get response back from the server but out of 11 loop of data retrieval, I get 7 time at first, then PPP closed, after 4min again restart to get remaining 4 loop of data. This is constant for any amount of data.
Here is the debug info. Also if somebody can tell me how to fix and I would like to enable the debug mode using pound (but forgot the keystroke), so that I can see more logs.
10/25/06 4:23:04 PM inside ReadAtCallBack##########
10/25/06 4:23:10 PM =>Call 0x5 Event 0x103
10/25/06 4:23:10 PM ==> AEETAPI_cbPhoneStatus
10/25/06 4:23:10 PM ==> AEETAPI_cbCallEvent
10/25/06 4:23:10 PM =>Call 0x5 Done.
10/25/06 4:23:10 PM # 54295664 (Net)
10/25/06 4:23:10 PM # 54295664 from OPEN to ASLEEP
10/25/06 4:23:10 PM # 66706512 (Net)
10/25/06 4:23:10 PM # 66706512 from OPEN to ASLEEP
10/25/06 4:23:23 PM 54295664 LINGER - timer fired
10/25/06 4:23:23 PM 54295664 LINGER - (activity) reset for
10/25/06 4:23:23 PM 66706512 LINGER - timer fired
10/25/06 4:23:23 PM 66706512 LINGER - (activity) reset for
10/25/06 4:23:34 PM 54295664 LINGER - timer fired
10/25/06 4:23:34 PM 54295664 LINGER - releasing PPP
10/25/06 4:23:34 PM 54295664 closing PPP
10/25/06 4:23:34 PM 54295664 PPP - Closed
10/25/06 4:23:34 PM # 54295664 (Net)
10/25/06 4:23:34 PM # 54295664 from ASLEEP to CLOSED
10/25/06 4:23:34 PM 54295664 PPP - Closed
10/25/06 4:23:34 PM 66706512 LINGER - timer fired
10/25/06 4:23:34 PM 66706512 LINGER - releasing PPP
10/25/06 4:23:34 PM 66706512 closing PPP
10/25/06 4:23:34 PM 66706512 ClosePPP - ActiveSockets!
10/25/06 4:27:03 PM =>Call 0x6 Event 0x104
10/25/06 4:27:03 PM =>CCall_Incoming 0x6
10/25/06 4:27:03 PM =>Call 0x6 Event 0x102
10/25/06 4:27:03 PM =>Call 0x6 Event 0x105
10/25/06 4:27:03 PM ==> AEETAPI_cbPhoneStatus
10/25/06 4:27:03 PM ==> AEETAPI_cbCallEvent
10/25/06 4:27:03 PM # 66706512 (Net)
10/25/06 4:27:03 PM # 66706512 from ASLEEP to OPEN
10/25/06 4:27:03 PM 66706512 LINGER - set for 30000
10/25/06 4:27:03 PM inside ReadAtCallBack##########
###################################
Thanks
BRU

If you're running on a 3.1.2 device (v3c, v325, etc.) use the 3.1.2 SDK. BREW for the most part respects backwards-compatibility (running an application compiled against an earlier version of the SDK), but you can't compile for a later version of the SDK and run on an older device (that's forwards-compatibility).

If you're running on a 3.1.2 device (v3c, v325, etc.) use the 3.1.2 SDK. BREW for the most part respects backwards-compatibility (running an application compiled against an earlier version of the SDK), but you can't compile for a later version of the SDK and run on an older device (that's forwards-compatibility).