Can we change the device linger time? | developer.brewmp.com Can we change the device linger time? | developer.brewmp.com

Developer

Can we change the device linger time?

Forums:

Hello All,

Am facing one problem on Motorola W170 device. My application is not fetching server data in first 2-3 hits and in the 4th-5th hit the data is coming from server. I suppose this is related to device linger time. Can anybody suggest me the way to make server connectibility in first time only. And also do reply how do we change device linger time?

Thanks in advance,
Ashwini

You should not change the linger time otherwise you will be failed in TBT by NSTL. If it is a handset issue, then you can get permission from them and modify.
I am not sure if this is a linger issue. First you should debug you code for the real issue. Watch for connection status, server side log etc., Linger time comes to picture when you do one good call and for the next call within this linger time you can send a request quicker(where the connectivity exist for this period).

You should not change the linger time otherwise you will be failed in TBT by NSTL. If it is a handset issue, then you can get permission from them and modify.
I am not sure if this is a linger issue. First you should debug you code for the real issue. Watch for connection status, server side log etc., Linger time comes to picture when you do one good call and for the next call within this linger time you can send a request quicker(where the connectivity exist for this period).

Well, thanks for ur reply. I supposed it as a linger time issue b'cos the same application is working very well on rest of the devices with no such issues. At the same time on other devices server data is getting fetched ....its giving connectivity error on W170 only.
One observation is also that when the device full charged the data is coming with no issues ....but if the battery gets low with even some amount then it creates problem.
Ashwini

Well, thanks for ur reply. I supposed it as a linger time issue b'cos the same application is working very well on rest of the devices with no such issues. At the same time on other devices server data is getting fetched ....its giving connectivity error on W170 only.
One observation is also that when the device full charged the data is coming with no issues ....but if the battery gets low with even some amount then it creates problem.
Ashwini

:confused: I am not sure if there is a link between battery power and a data connection. I can understand some app suspend/resume might happen because of the low bat., notification.
May be, try this - do 10,15 times when battery level is hight and intentionaly bring the battery down(just play the FM) , then try 10,15 times with some time gap(let the call indicator goes away) and see if that really happens.(Problem is some where else). Still you didnt say 'what happens when you do first time both at client as well server side.

:confused: I am not sure if there is a link between battery power and a data connection. I can understand some app suspend/resume might happen because of the low bat., notification.
May be, try this - do 10,15 times when battery level is hight and intentionaly bring the battery down(just play the FM) , then try 10,15 times with some time gap(let the call indicator goes away) and see if that really happens.(Problem is some where else). Still you didnt say 'what happens when you do first time both at client as well server side.