CMX audio not playing in Simulator | developer.brewmp.com CMX audio not playing in Simulator | developer.brewmp.com

Developer

CMX audio not playing in Simulator

Forums:

Hello,
Has anyone had problems playing CMX files in the BREW Simulator?
I'm testing an app where the sound plays fine on the device but I hear nothing in the simulator.
Is there a setting I need to adjust to make these work?

Thanks

There is a March 2007 CMX release in the developers extranet site. At the very least, make sure you have the updated release.

There is a March 2007 CMX release in the developers extranet site. At the very least, make sure you have the updated release.

I believe the CMX extension is buried somewhere around here:
1) Go to the BREW Developers Extranet.
2) Click on the "Support & Services"
3) Click on the "Developer Tools"
4) Click on the "Miscellaneous Development Tools"
5) Click on the "Miscellaneous Development Tools for Authenticated Developers"
6) Click on the "BREW® CMX™ Player (3.0.0.0)"

I believe the CMX extension is buried somewhere around here:
1) Go to the BREW Developers Extranet.
2) Click on the "Support & Services"
3) Click on the "Developer Tools"
4) Click on the "Miscellaneous Development Tools"
5) Click on the "Miscellaneous Development Tools for Authenticated Developers"
6) Click on the "BREW® CMX™ Player (3.0.0.0)"

Melody wrote:I believe the CMX extension is buried somewhere around here:
1) Go to the BREW Developers Extranet.
2) Click on the "Support & Services"
3) Click on the "Developer Tools"
4) Click on the "Miscellaneous Development Tools"
5) Click on the "Miscellaneous Development Tools for Authenticated Developers"
6) Click on the "BREW® CMX™ Player (3.0.0.0)"
Thanks; I had already done this & I still don't hear anything.
Another source is telling me I need "cmx.dll" and "CMXUtil.dll", but I don't know where to get those.

Melody wrote:I believe the CMX extension is buried somewhere around here:
1) Go to the BREW Developers Extranet.
2) Click on the "Support & Services"
3) Click on the "Developer Tools"
4) Click on the "Miscellaneous Development Tools"
5) Click on the "Miscellaneous Development Tools for Authenticated Developers"
6) Click on the "BREW® CMX™ Player (3.0.0.0)"
Thanks; I had already done this & I still don't hear anything.
Another source is telling me I need "cmx.dll" and "CMXUtil.dll", but I don't know where to get those.

I believe those dll's were for the previous version of the CMX.
Check out the MediaPlayer example in the BREW SDK. Copy your cmx media file into the /media directory and see if it plays. If you still don't hear any sound using the MediaPlayer app, you probably need to re-encode your cmx audio to the supported format.

I believe those dll's were for the previous version of the CMX.
Check out the MediaPlayer example in the BREW SDK. Copy your cmx media file into the /media directory and see if it plays. If you still don't hear any sound using the MediaPlayer app, you probably need to re-encode your cmx audio to the supported format.

Thanks For the Help

Thanks For the Help