difference between BREW 2.1 and 3.1 | developer.brewmp.com difference between BREW 2.1 and 3.1 | developer.brewmp.com

Developer

difference between BREW 2.1 and 3.1

Forums:

i want to ask, is there a big difference between BREW 3.1's and 2.1's IMedia / IMediaUtil???
i added some features in my app to play sounds using IMedia and IMediaUtil, i compiled it using BREW 3.1 SDK and uploaded it to a BREW 2.1 device (Kyocera KX2). before i added the sounds it worked all well, but then the sounds can't be played...

is it enough to just recompile it with 2.1 SDK??or should i recode it with 2.1 API??

Never compile with 3.x for a 2.x device. Recompiling should solve your problems.

Never compile with 3.x for a 2.x device. Recompiling should solve your problems.

i have recompiled it with 2.1 SDK, and it's still working in 3.x Simulator (but it won't work in 2.1 Emulator, it's said that the app has been unloaded...)
but in the device, the sound still can't be played...

i have recompiled it with 2.1 SDK, and it's still working in 3.x Simulator (but it won't work in 2.1 Emulator, it's said that the app has been unloaded...)
but in the device, the sound still can't be played...