BREW SQL extension problem while compiling | developer.brewmp.com BREW SQL extension problem while compiling | developer.brewmp.com

Developer

BREW SQL extension problem while compiling

Forums:

Greetings!

I have finally been able to download SQL extension [1.1.2] after maybe months of waiting. There is a sample QueryAnalyzer included with it. I just load the project into VS 2007 IDE and try to compile it. I get the error:

---------------------------------------------------------------------------------
...Qualcomm\BREWSQLExtension_1.1.2\isql\inc\AEESQL.h(29) : fatal error C1083: Cannot open include file: 'AEEOldVaList.h': No such file or directory
---------------------------------------------------------------------------------

I've tried searching for the said file over the internet, in forum, and on my local Harddisk where BREW SQL extensions are installed, but to no avail.

Does anybody know how to resolve this error? All that I did was load the project into IDE and hit the compile button. I did not follow all the steps that QueryAnalyzer help [in docs] say that I should do, i.e.

1- Creating and managing a database
2- Executing an SQL query
3- Using SQL user-defined function libraries
4- Building and running the project

except for (4), all part is useless unless project compiles first time at least...

Any suggesstions? I will appretiate every help from anyone who has any idea...

Thanks in advance

I have just read in its docs, that SQL extension runs only on SDK 3.1.5; while I have 3.1.2 installed, obviously this is the reason why it was not working. While i'm going to install that said version, I need to know if I can somehow compile on 3.1.5 then import some header files (like aeeOldVar.h) into 3.1.2 directory and compile it there as well?
So can I compile it on an old version of BREW as well this way? If not, then is there any other way to do this?
Thanks for any help!

I have just read in its docs, that SQL extension runs only on SDK 3.1.5; while I have 3.1.2 installed, obviously this is the reason why it was not working. While i'm going to install that said version, I need to know if I can somehow compile on 3.1.5 then import some header files (like aeeOldVar.h) into 3.1.2 directory and compile it there as well?
So can I compile it on an old version of BREW as well this way? If not, then is there any other way to do this?
Thanks for any help!