IHTMLViewer Proxy Problem | developer.brewmp.com IHTMLViewer Proxy Problem | developer.brewmp.com

Developer

IHTMLViewer Proxy Problem

Forums:

My application uses the IHTMLViewer object but need to go through a proxy. I set up the proxyspec as in:

awo[i].nId = WEBOPT_PROXYSPEC;
awo[i].pVal = (void *)"http:///http://myproxyaddress.com:9999/";
i++;

// other normal opts set here

IWEB_AddOpt(iWeb,awo);

The initial page request goes through the proxy but all requests inside the IHTMLVIEWER object for images do NOT go through the proxy but straight to the original site.

Several years ago, another developer had the same issue and responded with an "I fixed it. I used IHTMLVIEWER_SetIWeb." I am already using that function so that answer did not help.

Any thoughts?

I figured out the solution.
After I create the instance of the IWeb control, I use IWEB_AddOpt to add the proxyspec as mentioned in the initial message. Using the AddOpt tells the IWeb to keep the option permanent for the life of the instance. Then I tell the IHTMLViewer about the IWeb and it works.
Just thought I'd tell this to help anyone else with the problem.

I figured out the solution.
After I create the instance of the IWeb control, I use IWEB_AddOpt to add the proxyspec as mentioned in the initial message. Using the AddOpt tells the IWeb to keep the option permanent for the life of the instance. Then I tell the IHTMLViewer about the IWeb and it works.
Just thought I'd tell this to help anyone else with the problem.

Thanks a lot!My Friend! :p
With the help of your reply,I fixed the probleam!
Thank you.

Thanks a lot!My Friend! :p
With the help of your reply,I fixed the probleam!
Thank you.