Upload own application to Samsung U740 | developer.brewmp.com Upload own application to Samsung U740 | developer.brewmp.com

Developer

Upload own application to Samsung U740

Forums:

Dear all,

i try upload my own application (game) to Samsung U740 (Brew 3.x), but i cannot see icon in any menu.

My steps:
1. Connect phone to Brew AppLoader
2. Upload my app as New module ... brew apploader create folder with name of my app and also copy .mif file to mif folder.
3. Disconnect the phone
4. Open the phone menu > Get it now > Games
...and i see just the item "Get New App." and not my game applications.

Do i something wrong? Can you help me somebody please?

Thanks

you need to re-set/restart the device after copying new files.
Cable Loaded Apps viewable only after the device has been restarted.
also check BREW Apploader Help->Adding Files to device -> you may drag drop the app to avoid errors.
thanks.

you need to re-set/restart the device after copying new files.
Cable Loaded Apps viewable only after the device has been restarted.
also check BREW Apploader Help->Adding Files to device -> you may drag drop the app to avoid errors.
thanks.

shivendra;81756 wrote:you need to re-set/restart the device after copying new files.
Cable Loaded Apps viewable only after the device has been restarted.
also check BREW Apploader Help->Adding Files to device -> you may drag drop the app to avoid errors.
thanks.
shivendra, thank you for your response
We try the restart device after upload the application and app in phone menu still missing. I am also try upload our app as File, not Module, but result is same.
If you can please check this pictures (our app is BrewHamster):
http://img526.imageshack.us/i/aplloader1.png/
http://img15.imageshack.us/i/aplloader2.png/
http://img514.imageshack.us/i/aplloader3.png/
...maybe we do something wrong.
We check the present of application in menus:
Get It Now>Games
Get It Now>Tools on the Go
Get It Now>Extrax
..maybe we looking for wrong folder.
What you mean about? Thank you

shivendra;81756 wrote:you need to re-set/restart the device after copying new files.
Cable Loaded Apps viewable only after the device has been restarted.
also check BREW Apploader Help->Adding Files to device -> you may drag drop the app to avoid errors.
thanks.
shivendra, thank you for your response
We try the restart device after upload the application and app in phone menu still missing. I am also try upload our app as File, not Module, but result is same.
If you can please check this pictures (our app is BrewHamster):
http://img526.imageshack.us/i/aplloader1.png/
http://img15.imageshack.us/i/aplloader2.png/
http://img514.imageshack.us/i/aplloader3.png/
...maybe we do something wrong.
We check the present of application in menus:
Get It Now>Games
Get It Now>Tools on the Go
Get It Now>Extrax
..maybe we looking for wrong folder.
What you mean about? Thank you

All cable loaded apps would be under Tools on the Go Menu.
try loading helloworld application in the samples.
try - re-create the MIF of your App & make save you it as MIF V 2. there is option in MIF Editor while saving.
try - giving your App a new classid & then re-create the MIF (as V 2)& other MOD.
thanks.

All cable loaded apps would be under Tools on the Go Menu.
try loading helloworld application in the samples.
try - re-create the MIF of your App & make save you it as MIF V 2. there is option in MIF Editor while saving.
try - giving your App a new classid & then re-create the MIF (as V 2)& other MOD.
thanks.

shivendra;81769 wrote:All cable loaded apps would be under Tools on the Go Menu.
try loading helloworld application in the samples.
try - re-create the MIF of your App & make save you it as MIF V 2. there is option in MIF Editor while saving.
try - giving your App a new classid & then re-create the MIF (as V 2)& other MOD.
thanks.
Thank you for your help. Now we can see our applications in the Tools on the Go menu, but cannot run the application. If we click to shortcut then just see for one second icon of sand-glass and jump back to this menu.
Do you know what can be wrong? Wrong resources or something other? In emulator application running ok.

shivendra;81769 wrote:All cable loaded apps would be under Tools on the Go Menu.
try loading helloworld application in the samples.
try - re-create the MIF of your App & make save you it as MIF V 2. there is option in MIF Editor while saving.
try - giving your App a new classid & then re-create the MIF (as V 2)& other MOD.
thanks.
Thank you for your help. Now we can see our applications in the Tools on the Go menu, but cannot run the application. If we click to shortcut then just see for one second icon of sand-glass and jump back to this menu.
Do you know what can be wrong? Wrong resources or something other? In emulator application running ok.

1. Are you sure using the new MIF you checked the APP on simulator.
if not make sure of this & create a new MOD(if u changed the classid)
The App may not be starting due to classid mismatch.
2. SIG error. Check your test SIG File is correct. it should be in the same name as the MOD file.
3. SIG error. Check the helloworld App using your test SIG.
If helloworld runs: NOT 1 & 2...
4. Something may be failing in the function - initAppData or similar.
Do u return FALSE from this in some cases? Put some DBGPRINTF() to print some log messages in initAppData.
You BREW Logger to see the messages you printed using DBGPRINTF() & figure out what's failing.
thanks.

1. Are you sure using the new MIF you checked the APP on simulator.
if not make sure of this & create a new MOD(if u changed the classid)
The App may not be starting due to classid mismatch.
2. SIG error. Check your test SIG File is correct. it should be in the same name as the MOD file.
3. SIG error. Check the helloworld App using your test SIG.
If helloworld runs: NOT 1 & 2...
4. Something may be failing in the function - initAppData or similar.
Do u return FALSE from this in some cases? Put some DBGPRINTF() to print some log messages in initAppData.
You BREW Logger to see the messages you printed using DBGPRINTF() & figure out what's failing.
thanks.

Thank you for your help. Unfortunately we are stuck still on same place.
We try run the our App in phone with connected BREW Logger and this is result:
BREW Logger Version 3.1.1.15 FileLogging Thread Started
TimeStamp Message FileName Line # Sev. Qty Drop Count Total Messages
01/06/80 01:06:25.247158 #*p:ECode:101, Key:e035 *AEEShell.c 3492 3 1 0 8434
01/06/80 01:06:25.247707 AEEKey_AddPressed: 0xe035 *AEEShell.c 3292 3 1 0 8435
01/06/80 01:06:25.248348 #*p:ECode:100, Key:e035 *AEEShell.c 3492 3 1 0 8436
01/06/80 01:06:25.248745 AEEKey_Event: Key=0xe035, dwParam=0x0 *AEEShell.c 3344 3 1 0 8437
01/06/80 01:06:25.254543 #*gSU=16809984 *AEEShell.c 8625 3 1 0 8438
01/06/80 01:06:25.266567 #*g*C=12345678:32090128 *AEEShell.c 6583 3 1 0 8439
01/06/80 01:06:25.267635 #*gRE=16809984 *AEEShell.c 6875 3 1 0 8440
01/06/80 01:06:25.352290 #*p:ECode:102, Key:e035 *AEEShell.c 3492 3 1 0 8441
01/06/80 01:06:25.353205 AEEKey_RemovePressed: 0xe035 *AEEShell.c 3316 3 1 0 8442
We tried resolve error code 12345678:32090128 (bold line) to some understandable error message but unsuccessfully. Do you know what can be wrong please? By the our log file.

Thank you for your help. Unfortunately we are stuck still on same place.
We try run the our App in phone with connected BREW Logger and this is result:
BREW Logger Version 3.1.1.15 FileLogging Thread Started
TimeStamp Message FileName Line # Sev. Qty Drop Count Total Messages
01/06/80 01:06:25.247158 #*p:ECode:101, Key:e035 *AEEShell.c 3492 3 1 0 8434
01/06/80 01:06:25.247707 AEEKey_AddPressed: 0xe035 *AEEShell.c 3292 3 1 0 8435
01/06/80 01:06:25.248348 #*p:ECode:100, Key:e035 *AEEShell.c 3492 3 1 0 8436
01/06/80 01:06:25.248745 AEEKey_Event: Key=0xe035, dwParam=0x0 *AEEShell.c 3344 3 1 0 8437
01/06/80 01:06:25.254543 #*gSU=16809984 *AEEShell.c 8625 3 1 0 8438
01/06/80 01:06:25.266567 #*g*C=12345678:32090128 *AEEShell.c 6583 3 1 0 8439
01/06/80 01:06:25.267635 #*gRE=16809984 *AEEShell.c 6875 3 1 0 8440
01/06/80 01:06:25.352290 #*p:ECode:102, Key:e035 *AEEShell.c 3492 3 1 0 8441
01/06/80 01:06:25.353205 AEEKey_RemovePressed: 0xe035 *AEEShell.c 3316 3 1 0 8442
We tried resolve error code 12345678:32090128 (bold line) to some understandable error message but unsuccessfully. Do you know what can be wrong please? By the our log file.

01/06/80 01:06:25.266567 #*g*C=12345678:32090128 *AEEShell.c 6583 3 1 0 8439
#*g*C=classid:error: This indicates that the creation of an instance of classid failed with the error code error.
so must check the required privilege and set DBGPRINTF on creation of instance.
Thanks
Mukesh Badoni

01/06/80 01:06:25.266567 #*g*C=12345678:32090128 *AEEShell.c 6583 3 1 0 8439
#*g*C=classid:error: This indicates that the creation of an instance of classid failed with the error code error.
so must check the required privilege and set DBGPRINTF on creation of instance.
Thanks
Mukesh Badoni