IFlashPlayer_LoadURL failed,please tell me why,thanks! | developer.brewmp.com IFlashPlayer_LoadURL failed,please tell me why,thanks! | developer.brewmp.com

Developer

IFlashPlayer_LoadURL failed,please tell me why,thanks!

Forums:

I used flashplayer to play the sample swf file(flash_extensionapp.sw) in my widget based applet, code as below:
//////////////////////////////////////////////////////////////////////////////////////////////////////////////
//Create IFlashPlayer
result += ISHELL_CreateInstance(pMe->m_pApp->piShell, AEECLSID_FlashAMCPlayer, (void **)&pMe->piFlashPlayer);
//Create FlashWidget
result += ISHELL_CreateInstance(pMe->m_pApp->piShell, AEECLSID_FlashWidget, (void **) &pMe->piwFlash);
//Create FlashFrameModel
result += ISHELL_CreateInstance(pMe->m_pApp->piShell, AEECLSID_FlashFrameModel,(void **)&pMe->piFlashFrameModel);
//Set FlashPlayer to FlashFrameModel
result += IFlashFrameModel_SetIFlashPlayer(pMe->piFlashFrameModel, pMe->piFlashPlayer);
//Set FlashFrame model as FlashWidgt's model
result += IWidget_SetModel(pMe->piwFlash, (IModel *)(void *)pMe->piFlashFrameModel);
// Create an instance of SignalCBFactory.
result += ISHELL_CreateInstance(pMe->m_pApp->piShell, AEECLSID_SignalCBFactory, (void **)&pMe->piSignalCBFactory);
// Create a signal to be used for Flash player events.
result += ISignalCBFactory_CreateSignal(pMe->piSignalCBFactory,CoreIdleAppFlashWin_OnFlashEvent, pMe,&pMe->piSignal, &pMe->piSignalCtl);
// Register a signal to be set if a Flash player event occurs.
result += IFlashPlayer_OnEvent(pMe->piFlashPlayer, CAST(ISignal *, pMe->piSignalCtl));
//Load swf file
result += IFlashPlayer_LoadURL(pMe->piFlashPlayer,"flash_extensionapp.swf");
///////////////////////////////////////////////////////////////////////////////////////////////////////////////
All steps ok except the last call to IFlashPlayer_LoadURL,result is 13 (AEE_BADSTATE).
Anybody can tell me what's that mean,thanks very much!!!

Question been settled, close and thank you all!

Question been settled, close and thank you all!

Hi
What was the problem. Even i'm getting return value 13.
Thanks
Jithendra

Hi
What was the problem. Even i'm getting return value 13.
Thanks
Jithendra