IWeb returns nCode = -1289 | developer.brewmp.com IWeb returns nCode = -1289 | developer.brewmp.com

Developer

IWeb returns nCode = -1289

Forums:

I am loading jpg files from a web site to make tiles for a map.
I have a loop that gets the jpgs. For testing purposes I am currently getting the same url all the time.
There are 16 images to get however the loop goes thru 6 loops and then stops with an error code -1289.
This is from the log....

6/5/2010 4:10:03 AM sim_dssocket2.c:4757 - NetSim Error 100; "!ps" fulfilled!
6/5/2010 4:10:03 AM sim_dssocket2.c:3202 - NetSim Error 100; "!ps" fulfilled!
6/5/2010 4:10:03 AM sim_dssocket2.c:4218 - NetSim Error 100; "!ps" fulfilled!
6/5/2010 4:10:03 AM deCarta.c:94 - LOG: 4:10:3 ====== IWebCB: CALLED BACK
6/5/2010 4:10:03 AM deCarta.c:94 - LOG: 4:10:3 nCode = -1289
6/5/2010 4:10:03 AM deCarta.c:94 - LOG: 4:10:3 ====== WEB DID NOT SUCCEED

Can you tell me what the -1289 is about? I cannot find it in AEEErrors.h.
What should I do about this?

Thanks

It's WEB_ERROR_CONNECT
From API reference:
Description
The web error code equals the base WEB_ERROR_BASE(0x500) plus the code from the table.
Definitions
Error Code Description
WEB_ERROR_PROTOCOL 1 Protocol error. The value or associated error message is returned in response to
an "ask for extended information" that cannot be processed because the protocol
is invalid.
WEB_ERROR_BADURL 2 Malformed URL.
WEB_ERROR_BADHOSTNAME 3 Malformed hostname in URL.
WEB_ERROR_BADPORT 4 Malformed port in URL.
WEB_ERROR_UNSUPSCHEME 5 Unsupported scheme, no handler found.
WEB_ERROR_DNSCONFIG 6 No DNS servers configured.
WEB_ERROR_DNSTIMEOUT 7 No response from server.
WEB_ERROR_ADDRUNKNOWN 8 DNS server responded 'address unknown.
WEB_ERROR_CONNECT 9 Some kind of connect error.
WEB_ERROR_SEND 10 Error writing to socket.
WEB_ERROR_RECV 11 Error reading from socket.
WEB_ERROR_BADRESPONSE 12 Malformed headers.
WEB_ERROR_BODYLENGTH 13 A request body was specified, but no content length was supplied, or an incorrect
body length was supplied.
WEB_ERROR_PROXYSPEC 14 Invalid proxy spec.
WEB_ERROR_SSL 15 SSL specific error, ask response for extended info

It's WEB_ERROR_CONNECT
From API reference:
Description
The web error code equals the base WEB_ERROR_BASE(0x500) plus the code from the table.
Definitions
Error Code Description
WEB_ERROR_PROTOCOL 1 Protocol error. The value or associated error message is returned in response to
an "ask for extended information" that cannot be processed because the protocol
is invalid.
WEB_ERROR_BADURL 2 Malformed URL.
WEB_ERROR_BADHOSTNAME 3 Malformed hostname in URL.
WEB_ERROR_BADPORT 4 Malformed port in URL.
WEB_ERROR_UNSUPSCHEME 5 Unsupported scheme, no handler found.
WEB_ERROR_DNSCONFIG 6 No DNS servers configured.
WEB_ERROR_DNSTIMEOUT 7 No response from server.
WEB_ERROR_ADDRUNKNOWN 8 DNS server responded 'address unknown.
WEB_ERROR_CONNECT 9 Some kind of connect error.
WEB_ERROR_SEND 10 Error writing to socket.
WEB_ERROR_RECV 11 Error reading from socket.
WEB_ERROR_BADRESPONSE 12 Malformed headers.
WEB_ERROR_BODYLENGTH 13 A request body was specified, but no content length was supplied, or an incorrect
body length was supplied.
WEB_ERROR_PROXYSPEC 14 Invalid proxy spec.
WEB_ERROR_SSL 15 SSL specific error, ask response for extended info

so, was there any resolution to this, or hints to overcome this -1289 issue? I am getting the same error when retrieving images from a map server.

so, was there any resolution to this, or hints to overcome this -1289 issue? I am getting the same error when retrieving images from a map server.

Having too many concurrent streams can result in getting a -1289 error. Simply retry your request at a later point in time, e.g. 100 ms later.
Hope this helps,
Mike

Having too many concurrent streams can result in getting a -1289 error. Simply retry your request at a later point in time, e.g. 100 ms later.
Hope this helps,
Mike