How to create new brew application - Eclipse | developer.brewmp.com How to create new brew application - Eclipse | developer.brewmp.com

Developer

How to create new brew application - Eclipse

Hi

i am foolwing all the steps given for setup C/C++ Enviorment - Eclipse.

after that when i am trying to create new application the following error comes:

 Detail: "Errors occurred during the build.

Errors running builder 'Scanner Configuration Builder' on project 'Application1'.

java.lang.NullPointerException"

 

Thanks

 

1. refer this:
https://developer.brewmp.com/forum/how-use-sample-application-eclipse
 
2. did u check the JRE version installed on your system: Download & install Java Runtime Environment (JRE) 1.6.0_07-b06 or greater
Note: To verify your version, enter at a command prompt: java -version
download 1.7 here: - http://download.cnet.com/Java-Runtime-Environment-JRE/3000-2356_4-100096...
 
also hope you did not miss step 4:-
3. Download antlr-runtime-3.2.jar from http://www.antlr.org/download and copy it to the Eclipse "plugins" folder.

1. refer this:
https://developer.brewmp.com/forum/how-use-sample-application-eclipse
 
2. did u check the JRE version installed on your system: Download & install Java Runtime Environment (JRE) 1.6.0_07-b06 or greater
Note: To verify your version, enter at a command prompt: java -version
download 1.7 here: - http://download.cnet.com/Java-Runtime-Environment-JRE/3000-2356_4-100096...
 
also hope you did not miss step 4:-
3. Download antlr-runtime-3.2.jar from http://www.antlr.org/download and copy it to the Eclipse "plugins" folder.

I followed all the steps but still get the same error.  For a while everytime I reinstalled the plugin in Eclipse I could create one new app, but now reinstalling the plugin does not help.  I have uninstalled Eclipse, the BrewMP platform, and everything I can find several times but I cannot fix the problem.  Any suggestions?

I followed all the steps but still get the same error.  For a while everytime I reinstalled the plugin in Eclipse I could create one new app, but now reinstalling the plugin does not help.  I have uninstalled Eclipse, the BrewMP platform, and everything I can find several times but I cannot fix the problem.  Any suggestions?

I think you missed this out, you need to install two version of Codesoury - |Install both "IA32 Windows" and "ARM EABI" versions|.
"IA32 Windows" - is for Simulator: - If you only install this version, you can compile/run/debug brew Apps on Simulator. But if you try to compile for the device you will get the error: - make.exe : *** .....
"ARM EABI" - is for compilation on device.
 
If you install them in different directories, you will need to start Eclipse for Both versions seperatlly, to update the License in both versions.
 
Once you are done with this, close both versions & open only one, any one version will do both device & simulator work for u.

I think you missed this out, you need to install two version of Codesoury - |Install both "IA32 Windows" and "ARM EABI" versions|.
"IA32 Windows" - is for Simulator: - If you only install this version, you can compile/run/debug brew Apps on Simulator. But if you try to compile for the device you will get the error: - make.exe : *** .....
"ARM EABI" - is for compilation on device.
 
If you install them in different directories, you will need to start Eclipse for Both versions seperatlly, to update the License in both versions.
 
Once you are done with this, close both versions & open only one, any one version will do both device & simulator work for u.

After installing both, how do I fix the make error?

After installing both, how do I fix the make error?

after installing both & installing the plugins in IA32 Windows version. try compiling using win 32 version

after installing both & installing the plugins in IA32 Windows version. try compiling using win 32 version