Iweb Getresponse | developer.brewmp.com Iweb Getresponse | developer.brewmp.com

Developer

Iweb Getresponse

Forums:

Hi, I am using I web to read data from server and post data. I have maded few changes in my application to post data to my iis server. It is working fine for reading and writing. But when I finally post the data it hangs.
I am sending and url like the one mentioned bellow
"http://samalpramod.com/brewtest/lg?pramod&pd=keke&cg=3444&hg=3447&mbn=34..."
When ever I use IWEB, I send the url in the above fashion and get the desired result. but ib last submission it hang.? I could even send the code if somebody like to go through. Since the code is quite lengthy I dont like to post in forum for the sake of cleanness
With Best Regards
Samalpramod

It wud be better if u post the code

It wud be better if u post the code

Hi, Nilesh
I have always done the coding the similar manner that I am doing now. I dont have any problem with the earlier code. But why the same problem arising here.In any case I have never used post, a it was giving problem while posting data. Ok I Can give it a try. Could u please let me know how to post the data
with a samaple code
Regards
Pramod

Hi, Nilesh
I have always done the coding the similar manner that I am doing now. I dont have any problem with the earlier code. But why the same problem arising here.In any case I have never used post, a it was giving problem while posting data. Ok I Can give it a try. Could u please let me know how to post the data
with a samaple code
Regards
Pramod

Plz find file webber.c as an attachment here with few modifications from Webber example which is posting data correctly at my side.

Plz find file webber.c as an attachment here with few modifications from Webber example which is posting data correctly at my side.

Hi Nilesh
Thanks for the reply. I am able to solve the problem to some extent with my own set of codes and using the same method. But I will like to gor through ur code and try to implement that later. But I still have few problems still there. Hope u will not mind if I do share it with you. My application is some what like menu driven aaplication. Each menu is drawn depending upon the text of the web page, I used to read t using IWEB. when I toggle between diffrent menu the application hang up. It takes around 99% of the cpu usage time. I have to kill the application to restart again. It is happening randomly, not specifically on some particular point on the code. Could u plz let me know what colud be the problem
Regards
Pramod

Hi Nilesh
Thanks for the reply. I am able to solve the problem to some extent with my own set of codes and using the same method. But I will like to gor through ur code and try to implement that later. But I still have few problems still there. Hope u will not mind if I do share it with you. My application is some what like menu driven aaplication. Each menu is drawn depending upon the text of the web page, I used to read t using IWEB. when I toggle between diffrent menu the application hang up. It takes around 99% of the cpu usage time. I have to kill the application to restart again. It is happening randomly, not specifically on some particular point on the code. Could u plz let me know what colud be the problem
Regards
Pramod

Have you tried using Visual Studio to debug your application? This should help you pinpoint the cause of your errors.

Have you tried using Visual Studio to debug your application? This should help you pinpoint the cause of your errors.

Hi mohlendo,
Yeh, I am using the Vusual Studio debug window to debug the application.But when the emulator hangs, it does not allow me to do anything. Even if I left the application for some time then even also it hangs. One more thing I want to know if is there any way to come out of this problem?
Regards
Pramod

Hi mohlendo,
Yeh, I am using the Vusual Studio debug window to debug the application.But when the emulator hangs, it does not allow me to do anything. Even if I left the application for some time then even also it hangs. One more thing I want to know if is there any way to come out of this problem?
Regards
Pramod

Have you tried setting breakpoints?

Have you tried setting breakpoints?

When your application hangs, try to use "break execution" feature of visual studio to see where your application is hanging (any infinite loop etc)

When your application hangs, try to use "break execution" feature of visual studio to see where your application is hanging (any infinite loop etc)

HTTP POST has issues on BREW2.0 and should not be used with BREW2.0. This has been fixed in BREW 2.1 onwards. However, the problem you are seeing may not be due to this. I would recommend you to work on BREW2.1 or higher SDK version if you are implementing POST in IWeb
---tamoghna

HTTP POST has issues on BREW2.0 and should not be used with BREW2.0. This has been fixed in BREW 2.1 onwards. However, the problem you are seeing may not be due to this. I would recommend you to work on BREW2.1 or higher SDK version if you are implementing POST in IWeb
---tamoghna

Hi, Ruben and Mohelendo
Yeh I am trying on break point. But the problem is when ever it hangs if break the execution, it takes me to disassembly window. I could not able to understand what is happening there. Sometimes it behaves very strangely. Even thought I came out of the application the program seems to be stop some point in the code though there is no break point there. Could anybody let me know the problem and how to solve it?
Regards
Pramod

Hi, Ruben and Mohelendo
Yeh I am trying on break point. But the problem is when ever it hangs if break the execution, it takes me to disassembly window. I could not able to understand what is happening there. Sometimes it behaves very strangely. Even thought I came out of the application the program seems to be stop some point in the code though there is no break point there. Could anybody let me know the problem and how to solve it?
Regards
Pramod

Hi, samalPramod
I have same problem with you about post the data, can you help me.Give me a cue.

Hi, samalPramod
I have same problem with you about post the data, can you help me.Give me a cue.

Hi Xpig
Nilesh has send an text file attached in this thread. Check out how he does use the post method. I am using passing the data to asp as query string and getting the desired result so far successfully
Regards
Pramod

Hi Xpig
Nilesh has send an text file attached in this thread. Check out how he does use the post method. I am using passing the data to asp as query string and getting the desired result so far successfully
Regards
Pramod