Upgrading to 3.1.4 *broke* OpenGL ES | developer.brewmp.com Upgrading to 3.1.4 *broke* OpenGL ES | developer.brewmp.com

Developer

Upgrading to 3.1.4 *broke* OpenGL ES

Forums:

Everything was happy under BREW SDK 3.1.3. But yesterday I downloaded the 3.1.4 SDK and now I can't instantiate OpenGL ES. Here is the offending function call:

// Use the BREW framework to create IGL and IEGL objects for us
result = ISHELL_CreateInstance(shell, AEECLSID_GL, (void**)&pIGL);

So now, all of a sudden, the function call is returning ECLASSNOTSUPPORT.

Any ideas? Any similar experiences? Should I just go back to the (relatively) safe world of 3.1.3?

Did you put OpenGLESExtension.dll in the bin/Modules directory of your 3.1.4 installation?

Did you put OpenGLESExtension.dll in the bin/Modules directory of your 3.1.4 installation?

Yes. I have it installed the same way as 3.1.3, but now it no longer works.

Yes. I have it installed the same way as 3.1.3, but now it no longer works.

DeFaultRyan wrote:Yes. I have it installed the same way as 3.1.3, but now it no longer works.
I have the same problem. I reverted back to 3.1.3 because of that.

DeFaultRyan wrote:Yes. I have it installed the same way as 3.1.3, but now it no longer works.
I have the same problem. I reverted back to 3.1.3 because of that.

Hi all,
QUALCOMM has addressed this issue with a new version of the OpenGL ES simulator extension available on the extranet:
https://brewx.qualcomm.com/brew/sdk/download.jsp?page=dx/devmisc
Sean

Hi all,
QUALCOMM has addressed this issue with a new version of the OpenGL ES simulator extension available on the extranet:
https://brewx.qualcomm.com/brew/sdk/download.jsp?page=dx/devmisc
Sean