How to use IVocoder Interface? | developer.brewmp.com How to use IVocoder Interface? | developer.brewmp.com

Developer

How to use IVocoder Interface?

Forums:

Do anybody has an example or document of IVocoder ?
I don't know how to use it .

thank you

do you mean I should call OEM layer to in order to play on reverslink?
and what 's the relationship between this document and IVOCODER ?
I am puzzled. I have an example of IVOCUSE , but this example has nothing to do with the ISOUND interface, then how can they contacted?
What's the usage of IVOCODER in order to play on reverslink?

do you mean I should call OEM layer to in order to play on reverslink?
and what 's the relationship between this document and IVOCODER ?
I am puzzled. I have an example of IVOCUSE , but this example has nothing to do with the ISOUND interface, then how can they contacted?
What's the usage of IVOCODER in order to play on reverslink?

I mean Isound interface can not specify a file inorder to play to a specify device

I mean Isound interface can not specify a file inorder to play to a specify device

I'm a little confused on what your asking. I gave you a sample of how to use IVocoder. There is no need for ISound or any OEM layer calls...What are you trying to do?
If your trying to play a recorded message during a voice call, it's probably not going to work. Too much contention with the DSP.

I'm a little confused on what your asking. I gave you a sample of how to use IVocoder. There is no need for ISound or any OEM layer calls...What are you trying to do?
If your trying to play a recorded message during a voice call, it's probably not going to work. Too much contention with the DSP.

Hi,
I'm using the ivocuse code for my real time audio capture application.
I've some doubts.
1. I tried to use VOC_G711(vocoder type) giving the max= companding type
rest being unchanged.
I'm getting the error 1794 --- 702 - AEE_VOC_ENOT_AVAIL .
2. Is any other settings to be done.
pMe->vocConfig.usrPtr = pMe;
pMe->vocConfig.readyCB = ReadyCB;
pMe->vocConfig.haveDataCB = HaveDataCB;
pMe->vocConfig.needDataCB = NeedDataCB;
pMe->vocConfig.playedDataCB = NULL;
pMe->vocConfig.watermark = 24;
pMe->vocConfig.txReduction = 0;
pMe->vocConfig.max = IVOC_G711_MODE_MULAW;
pMe->vocConfig.min = EIGHTH_RATE;
pMe->vocConfig.overwrite = TRUE;
pMe->vocConfig.vocoder = VOC_G711;
Pls reply,
Thanks,
Celia

Hi,
I'm using the ivocuse code for my real time audio capture application.
I've some doubts.
1. I tried to use VOC_G711(vocoder type) giving the max= companding type
rest being unchanged.
I'm getting the error 1794 --- 702 - AEE_VOC_ENOT_AVAIL .
2. Is any other settings to be done.
pMe->vocConfig.usrPtr = pMe;
pMe->vocConfig.readyCB = ReadyCB;
pMe->vocConfig.haveDataCB = HaveDataCB;
pMe->vocConfig.needDataCB = NeedDataCB;
pMe->vocConfig.playedDataCB = NULL;
pMe->vocConfig.watermark = 24;
pMe->vocConfig.txReduction = 0;
pMe->vocConfig.max = IVOC_G711_MODE_MULAW;
pMe->vocConfig.min = EIGHTH_RATE;
pMe->vocConfig.overwrite = TRUE;
pMe->vocConfig.vocoder = VOC_G711;
Pls reply,
Thanks,
Celia

HI
I am using the IVocuse example given by qualcomm. But when i start the app there is silence. I dont know how the sound gets recorded but there is nothing to hear. Has any 1 used the app successfully? Please help

HI
I am using the IVocuse example given by qualcomm. But when i start the app there is silence. I dont know how the sound gets recorded but there is nothing to hear. Has any 1 used the app successfully? Please help

I have used this sample app AS IS, and what I found was, when it is recording you have to talk something and listen to the reply immediatly. But the playback is not playing exact input sound rather vibrating sound is played. It looks some code tweaking is needed.

I have used this sample app AS IS, and what I found was, when it is recording you have to talk something and listen to the reply immediatly. But the playback is not playing exact input sound rather vibrating sound is played. It looks some code tweaking is needed.

Thanks a lot BRU for ur reply....
Jus had some more questions....
I am using the Kyocera KX444 handset on which the Vocoder instance is being created but i am not able to hear any sound. Which handset did u try the app on ??... any other suggestions or modificatoins in the code u wud like to suggest

Thanks a lot BRU for ur reply....
Jus had some more questions....
I am using the Kyocera KX444 handset on which the Vocoder instance is being created but i am not able to hear any sound. Which handset did u try the app on ??... any other suggestions or modificatoins in the code u wud like to suggest

I did it on Mot V3M.

I did it on Mot V3M.

i could't able to launch the ivocuse application on the handset it shows an unknown error(1)
can any one help me out in this regard

i could't able to launch the ivocuse application on the handset it shows an unknown error(1)
can any one help me out in this regard