Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Hi all,

I was trying to compile my code in ARM 3.0 which worked well in earlier ARM version. It compiled fine but when I load it on device, application got crashed while trying to do floating point operation. Did anyone faced similar kind of problem? How to solve this?

Also, I have tried changing the settings in RealView Compiler -> Target (tab) -> Floating point (from none to vfpv2, softvfp, softvfp + vfpv2, softvfp+vfpv3) it didn't get solved. Please let me know which settings I have to set.

Thanks,
Venkat

Hello, has anyone found a solution to this problem, I have also found that when I use _fp_init() in some devices, it makes them crash, even the phone reset it self. But if I take out this function the application starts fine, but when some models (the application use some 3d models) are loaded then the application crash again.
Also tried to use another -fpu vfp but it shows me the error:
Error: A1473E: FPU selection is incompatible with restrictions in 'default'
(the last I think is something with my license, but not sure)
thank you for any information.

Hello, has anyone found a solution to this problem, I have also found that when I use _fp_init() in some devices, it makes them crash, even the phone reset it self. But if I take out this function the application starts fine, but when some models (the application use some 3d models) are loaded then the application crash again.
Also tried to use another -fpu vfp but it shows me the error:
Error: A1473E: FPU selection is incompatible with restrictions in 'default'
(the last I think is something with my license, but not sure)
thank you for any information.