Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

Hello Friends,

I am currently using the transport based on HTTP/1.1. Now Planning to migrate to Brew based transport for my application. I heard that Brew 3.1.5 supports HTTP/1.0. Is it TRUE ?

Is it safe to migrate to Brew which support HTTP1.0?

What are the things I should take care of / confirm before attempting to start to migrate to the Brew based Transport for my App.

Could somebody let me know.

Thanks In Advance,
Tanveer

BREW 3.1.3 and higher supports 1.0 and 1.1. See documentation for IWEB_GetResponse.

BREW 3.1.3 and higher supports 1.0 and 1.1. See documentation for IWEB_GetResponse.

BREW's "http:" engine supports and advertises HTTP version 1.0. The engine has support for HTTP Keep-Alives, which it manages without bothering the application with details of persistent sockets and protocol state. Applications need only manage individual HTTP transactions via the IWEB_GetResponse() method. This is true of all IWeb transactions, not just HTTP.
this text is extracted from brew api reference 2.1.0
It is supported from 2.0.1 further on ( i've done it, i know it works ). As for older versions than 2.0.1 , i don't know :). I've worked only with 1.0 http version. As long as the parameters are right...it should work.
Why should you use only 1.0 ? well...in my opinion you don't want to make separate servers for brew/j2me/symbian , http1.1/http1.0.... You want just 1 server...so...the server should be on 1.0.
Have a nice day

BREW's "http:" engine supports and advertises HTTP version 1.0. The engine has support for HTTP Keep-Alives, which it manages without bothering the application with details of persistent sockets and protocol state. Applications need only manage individual HTTP transactions via the IWEB_GetResponse() method. This is true of all IWeb transactions, not just HTTP.
this text is extracted from brew api reference 2.1.0
It is supported from 2.0.1 further on ( i've done it, i know it works ). As for older versions than 2.0.1 , i don't know :). I've worked only with 1.0 http version. As long as the parameters are right...it should work.
Why should you use only 1.0 ? well...in my opinion you don't want to make separate servers for brew/j2me/symbian , http1.1/http1.0.... You want just 1 server...so...the server should be on 1.0.
Have a nice day