Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

Hi,

do you know if it is possible to debug C++ apps with BREW on target debugging?

I'm having problems to debug it. I can connect to the device, it stops on brew_debugger_entry(), I can set breakpoints correctly but, when I do "continue" in GDB it shows the following:

(gdb) c
Continuing.
Sending packet: $Z0,200f810,4#a7...Ack
Packet received: OK
Packet Z0 (software-breakpoint) is supported
Sending packet: $Hc0#db...Ack
Packet received: OK
Sending packet: $c#63...Ack

...and freezes.

Thanks in advance.

Hi All,
I already have the answers for my questions. The problem was that I compiled the AEE stuff (AEEModGen and AEEAppGen) using G++ instead of GCC, because I'm trying to make compilation process automatic.
Now I'm using GCC and it is working fine.
Thanks,

Hi All,
I already have the answers for my questions. The problem was that I compiled the AEE stuff (AEEModGen and AEEAppGen) using G++ instead of GCC, because I'm trying to make compilation process automatic.
Now I'm using GCC and it is working fine.
Thanks,

Hi,
Could you tell me the gcc command that you use (wich switches, etc) I have something similar in that the debugger entry point is hit but then I never hit breakpoints I set. I am using gcc.
Are you using gcc to compile all your cpp files as well ?
Thanks
Bruno

Hi,
Could you tell me the gcc command that you use (wich switches, etc) I have something similar in that the debugger entry point is hit but then I never hit breakpoints I set. I am using gcc.
Are you using gcc to compile all your cpp files as well ?
Thanks
Bruno