Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

I am not able to see list of brew installable on the following link-
https://brewx.qualcomm.com/brew/sdk/download.jsp?page=dx/en/brew31/ad/tl/sdk

Can anyone provide me the direct link to install Brew sdk3.1.5?.

when u post this link, It shows a web page asking you to agree. click i agree. Then you are led to a list containing different sdk. click brew sdk 3.1 under BREW Development. now you go to a new page. here select brew 3.1 link at the left side.
Or
you can agree and then paste the link directly to another tab in browser.

when u post this link, It shows a web page asking you to agree. click i agree. Then you are led to a list containing different sdk. click brew sdk 3.1 under BREW Development. now you go to a new page. here select brew 3.1 link at the left side.
Or
you can agree and then paste the link directly to another tab in browser.

Thanks Deepak,I follow the same steps but on click of BrewSDk 3.1 on the left side,i again get to Terms and conditions page.Pls. try it at your end and let me know if that works.

Thanks Deepak,I follow the same steps but on click of BrewSDk 3.1 on the left side,i again get to Terms and conditions page.Pls. try it at your end and let me know if that works.

yes... it works for me... wonder why it doesn't work for you. :confused:

yes... it works for me... wonder why it doesn't work for you. :confused:

just downloaded 3.1.5SP01

just downloaded 3.1.5SP01

Ohkay,Can you send me the direct link to it.

Ohkay,Can you send me the direct link to it.

The direct link to it is same as that posted above. I was using firefox... just now tried using internet explorer. It goes in a never ending loop as you posted. funny. Don't know why this is happening.

The direct link to it is same as that posted above. I was using firefox... just now tried using internet explorer. It goes in a never ending loop as you posted. funny. Don't know why this is happening.

Its working for me now:-).Also,i have just started learning brew,Do you have any pdf's or documents to start for simple games or application from scratch.

Its working for me now:-).Also,i have just started learning brew,Do you have any pdf's or documents to start for simple games or application from scratch.

i am try to parse the url and veiw the awff array......but i am not able to see all the name=values formats....(only the first one is visible)
noForm = IWEBUTIL_ParseFormFields( pIWebUtil, &pTemp, NULL,((unsigned int)-1)>>1, WEBUTIL_PFFF_NOMUTATE );
if(noForm > 0)
{
ptr=(WebFormField *)MALLOC(sizeof(WebFormField) * noForm);
if(!ptr)
return FALSE;
}
pTemp=pTuri;
result=IWEBUTIL_ParseFormFields( pIWebUtil, &pTemp, ptr ,noForm, (WEBUTIL_PFFF_NOMUTATE||WEBUTIL_PFFF_NODECODE) );
this code will work only for the firast formfeild.....and u should remove the nodecode from the code

i am try to parse the url and veiw the awff array......but i am not able to see all the name=values formats....(only the first one is visible)
noForm = IWEBUTIL_ParseFormFields( pIWebUtil, &pTemp, NULL,((unsigned int)-1)>>1, WEBUTIL_PFFF_NOMUTATE );
if(noForm > 0)
{
ptr=(WebFormField *)MALLOC(sizeof(WebFormField) * noForm);
if(!ptr)
return FALSE;
}
pTemp=pTuri;
result=IWEBUTIL_ParseFormFields( pIWebUtil, &pTemp, ptr ,noForm, (WEBUTIL_PFFF_NOMUTATE||WEBUTIL_PFFF_NODECODE) );
this code will work only for the firast formfeild.....and u should remove the nodecode from the code

Hi,
I am using Brew 3.1.3.When i build my aplication,it has no errors and also,i saved my application in C:\Program Files\BREW 3.1.3\sdk\examples.When i start the simulator,it displays only the by-default applications in examples and does not display my application.
Secondly,when i run any of the example application eg. HelloWorld,it throws the below error.
"The app was disabled to save space.Would you like to restore it now?".
Pls. help me on this.

Hi,
I am using Brew 3.1.3.When i build my aplication,it has no errors and also,i saved my application in C:\Program Files\BREW 3.1.3\sdk\examples.When i start the simulator,it displays only the by-default applications in examples and does not display my application.
Secondly,when i run any of the example application eg. HelloWorld,it throws the below error.
"The app was disabled to save space.Would you like to restore it now?".
Pls. help me on this.

Ekta wrote:Hi,
I am using Brew 3.1.3.When i build my aplication,it has no errors and also,i saved my application in C:\Program Files\BREW 3.1.3\sdk\examples.When i start the simulator,it displays only the by-default applications in examples and does not display my application.
hello...
if your application is in : C:\Program Files\BREW 3.1.3\sdk\examples" than put mif file of your application in examples folder.
set the proper path for applet directry.
Thanks

Ekta wrote:Hi,
I am using Brew 3.1.3.When i build my aplication,it has no errors and also,i saved my application in C:\Program Files\BREW 3.1.3\sdk\examples.When i start the simulator,it displays only the by-default applications in examples and does not display my application.
hello...
if your application is in : C:\Program Files\BREW 3.1.3\sdk\examples" than put mif file of your application in examples folder.
set the proper path for applet directry.
Thanks

My application's MIF lies in examples folder only but still it shows that problem.

My application's MIF lies in examples folder only but still it shows that problem.

Ekta wrote:My application's MIF lies in examples folder only but still it shows that problem.
For your application to be listed in the emulator. The appname.mif should be outside the folder appname [the folder name should be same as the appname]. Inside the folder appname, have your appname.dll, .bar, etc. Like,
bin [folder]
|
|--appname.mif
|
|--appname [folder]
|
|--appname.dll
|--appname.bar
|-- ... [any other resources]
Now when you change the applet dir in the simulator, point it to the folder containing the .mif [In the above example its "bin"]. Now you will be able to see your app in the emulator.
HTH.

Ekta wrote:My application's MIF lies in examples folder only but still it shows that problem.
For your application to be listed in the emulator. The appname.mif should be outside the folder appname [the folder name should be same as the appname]. Inside the folder appname, have your appname.dll, .bar, etc. Like,
bin [folder]
|
|--appname.mif
|
|--appname [folder]
|
|--appname.dll
|--appname.bar
|-- ... [any other resources]
Now when you change the applet dir in the simulator, point it to the folder containing the .mif [In the above example its "bin"]. Now you will be able to see your app in the emulator.
HTH.

Thanks alot.Now am able to run the code.
When i add a image through resource editor and give the following code in my application,it throws the error as
Error 1 error C2065: 'IDI_IMG_CURSOR' : undeclared identifierc:\Program Files\BREW 3.1.3\sdk\examples\firstapp\firstapp.c 291
Code used for this is:
pMe->pIImage = ISHELL_LoadResImage(pMe->pIShell,FIRSTAPP_RES_FILE,IDI_IMG_CURSOR);
Please let me know why is it throwing this error even when i have declared this in resource editor as
Identification
ID 1
Name IDI_IMG_CURSOR
Attributes
Source File
Data .\images\256color\cursor-1.bmp
Encoding
Comment
Preview
Mime type image/bmp
Width 9
height 9
Bit/Pix 1
Pls. help.

Thanks alot.Now am able to run the code.
When i add a image through resource editor and give the following code in my application,it throws the error as
Error 1 error C2065: 'IDI_IMG_CURSOR' : undeclared identifierc:\Program Files\BREW 3.1.3\sdk\examples\firstapp\firstapp.c 291
Code used for this is:
pMe->pIImage = ISHELL_LoadResImage(pMe->pIShell,FIRSTAPP_RES_FILE,IDI_IMG_CURSOR);
Please let me know why is it throwing this error even when i have declared this in resource editor as
Identification
ID 1
Name IDI_IMG_CURSOR
Attributes
Source File
Data .\images\256color\cursor-1.bmp
Encoding
Comment
Preview
Mime type image/bmp
Width 9
height 9
Bit/Pix 1
Pls. help.

You have to include the .brh file (generated along with the .bar) while compiling the application.

You have to include the .brh file (generated along with the .bar) while compiling the application.

Hi..
have u properly included the resourcefilename_res.h or resourcefilename.brh file in ur workspace??
if it is not able to read this "IDI_IMG_CURSOR" id it means there is no mapping
for tht.
thnaks

Hi..
have u properly included the resourcefilename_res.h or resourcefilename.brh file in ur workspace??
if it is not able to read this "IDI_IMG_CURSOR" id it means there is no mapping
for tht.
thnaks

Ekta,
Check whether your resource file name is in "lowercase" letters or not

Ekta,
Check whether your resource file name is in "lowercase" letters or not