Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

Hi. I'm trying to make a Brew MP scheduled TFS build system.
In my customized TFSBuild.proj, I call this

cs-make.exe -f "MyProject.mak" "V=ADS12arm9_Release" "BREWMPSDK=C:\PROGRA~1\Qualcomm\BREWMP~1\PLATFO~1\110~1.884\platform" "BREWMP_PLATFORM=C:\PROGRA~1\Qualcomm\BREWMP~1\PLATFO~1\110~1.884\platform"

It's working fine on local PC or command prompt on server, but when we queue the build to TFS, it always fails with the log:

process_begin: CreateProcess(NULL, uname -s, ...) failed.
process_begin: CreateProcess(NULL, C:/PROGRA~1/Qualcomm/BREWMP~1/PLATFO~1/110~1.884/tools/bin/cdep.exe -IC:/PROGRA~1/Qualcomm/BREWMP~1/PLATFO~1/110~1.884/platform/connectivity/inc -IC:/PROGRA~1/Qualcomm/BREWMP~1/PLATFO~1/110~1.884/platform/databases/inc -IC:/PROGRA~1/Qualcomm/BREWMP~1/PLATFO~1/110~1.884/platform/deprecated/inc -IC:/PROGRA~1/Qualcomm/BREWMP~1/PLATFO~1/110~1.884/platform/hardware/inc -IC:/PROGRA~1/Qualcomm/BREWMP~1/PLATFO~1/110~1.884/platform/languages/inc -IC:/PROGRA~1/Qualcomm/BREWMP~1/PLATFO~1/110~1.884/platform/media/inc -IC:/PROGRA~1/Qualcomm/BREWMP~1/PLATFO~1/110~1.884/platform/networking/inc -IC:/PROGRA~1/Qualcomm/BREWMP~1/PLATFO~1/110~1.884/platform/security/inc -IC:/PROGRA~1/Qualcomm/BREWMP~1/PLATFO~1/110~1.884/platform/system/inc -IC:/PROGRA~1/Qualcomm/BREWMP~1/PLATFO~1/110~1.884/platform/telephony/inc -IC:/PROGRA~1/Qualcomm/BREWMP~1/PLATFO~1/110~1.884/platform/ui/inc -IADS12arm9_Debug -1 ICityID.idl, ...) failed.

Does anyone have any solution? Thank you.