Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

Is it just me, or does the g'zone emulator not display PNG images?

I have 2 versions of my application, one with PNGs and one with BMP images... the PNG version works on the 23/26 handsets I've tested it on (including the gzone device itself, and excluding some little phones like the n330, 8910). However, the gzone emulator won't display the pngs, but works fine with the bmp version.

Anyone seen something like this before? I didn't know that emulators could be so specific as far as supported image types.

-Joe

Does DDS say that target device support PNG?

Does DDS say that target device support PNG?

There is no device data sheet listed for the utstarcom gz1. We have the device (gz1-V), and it does run the PNG version just fine, it is only a problem in the emulator.

There is no device data sheet listed for the utstarcom gz1. We have the device (gz1-V), and it does run the PNG version just fine, it is only a problem in the emulator.

I managed to work around it somehow, still not sure why only this emulator was having problems with the code... we were doing a conversion through IBITMAP_CreateCompatibleBitmap which managed to change the bitmap dimensions somehow, which broke the sprite rescaling and blah blah blah it broke.

I managed to work around it somehow, still not sure why only this emulator was having problems with the code... we were doing a conversion through IBITMAP_CreateCompatibleBitmap which managed to change the bitmap dimensions somehow, which broke the sprite rescaling and blah blah blah it broke.