Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

I've got an LG VX-8500 chocolate, and I'm trying to get my existing (working) camera code to work on this phone. It seem that when the viewfinder is enabled, the form no longer receives key events with any consistency. The keys work from time to time, but the majority of the time, it is completely unresponsive. Once the viewfinder is shown, not even the end key or slider seem to be able to do anything. You pretty much just have to reset the phone using the apploader or by taking the battery out. Has anyone else experienced these issues? Anyone know workarounds?

Thanks

-Al

I have seen similar behaviour on the VX8500, but have not yet found a work-around. If you find a solution to this problem, please post it here. I will do likewise.

I have seen similar behaviour on the VX8500, but have not yet found a work-around. If you find a solution to this problem, please post it here. I will do likewise.

I had same problem...

I had same problem...

In talking to Qualcomm's technical support, they were able to reproduce the problem 100%. There is currently no known work-around. For now, it will be added to the known issues list for the VX8500.

In talking to Qualcomm's technical support, they were able to reproduce the problem 100%. There is currently no known work-around. For now, it will be added to the known issues list for the VX8500.

Max,
Has anyone heard about an update to this issue? Although there are not a lot of applications that currently use the camera, I am pretty surprised that such a major bug would make it through. Ofcourse the Chocolate was clearly rushed to market, but never mind that....
THanks,

Max,
Has anyone heard about an update to this issue? Although there are not a lot of applications that currently use the camera, I am pretty surprised that such a major bug would make it through. Ofcourse the Chocolate was clearly rushed to market, but never mind that....
THanks,

I haven't heard anything from Qualcomm on this issue. In fact, when I check the Developer Extranet, they haven't even added this bug as a "known issue" for the phone.

I haven't heard anything from Qualcomm on this issue. In fact, when I check the Developer Extranet, they haven't even added this bug as a "known issue" for the phone.

It has now been a year since last post on this thread.
Any update or address from Qualcomm?
- Thanks, David

It has now been a year since last post on this thread.
Any update or address from Qualcomm?
- Thanks, David

I haven't checked the updated Chocolate yet though, the VX8550. Probably worth looking into because if it was addressed, that would be the most likely spot.
Cheers

I haven't checked the updated Chocolate yet though, the VX8550. Probably worth looking into because if it was addressed, that would be the most likely spot.
Cheers

QUALCOMM employees are somewhat restricted by NDAs in how we communicate issues related to specific OEMs/devices. This is why you usually won't see us replying to device-specific issue confirmations on a public forum -- if you need help from QCOM with a device-specific issue, you're better off submitting an SR.

QUALCOMM employees are somewhat restricted by NDAs in how we communicate issues related to specific OEMs/devices. This is why you usually won't see us replying to device-specific issue confirmations on a public forum -- if you need help from QCOM with a device-specific issue, you're better off submitting an SR.

I have a semi-acceptable workaround to the keypad lockup problem.
Skip processing of one out of every 3 or 4 preview frames.
This works for VX8550. I have not yet tested on VX8500.
case CAM_STATUS_FRAME:
{
if(IS_CHOCOLATE(pMe->DeviceInfo.dwPlatformID)) {
pMe->chocFrameFlag = ((pMe->chocFrameFlag + 1) % 4);
if(pMe->chocFrameFlag == 0) {
// Skip n'th frame frees cycles for keypad event processing.
break;
}
}

Do this before ICAMERA_GetFrame.
I am having difficulty resizing the camera capture dimensions on the VX8550. So far, I have only been able to preview AND capture 176x144, which is an unacceptable limitation. Any ideas?
- David

I have a semi-acceptable workaround to the keypad lockup problem.
Skip processing of one out of every 3 or 4 preview frames.
This works for VX8550. I have not yet tested on VX8500.
case CAM_STATUS_FRAME:
{
if(IS_CHOCOLATE(pMe->DeviceInfo.dwPlatformID)) {
pMe->chocFrameFlag = ((pMe->chocFrameFlag + 1) % 4);
if(pMe->chocFrameFlag == 0) {
// Skip n'th frame frees cycles for keypad event processing.
break;
}
}

Do this before ICAMERA_GetFrame.
I am having difficulty resizing the camera capture dimensions on the VX8550. So far, I have only been able to preview AND capture 176x144, which is an unacceptable limitation. Any ideas?
- David

I have a partial solution. Problem is same on standard VX8500 Chocolate and VX8550 Chocolate 2, so there is probably no firmware update to address the problem.
My work around is to skip processing of every 3rd or 4th preview frame.
Unfortunately, I can only preview in 176x144 even though screen is much larger. I cannot capture in any larger sizes. If anyone figures out how, please update. When I try to turn off/on the camera to reset size, the keypad locks up indefinately.
- David Manpearl

I have a partial solution. Problem is same on standard VX8500 Chocolate and VX8550 Chocolate 2, so there is probably no firmware update to address the problem.
My work around is to skip processing of every 3rd or 4th preview frame.
Unfortunately, I can only preview in 176x144 even though screen is much larger. I cannot capture in any larger sizes. If anyone figures out how, please update. When I try to turn off/on the camera to reset size, the keypad locks up indefinately.
- David Manpearl

I tried the workaround about skipping the third and forth frame of preview.
It just work on 8550.
You know even it still fails even I trid to skip three of the four frames.
So I enlarge the count to 10 finally it works, but the screen of course is not smoothly.
Can anyone give a better workaround for it?
really appreciate!
Regards,
Chunyuan

I tried the workaround about skipping the third and forth frame of preview.
It just work on 8550.
You know even it still fails even I trid to skip three of the four frames.
So I enlarge the count to 10 finally it works, but the screen of course is not smoothly.
Can anyone give a better workaround for it?
really appreciate!
Regards,
Chunyuan