Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Hi!

Here's the problem:
My application is designed to work with phones with 16bpp displays and some parts my graphics engine are specifically optimised in assembler for such format. Obviously everything works perfectly fine on the phone. Unfortunately the emulator supports only 256 colours and this is causing two problems:

1) To support 8bpp display on the emulator I would have to completely rewrite mentioned code to emulate the same behaviour on the emulator.
2) Even if I rewrite it for the emulator everything will look terrible in 256 colours.

So I am thinking about placing some kind of label saying "feature not supported on the emulator".

Any other ideas?
I wonder if anyone had similar experiences.

Zim

Use device configurator to configure the emulator to support 16bit/pixel support.
It should work fine in emulator( I have used it many time)
ruben

Use device configurator to configure the emulator to support 16bit/pixel support.
It should work fine in emulator( I have used it many time)
ruben

Thanks a lot, Ruben. I had a lot of problems with this feature of the emulator for 1.1 . Apparently everything works fine on 2.0.
Zim

Thanks a lot, Ruben. I had a lot of problems with this feature of the emulator for 1.1 . Apparently everything works fine on 2.0.
Zim

BREW SDK 1.1 emulator has quite a few problems. I use 2.1 emulator without any problem.
ruben

BREW SDK 1.1 emulator has quite a few problems. I use 2.1 emulator without any problem.
ruben