Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

Hello,

I tried to display Japanese font on simulator in the two environments.
One environment is OK, another is NG.

Please tell me how to fix that trouble.
------------------------------------------------------------------------------
Environment 1 : [Windows XP Japanse version]
I removed two files , sysfonts.mif and hdksansfont.mif, from Simulator.
Simulator could show both Japanese and ASCII font.

Environment 2: [Windows XP English version and japanese language pack]
Same files were removed.
All characters that simulator shows are unreadable(garbled characters).
------------------------------------------------------------------------------

I need to develop in Windows XP English version and japanese language pack.

Thank you.

Hello,
You need to set the Japanese language as the default language in Env 2. If you have not done so, it will use English by default.
Regards,
Brian

Hello,
You need to set the Japanese language as the default language in Env 2. If you have not done so, it will use English by default.
Regards,
Brian

Hello, Brian
Thank you for your response.
I set "Reagion and Language Options" of Windows XP as follows in Env 2.
But all characters, both japanese and acii font, are unreadable(garbled characters).
In addition, characters of application launcher screen on simulator are garbled in Env 2.
---------------------------------------------------------
1)Language Tab
"Install files for East Asian languages" was checked.
Detail options of "Text services and input languages" were set to Japanese IME and Keyboard.
2)Advanced Tab
"Language for non-Unicode programs" was set to Jananese.
"Code page conversion tables" were set to MAC-Roman and MAC-Japanese.
---------------------------------------------------------

Hello, Brian
Thank you for your response.
I set "Reagion and Language Options" of Windows XP as follows in Env 2.
But all characters, both japanese and acii font, are unreadable(garbled characters).
In addition, characters of application launcher screen on simulator are garbled in Env 2.
---------------------------------------------------------
1)Language Tab
"Install files for East Asian languages" was checked.
Detail options of "Text services and input languages" were set to Japanese IME and Keyboard.
2)Advanced Tab
"Language for non-Unicode programs" was set to Jananese.
"Code page conversion tables" were set to MAC-Roman and MAC-Japanese.
---------------------------------------------------------

Hello,
The changes in step 2. Advanced Tab may not be necessary. Can you please try setting the Formats to Japanese and Location to Japan and let me know if this works for you?
Regards,
Brian

Hello,
The changes in step 2. Advanced Tab may not be necessary. Can you please try setting the Formats to Japanese and Location to Japan and let me know if this works for you?
Regards,
Brian

Hello, Brian
I have set the Formats to Japanese and Location to Japan and restarted OS.
Result was NG.
All characters, both japanese and acii font, are unreadable(garbled characters).
I describe the details of procedure.
1)Remove the two files (sysfonts.mif and hdksansfont.mif) from Simulator.
2)Create a new project by BMP C template.
3)Edit the resource file by Resouce Manager.
I add the japanese characters to "HelloWorld".
Build the bar file.
4)Run the project
System Environment 2
BMP SDK 7.8.0
WindowsXP SP3 English version
Visual Studio 2008 Std English version

Hello, Brian
I have set the Formats to Japanese and Location to Japan and restarted OS.
Result was NG.
All characters, both japanese and acii font, are unreadable(garbled characters).
I describe the details of procedure.
1)Remove the two files (sysfonts.mif and hdksansfont.mif) from Simulator.
2)Create a new project by BMP C template.
3)Edit the resource file by Resouce Manager.
I add the japanese characters to "HelloWorld".
Build the bar file.
4)Run the project
System Environment 2
BMP SDK 7.8.0
WindowsXP SP3 English version
Visual Studio 2008 Std English version

Hello,
I attached the screen captuer.
Left: Env1 Japanese OS
Right:Env2 EnglishOS+Japanese languagepak

Hello,
I attached the screen captuer.
Left: Env1 Japanese OS
Right:Env2 EnglishOS+Japanese languagepak

Can you revert back step 2? especially Language for non-unicode programs need to be set to English.
2)Advanced Tab
"Language for non-Unicode programs" was set to Jananese.
"Code page conversion tables" were set to MAC-Roman and MAC-Japanese.
Also are you using Shift-JIS encoding? If yes, then you need to change the
IDS_DD_ENCODING to 2
it is in the settings.ini file in the target you've created \fs\sys\mod\simulator
After that, run the same app that works fine in Env 1 on Env2 and see if that works.

Can you revert back step 2? especially Language for non-unicode programs need to be set to English.
2)Advanced Tab
"Language for non-Unicode programs" was set to Jananese.
"Code page conversion tables" were set to MAC-Roman and MAC-Japanese.
Also are you using Shift-JIS encoding? If yes, then you need to change the
IDS_DD_ENCODING to 2
it is in the settings.ini file in the target you've created \fs\sys\mod\simulator
After that, run the same app that works fine in Env 1 on Env2 and see if that works.

Hello, chunmeis
Thank you for your response.
I checked two tests in Env2(English OS + Japanese language pack)
[Test1]
I reverted the setting of "Language for non-Unicode programs" to English(United States)
I restarted OS.
I run the Hellowold project.
The result was NG. Simulator showed unreadable characters.
[Test2]
The bar file of the Helloworld project used Unicode, but I tried to change the value of IDS_DD_ENCODING.
I run the Hellowold project.
Visual Studio showed the dialog of "Visual Stuio Just-In-Time Debugger".
Error messages were "An unhandled win32 exception occured in SimTargetExecutor.exe[1940]"
Simulator power was turned off.

Hello, chunmeis
Thank you for your response.
I checked two tests in Env2(English OS + Japanese language pack)
[Test1]
I reverted the setting of "Language for non-Unicode programs" to English(United States)
I restarted OS.
I run the Hellowold project.
The result was NG. Simulator showed unreadable characters.
[Test2]
The bar file of the Helloworld project used Unicode, but I tried to change the value of IDS_DD_ENCODING.
I run the Hellowold project.
Visual Studio showed the dialog of "Visual Stuio Just-In-Time Debugger".
Error messages were "An unhandled win32 exception occured in SimTargetExecutor.exe[1940]"
Simulator power was turned off.

If you are using unicode encoding, then don't change the IDS_DD_ENCODING, leave it at 0.You also don't need to do any of the language settings, install Eastern Asia Fonts are the only requirement.
When you are making the car file, open it in notepad, and use UTF16_EncString to define your string. like below.
ModRsc {
--
name = "IDS_STRING_1001",
id = 1001,
type = 1, --RESTYPE_ENCSTRING (see AEEResType.h)
data = UTF16_EncString("eåg, Hello World"),

and when you do save as, select Encoding UTF-8 and Save As File type: All files
then use resource manager to build the .bar file from the .car file. use this .bar file, copy the .bar file you've just built to your project ->package->projectName, to overwrite the .bar file already there, then when you run this, you should see the fonts displayed correctly.

If you are using unicode encoding, then don't change the IDS_DD_ENCODING, leave it at 0.You also don't need to do any of the language settings, install Eastern Asia Fonts are the only requirement.
When you are making the car file, open it in notepad, and use UTF16_EncString to define your string. like below.
ModRsc {
--
name = "IDS_STRING_1001",
id = 1001,
type = 1, --RESTYPE_ENCSTRING (see AEEResType.h)
data = UTF16_EncString("eåg, Hello World"),

and when you do save as, select Encoding UTF-8 and Save As File type: All files
then use resource manager to build the .bar file from the .car file. use this .bar file, copy the .bar file you've just built to your project ->package->projectName, to overwrite the .bar file already there, then when you run this, you should see the fonts displayed correctly.

Hello, chunmeis
Thank you for your assistance.
I could not find any differences between your guide and my car file.
I think that there are other causes.
I described the summary of the trouble.
Only case 4 was an unexpected result.
-----------------------------------------------------------------------------
case 1)Japanese OS environment(Before removed two files)
ASCII font : OK, Japanse font: NG, Appl Launcher: OK
case 2)Japanese OS environment(After removed two files)
ASCII font : OK, Japanse font: OK, Appl Launcher: OK
case 3)EnglishOS+Japanese language Pack(Before removed two files)
ASCII font : OK, Japanse font: NG, Appl Launcher: OK
case 4)EnglishOS+Japanese language Pack(After removed two files)
ASCII font : NG, Japanse font: NG, Appl Launcher: NG
-----------------------------------------------------------------------------
I attached the screen shots of Appl Launcher.
Left:case3 Right:case4

Hello, chunmeis
Thank you for your assistance.
I could not find any differences between your guide and my car file.
I think that there are other causes.
I described the summary of the trouble.
Only case 4 was an unexpected result.
-----------------------------------------------------------------------------
case 1)Japanese OS environment(Before removed two files)
ASCII font : OK, Japanse font: NG, Appl Launcher: OK
case 2)Japanese OS environment(After removed two files)
ASCII font : OK, Japanse font: OK, Appl Launcher: OK
case 3)EnglishOS+Japanese language Pack(Before removed two files)
ASCII font : OK, Japanse font: NG, Appl Launcher: OK
case 4)EnglishOS+Japanese language Pack(After removed two files)
ASCII font : NG, Japanse font: NG, Appl Launcher: NG
-----------------------------------------------------------------------------
I attached the screen shots of Appl Launcher.
Left:case3 Right:case4

The Key here is when you save your .car file from note pad, you need to specify to use UTF-8 encoding. Also, you will need to set the IDS_DD_ENCODING = 0 (default value), of course you also need to remove the sysfont and hdksansfont from your target fs:/sys/mod. I have tested on English XP and windows 7, with platform 1.0.2.410 and 1.0.2.488 all works fine.

The Key here is when you save your .car file from note pad, you need to specify to use UTF-8 encoding. Also, you will need to set the IDS_DD_ENCODING = 0 (default value), of course you also need to remove the sysfont and hdksansfont from your target fs:/sys/mod. I have tested on English XP and windows 7, with platform 1.0.2.410 and 1.0.2.488 all works fine.

Have you changed the LANG settings in the settings.ini file in the \fs\sys\mod\simulator directory? the appManager problem looks like the LAN setting is changed. You should keep it the default value which is 538996325. Another question is What platform are you using? There is a font bug in 1.0.3.557, 1.0.3.587. You will need to use 1.0.3.639, the latest 1.0.3 platform. or you can use 1.0.2.410, 1.0.2.588 platforms.
thanks,

Have you changed the LANG settings in the settings.ini file in the \fs\sys\mod\simulator directory? the appManager problem looks like the LAN setting is changed. You should keep it the default value which is 538996325. Another question is What platform are you using? There is a font bug in 1.0.3.557, 1.0.3.587. You will need to use 1.0.3.639, the latest 1.0.3 platform. or you can use 1.0.2.410, 1.0.2.588 platforms.
thanks,

Hello, chunmeis
Thank you for your assistance.
I have used the platforms 1.0.2.431.
I could not find the recommended platforms , 1.0.3.639 , 1.0.2.410 and 1.0.2.588, in the BMP Downloads menu.
Please tell me how to get these platforms.
I have not changed the settings.ini file.
I confirmed that the value of LANG setting was 538996325.
Thank you.

Hello, chunmeis
Thank you for your assistance.
I have used the platforms 1.0.2.431.
I could not find the recommended platforms , 1.0.3.639 , 1.0.2.410 and 1.0.2.588, in the BMP Downloads menu.
Please tell me how to get these platforms.
I have not changed the settings.ini file.
I confirmed that the value of LANG setting was 538996325.
Thank you.

Hi Daiba,
You can find these platform in the following link
https://brewmobileplatform.qualcomm.com/devnet/summary_platform102_488.jsp
https://brewmobileplatform.qualcomm.com/devnet/summary_platform103s154_p...
You may not have access to the second link because it is a prokit, but the first should be available to you,. I had a typo for the 1.0.2 platform it should be 1.0.2.488 not 1.0.2.588(we don't have that).
Thanks,
Chunmei

Hi Daiba,
You can find these platform in the following link
https://brewmobileplatform.qualcomm.com/devnet/summary_platform102_488.jsp
https://brewmobileplatform.qualcomm.com/devnet/summary_platform103s154_p...
You may not have access to the second link because it is a prokit, but the first should be available to you,. I had a typo for the 1.0.2 platform it should be 1.0.2.488 not 1.0.2.588(we don't have that).
Thanks,
Chunmei

Hello, chunmeis
Thank you for your support.
The font trouble have been fixed by your assistances.
I think that the reason of trouble was the bug of platform 1.0.2.431.
I described the detail.
--------------------------------------------------------------------
[Environment]
EnglishOS(Windows XP)+Japanese language Pack
Toolset 7.8.0.1.1434704
Platform 1.0.2.488
[Procedure]
1)Install the paltform 1.0.2.488
2)Create the simulator target
3)Remove the two files from target
4)Run the Helloworld application including Japanese characters.
ASCII font OK
Japanese font: OK
Appl Launcher font : OK

Hello, chunmeis
Thank you for your support.
The font trouble have been fixed by your assistances.
I think that the reason of trouble was the bug of platform 1.0.2.431.
I described the detail.
--------------------------------------------------------------------
[Environment]
EnglishOS(Windows XP)+Japanese language Pack
Toolset 7.8.0.1.1434704
Platform 1.0.2.488
[Procedure]
1)Install the paltform 1.0.2.488
2)Create the simulator target
3)Remove the two files from target
4)Run the Helloworld application including Japanese characters.
ASCII font OK
Japanese font: OK
Appl Launcher font : OK