Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Hi,

I am trying to create mod file using Visual Studio 2008 for BREW MP application.

1.I have selected ARM built from the BREW MP settings->Options.
2.Select the "Physical"option as Target Type from the drop down menu of toolbar.
3.Click the Build option.

But got the following Error message .

Error:A make utility was not found. Please install cs-make.exe to compile for device builds.
If cs-make.exe has been installed, verify the make directory is included in the Path environment variable.

Please anybody knows what is the reason of this error?

Thanks,
Snehal

I think, ARM Compiler selection in Brew MP Options is codesourcery for you. Are you using codesourcery compiler? If not, Please select the proper compiler.
Go to BrewMP settings (Toolbar)->options->Brew MP->ARM Build->ARM Compiler and select the proper compiler.
If you want to compile using codesourcery: Set the path of cs-make.exe in environment variables (PATH). cs-make is part of the Code Sourcery distribution. Please double-check that you have installed the Code Sourcery package from http://www.codesourcery.com/sgpp/lite/arm/portal/release1033.
Also, please double-check the other pre-requisites listed on the SDK Download page:
https://brewmobileplatform.qualcomm.com/devnet/multiplatform_sdk.jsp

I think, ARM Compiler selection in Brew MP Options is codesourcery for you. Are you using codesourcery compiler? If not, Please select the proper compiler.
Go to BrewMP settings (Toolbar)->options->Brew MP->ARM Build->ARM Compiler and select the proper compiler.
If you want to compile using codesourcery: Set the path of cs-make.exe in environment variables (PATH). cs-make is part of the Code Sourcery distribution. Please double-check that you have installed the Code Sourcery package from http://www.codesourcery.com/sgpp/lite/arm/portal/release1033.
Also, please double-check the other pre-requisites listed on the SDK Download page:
https://brewmobileplatform.qualcomm.com/devnet/multiplatform_sdk.jsp

It worked...Thanks!!!!

It worked...Thanks!!!!