Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

Is there a way to display .gif images on the t720?

T720 supports GIF and you can load them either using ISHEL_LoadResImage or ISHELL_LoadImage API. Its same as loading BMP images. What exactly is your problem? If images r not loading, check the color depth or compression of the images.
Regards
Arun Bangari

T720 supports GIF and you can load them either using ISHEL_LoadResImage or ISHELL_LoadImage API. Its same as loading BMP images. What exactly is your problem? If images r not loading, check the color depth or compression of the images.
Regards
Arun Bangari

Hi
Are you sure about this? I checked the Data Sheet for the T720 and it said nothing about gif. I tried them on the emulator and they dont work.
Thanks

Hi
Are you sure about this? I checked the Data Sheet for the T720 and it said nothing about gif. I tried them on the emulator and they dont work.
Thanks

GIF doesn't woks on emulator, but they do on t720
try to compile your project and if you're are doing it correctly it will work
fine
[]'s
Marcel

GIF doesn't woks on emulator, but they do on t720
try to compile your project and if you're are doing it correctly it will work
fine
[]'s
Marcel

You Guys are so right. I did the same test on my T720 and it works! but not in the emulator... weird, isn't it?

You Guys are so right. I did the same test on my T720 and it works! but not in the emulator... weird, isn't it?

Not so weird if you think that the emulator doesn't support the format... It doesn't even support images with more than 256 colors... :D
I think it returns NULL when you use ISHELL_LoadResImage with a gif... If you check it before displaying it I guess it wouldn't pose too big a problem in the emulator.

Not so weird if you think that the emulator doesn't support the format... It doesn't even support images with more than 256 colors... :D
I think it returns NULL when you use ISHELL_LoadResImage with a gif... If you check it before displaying it I guess it wouldn't pose too big a problem in the emulator.

You would need a gif viewer extension to make it work in the Simulator. It is shipped by default with the uiOne SDK, but unfortunately not with BREW SDk..take the one from UIOne sdk, then it should work.

You would need a gif viewer extension to make it work in the Simulator. It is shipped by default with the uiOne SDK, but unfortunately not with BREW SDk..take the one from UIOne sdk, then it should work.