Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

hi frds,

I have a handset coolpad which has buiw 1.1.4.
But my application is built using buiw 2.0.1

I have created the my application mod and when i load the revelant files in the handset and try to run the application, the handset just reboots.

I have heard that we need to place the forms and widgets mod and mif file into the handset if the handset does not support buiw.
But when i load the forms and widgets files to the handset, the handset does not boot up.
can someone tell me how can i achieve the desired behaviour

Thanks
Viral

what is the Brew version of the handset?
BREW UI Widgets 2.0.1 requires BREW SDK v3.1.2 and greater and v3.1.4 with FP02 for Touchscreen.

what is the Brew version of the handset?
BREW UI Widgets 2.0.1 requires BREW SDK v3.1.2 and greater and v3.1.4 with FP02 for Touchscreen.

hey thanks for the prompt reply.
the handset has brew 3.1.5

hey thanks for the prompt reply.
the handset has brew 3.1.5

on further search in the forun, i found that
either we need to build widgets and forms again
or include the buiw source files to our project and call _Ctor() in place of ishell_create instance.
can someone throw some light, has done this successfully.

on further search in the forun, i found that
either we need to build widgets and forms again
or include the buiw source files to our project and call _Ctor() in place of ishell_create instance.
can someone throw some light, has done this successfully.

some more updates
I tried loading the same mod to the different handset,
The application does not crash, but it does not show the widgets (text box and static text) as well
just the form and the softkeys are visible
any clue on this one ?

some more updates
I tried loading the same mod to the different handset,
The application does not crash, but it does not show the widgets (text box and static text) as well
just the form and the softkeys are visible
any clue on this one ?