Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

I am testing a Brew program in the emulator on my PC, running it against a local web server (IIS). Both the emulator and the web server are running in Visual Studio debuggers (two debuggers). The problem is that the IIS Web Server only accepts connections from the loopback address. From a browser, http://127.0.0.1 works, but http://192.168.1.68 (my DHCP address) does not.

However, if I use the Loopback address (127.0.0.1) in my emulator (to connect to the web server), it thinks it's trying to connect to the phone. If I use the LAN IP address (192.168.1.68) the debug web server refuses the connection.

I have looked at MSFT KB89861 ([url]http://support.microsoft.com/kb/896861)[/url], but this has not solved my problem, although I believe it's related. I don't have IIS configured to run in general on my PC, only within Visual Studio. I suspect there is a configuration change I need to make through Visual Studio.

I need to be able to debug both client (phone) and server (web server). The phone needs to connect to the web server and I don't think I can tell BREW emulator to pass the Loopback address out to the PC (can I?). I can't figure out how to reconfigure Visual Studio settings so that IIS serves "network" requests.

Has anyone else encountered this problem? Has anyone solved this problem?

Thanks,

Andy

PS: This message is cross-posted to the MSDN Forums: http://forums.microsoft.com/MSDN/AddPost.aspx?ForumID=56&SiteID=1

Here's the answer I recv'd in the MSFT Forum.
-------------------------
It sounds like you might not actually be using IIS, but rather Cassini - the built in web server for Visual Studio testing. Cassini only supports 127.0.0.1
If that is the case, you could install IIS, and then create an HTTP based Web Service. Once you have IIS installed, go to projects | New Web Site.
On the dialog that comes up pick ASP.NET Web Service, and for Location, make sure you specify HTTP.
For more information, see the following MSDN article:
http://msdn2.microsoft.com/en-us/library/33ch9sfb.aspx

Here's the answer I recv'd in the MSFT Forum.
-------------------------
It sounds like you might not actually be using IIS, but rather Cassini - the built in web server for Visual Studio testing. Cassini only supports 127.0.0.1
If that is the case, you could install IIS, and then create an HTTP based Web Service. Once you have IIS installed, go to projects | New Web Site.
On the dialog that comes up pick ASP.NET Web Service, and for Location, make sure you specify HTTP.
For more information, see the following MSDN article:
http://msdn2.microsoft.com/en-us/library/33ch9sfb.aspx