Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

Hello Friends,
I am new to this API. I used following code.

INETMGR_GetHostByName(pMe->pINetMgr,&pMe->result,"www.msn.com",&(pMe->pCB));

I am getting Proper IP Address, Its working fine on Emulator.

But, on Hand set its giving 0.0.0.0

are there any other setting to be done so that it works.

Thanks a Lot.

Sujit :)

Please make sure that you have PPP connection established before using this API function and in 2.x devices (and emulator), you have to bind socket first in order to establish a PPP connection.

Please make sure that you have PPP connection established before using this API function and in 2.x devices (and emulator), you have to bind socket first in order to establish a PPP connection.

Thanks a lot Swapnil.
I will try out your suggestion and let u know.
Thanks again.
Sujit. :)

Thanks a lot Swapnil.
I will try out your suggestion and let u know.
Thanks again.
Sujit. :)

https://brewx.qualcomm.com/brew/sdk/download.jsp?page=appseng/en/develop...
All the general issues with Network programming is listed in here.

https://brewx.qualcomm.com/brew/sdk/download.jsp?page=appseng/en/develop...
All the general issues with Network programming is listed in here.

Thanks,
Its really very helpFul Information.
i am still working over it.
Thanks a lot.
Sujit :)

Thanks,
Its really very helpFul Information.
i am still working over it.
Thanks a lot.
Sujit :)

:confused: can someone tell me how long is the timeout before the callback in INETMGT_GetHostByName is called after calling INETMGT_GetHostByName

:confused: can someone tell me how long is the timeout before the callback in INETMGT_GetHostByName is called after calling INETMGT_GetHostByName

swapnilp wrote:Please make sure that you have PPP connection established before using this API function and in 2.x devices (and emulator), you have to bind socket first in order to establish a PPP connection.
Hi Swapnil,
I have a similar problem:
I am trying to do a DNS query but the network is in NET_PPP_CLOSED state.
From what I understand, you advised to "bind a socket first".
1. Could you please attach a code snippet?
2. Is this a workaround or actually the proper thing to do?
(BTW, I am using BREW 3.1)
Thanks!

swapnilp wrote:Please make sure that you have PPP connection established before using this API function and in 2.x devices (and emulator), you have to bind socket first in order to establish a PPP connection.
Hi Swapnil,
I have a similar problem:
I am trying to do a DNS query but the network is in NET_PPP_CLOSED state.
From what I understand, you advised to "bind a socket first".
1. Could you please attach a code snippet?
2. Is this a workaround or actually the proper thing to do?
(BTW, I am using BREW 3.1)
Thanks!