Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

I'm having a problem with the ISoundPlayer on the Motorola V60x. When the soundplayer is playing the AEE_SOUNDPLAYER_DONE callback is sent if an arrow key is pressed, or anyother key for that matter. Where is this event coming from? It doesn't behave in this manner on the emulator. So, it's hard to track down exactly whats happening. But it is definitely getting sent in the soundplayer callback function, not the regular event loop.
If anyone has advice, I'd appreciate it.

thanks

Ok,
So, I think this happens because the v60x has only one sound channel, and it wants to play the beep sound for the keypress, so it forces the currently playing sound to finish. The question remains, How can I override this behaviour? Is there any way to suppress the keybeeping?
thanks

Ok,
So, I think this happens because the v60x has only one sound channel, and it wants to play the beep sound for the keypress, so it forces the currently playing sound to finish. The question remains, How can I override this behaviour? Is there any way to suppress the keybeeping?
thanks

I do not have a solution for you, but I have seen this same behavior on the C343 as well.

I do not have a solution for you, but I have seen this same behavior on the C343 as well.

Can anyone tell me whether other handsets, particularly the
motorola v810 and e310, exhibit this behaviour?
-geoff

Can anyone tell me whether other handsets, particularly the
motorola v810 and e310, exhibit this behaviour?
-geoff

Hello,
Im having this issue with the C343. Has anyone found a solution to this?
All help and possible workaround solutions that you might have will be highly appreciated.
Jaakko

Hello,
Im having this issue with the C343. Has anyone found a solution to this?
All help and possible workaround solutions that you might have will be highly appreciated.
Jaakko