Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

In motorola razr V3C, if we start the applet through ishell_startapplet( ), if we are outside the application at mobileshop screen....its starting the app.

But i come outside from mobileshop at handset main screen, its throwing "Unable to start the app" first then starting the app.
I tried but still not able to resolve it.....

Did anybody get the same (Device known issue) or problem with the application?

Please reply....or anything related to starting applet...?

It is very likely OEM is blocking to start the application. Before you start the application, try calling ISHELL_CanStartApplet and see what is the return value.

It is very likely OEM is blocking to start the application. Before you start the application, try calling ISHELL_CanStartApplet and see what is the return value.

ruben wrote:It is very likely OEM is blocking to start the application. Before you start the application, try calling ISHELL_CanStartApplet and see what is the return value.
Hi Ruben,
I tried that one, its returning False. Then i put a timer for the starting applet if its returning false. But after that also while Starting the applet later it showing same "unable to start the app".
Ishell_startapplet( ) is returning 6 there.

ruben wrote:It is very likely OEM is blocking to start the application. Before you start the application, try calling ISHELL_CanStartApplet and see what is the return value.
Hi Ruben,
I tried that one, its returning False. Then i put a timer for the starting applet if its returning false. But after that also while Starting the applet later it showing same "unable to start the app".
Ishell_startapplet( ) is returning 6 there.

Look into the debug logs. Enable BREW debug sequence and it will tell you the error code for Starting the app.
I had an issue with sig file on the RAZR. actually the razr date was set improperly and Signature testign uses the handset date for verification. I changed it to the correct date and the app is now working.

Look into the debug logs. Enable BREW debug sequence and it will tell you the error code for Starting the app.
I had an issue with sig file on the RAZR. actually the razr date was set improperly and Signature testign uses the handset date for verification. I changed it to the correct date and the app is now working.

HI Ash...
thanks for ur reply...application is starting, my application is actually alert application on receiving new message(or mail). What i am doing is
if we r outside the appllication, calling ishell_startapplet( ), if i close the application and then if i wait for the alert while on mobileshop screen (catalog) its working fine its starting and showing alert.
Problem is there if i am outside of app catalog (mobile shop), on phone first screen. Now its showing unable to start app first, then after 2-3 secs starting app and showing alert. its happening with razr but on other device, its not able to start at all.
Not the problem with Date i guess.

HI Ash...
thanks for ur reply...application is starting, my application is actually alert application on receiving new message(or mail). What i am doing is
if we r outside the appllication, calling ishell_startapplet( ), if i close the application and then if i wait for the alert while on mobileshop screen (catalog) its working fine its starting and showing alert.
Problem is there if i am outside of app catalog (mobile shop), on phone first screen. Now its showing unable to start app first, then after 2-3 secs starting app and showing alert. its happening with razr but on other device, its not able to start at all.
Not the problem with Date i guess.

Hi all...
Can you tell the conditions when any application is unable to start?
or restricted by OEM to start the app.

Hi all...
Can you tell the conditions when any application is unable to start?
or restricted by OEM to start the app.