Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Can't get the LG7000 going with the 2.1 apploader, if the phones plugged in via usb and apploader is run, apploader crashes, if you run apploader then plug the phone in, it crashes..

AppLoader tries to print out an error message via the afx message box about qcomem.dll or whatever its called not being able to be loadded, and since the app either has already shutdown or not initialized , the error message routine in apploader fails, some sort of irony.

only one person i know (vexxed) has it running, i just tried it on a virgin install and it does the same thing, we've tried about 9 systems so far, same results.

oh well i dont care anymore 3.0.0 apploader works, nice timing there ;)

oh well i dont care anymore 3.0.0 apploader works, nice timing there ;)

charliex wrote:Can't get the LG7000 going with the 2.1 apploader, if the phones plugged in via usb and apploader is run, apploader crashes, if you run apploader then plug the phone in, it crashes..
AppLoader tries to print out an error message via the afx message box about qcomem.dll or whatever its called not being able to be loadded, and since the app either has already shutdown or not initialized , the error message routine in apploader fails, some sort of irony.
only one person i know (vexxed) has it running, i just tried it on a virgin install and it does the same thing, we've tried about 9 systems so far, same results.
I just used it today with the 2.1 apploader at the lab with no problem.
Nice, fast phone with a huge screen size.

charliex wrote:Can't get the LG7000 going with the 2.1 apploader, if the phones plugged in via usb and apploader is run, apploader crashes, if you run apploader then plug the phone in, it crashes..
AppLoader tries to print out an error message via the afx message box about qcomem.dll or whatever its called not being able to be loadded, and since the app either has already shutdown or not initialized , the error message routine in apploader fails, some sort of irony.
only one person i know (vexxed) has it running, i just tried it on a virgin install and it does the same thing, we've tried about 9 systems so far, same results.
I just used it today with the 2.1 apploader at the lab with no problem.
Nice, fast phone with a huge screen size.

yeah i dont know what the lucky charm is, but we get the same effect on every system everytime
it does appear to be a decent phone though

yeah i dont know what the lucky charm is, but we get the same effect on every system everytime
it does appear to be a decent phone though

charliex wrote:yeah i dont know what the lucky charm is, but we get the same effect on every system everytime
it does appear to be a decent phone though
I did notice today, that there seems to be an issue with IGraphics on the 7000 emulator, though. At certain screen positions the graphics get compressed as some of the horizontal scan lines are not drawn. This does not appear to be the case with BitBlt - only with primitives like triangle and circle.

charliex wrote:yeah i dont know what the lucky charm is, but we get the same effect on every system everytime
it does appear to be a decent phone though
I did notice today, that there seems to be an issue with IGraphics on the 7000 emulator, though. At certain screen positions the graphics get compressed as some of the horizontal scan lines are not drawn. This does not appear to be the case with BitBlt - only with primitives like triangle and circle.

The size of the output window size in the emulator is wrong so your 176x203 screen is scaled down .. this causes all kinds of graphic problems. You can fix the skin in the device configurator and get rid of this problem.
I fail to understand why Qualcomm does this ... there's a LOT of skins out there with the wrong output sizes, and even some with the wrong sizes in general (don't match the actual device). It's easy enough to fix, but it seems like a silly thing to get wrong. I cacn understand the fonts being wrong .. that's a lot of work to get right, but getting something as basic as the size of the display right shouldn't be so hard.
Tom

The size of the output window size in the emulator is wrong so your 176x203 screen is scaled down .. this causes all kinds of graphic problems. You can fix the skin in the device configurator and get rid of this problem.
I fail to understand why Qualcomm does this ... there's a LOT of skins out there with the wrong output sizes, and even some with the wrong sizes in general (don't match the actual device). It's easy enough to fix, but it seems like a silly thing to get wrong. I cacn understand the fonts being wrong .. that's a lot of work to get right, but getting something as basic as the size of the display right shouldn't be so hard.
Tom

Vexxed wrote:The size of the output window size in the emulator is wrong so your 176x203 screen is scaled down .. this causes all kinds of graphic problems. You can fix the skin in the device configurator and get rid of this problem.
I fail to understand why Qualcomm does this ... there's a LOT of skins out there with the wrong output sizes, and even some with the wrong sizes in general (don't match the actual device). It's easy enough to fix, but it seems like a silly thing to get wrong. I cacn understand the fonts being wrong .. that's a lot of work to get right, but getting something as basic as the size of the display right shouldn't be so hard.
Tom
Yup that did the trick. After playing with it a bit, I think it has more to do with shoving the screen size into the digital picture. (The reason they scaled it down).

Vexxed wrote:The size of the output window size in the emulator is wrong so your 176x203 screen is scaled down .. this causes all kinds of graphic problems. You can fix the skin in the device configurator and get rid of this problem.
I fail to understand why Qualcomm does this ... there's a LOT of skins out there with the wrong output sizes, and even some with the wrong sizes in general (don't match the actual device). It's easy enough to fix, but it seems like a silly thing to get wrong. I cacn understand the fonts being wrong .. that's a lot of work to get right, but getting something as basic as the size of the display right shouldn't be so hard.
Tom
Yup that did the trick. After playing with it a bit, I think it has more to do with shoving the screen size into the digital picture. (The reason they scaled it down).

jmiller2 wrote:Yup that did the trick. After playing with it a bit, I think it has more to do with shoving the screen size into the digital picture. (The reason they scaled it down).
Of course ... but is really that difficult to rescale the digital picture so the area for the screen is the proper size? In any case, the errors are usually small enough that just changing them without rescaling ends up working reasonably well.
Tom

jmiller2 wrote:Yup that did the trick. After playing with it a bit, I think it has more to do with shoving the screen size into the digital picture. (The reason they scaled it down).
Of course ... but is really that difficult to rescale the digital picture so the area for the screen is the proper size? In any case, the errors are usually small enough that just changing them without rescaling ends up working reasonably well.
Tom

yeah talk about form over function.
i think they should get the fonts right as well as the screen size, its not that difficult, and its only once per skin.

yeah talk about form over function.
i think they should get the fonts right as well as the screen size, its not that difficult, and its only once per skin.

OEM is responsible for providing the skin. :)

OEM is responsible for providing the skin. :)

i sense a cop out ;)

i sense a cop out ;)

I am able to put an application on the 7000. I am using the serial cable and app loader 2.1.0. After installing the application, however, I cannot find its icon in the phone's UI in order to launch the application. I have powered cycled the phone (many times.)
Since the application is not deleted when the phone is power cycled I am assuming this is evidence that the phone is indeed test enabled. (We got the phone from one of our partners who say the phone has been test enabled, but I did not do this myself, so I have not dismissed this possibility entirely.)
There are no other applications on this phone, so I cannot see any application icons.
Does anybody have any ideas about what I might be doing wrong? How can I find the application's icon and launch it?
Rob

I am able to put an application on the 7000. I am using the serial cable and app loader 2.1.0. After installing the application, however, I cannot find its icon in the phone's UI in order to launch the application. I have powered cycled the phone (many times.)
Since the application is not deleted when the phone is power cycled I am assuming this is evidence that the phone is indeed test enabled. (We got the phone from one of our partners who say the phone has been test enabled, but I did not do this myself, so I have not dismissed this possibility entirely.)
There are no other applications on this phone, so I cannot see any application icons.
Does anybody have any ideas about what I might be doing wrong? How can I find the application's icon and launch it?
Rob

what are you using for the icons in the mif file? i think its recommended to use bitmaps for these images.
just a guess.
-Tyndal

what are you using for the icons in the mif file? i think its recommended to use bitmaps for these images.
just a guess.
-Tyndal

You need to assign a category in the MIF that matches up with the OEM's defined categories...for example, Game.

You need to assign a category in the MIF that matches up with the OEM's defined categories...for example, Game.

Thanks, setting the category to Game added the application to the "Fun and Games" category.
I never saw the icon, only the name of the application in text - does this phone never use icons to display applications?
My application is a ringtone application, but I do not see a category in the MIF Editor for "Ringtones" or anything like that (MIF Editor 2.0.1.5). Is there a category setting that I can choose that will cause the application to appear in the "Get Tunes and Tones" menu? Does the MIF that we submit to NSTL have to have the same category as where we want the applicatino to appear, or might this category be changed by someone further down the chain (such as the carrier)?
What about applications that we would like to see under "Get News and Info"? This launches the browser - does this mean that no Brew application can appear under this menu?
And finally, what category would we choose if we wanted the application to appear under "Get Going"?
Rob

Thanks, setting the category to Game added the application to the "Fun and Games" category.
I never saw the icon, only the name of the application in text - does this phone never use icons to display applications?
My application is a ringtone application, but I do not see a category in the MIF Editor for "Ringtones" or anything like that (MIF Editor 2.0.1.5). Is there a category setting that I can choose that will cause the application to appear in the "Get Tunes and Tones" menu? Does the MIF that we submit to NSTL have to have the same category as where we want the applicatino to appear, or might this category be changed by someone further down the chain (such as the carrier)?
What about applications that we would like to see under "Get News and Info"? This launches the browser - does this mean that no Brew application can appear under this menu?
And finally, what category would we choose if we wanted the application to appear under "Get Going"?
Rob

I don't belive this device uses icons for the Get It Now menus, but you will need to check the manual for available configuration options to be sure.
The category in which an application will be found is determined by the carrier when building the catalog. When the application is downloaded over the air it will be placed in the appropriate category in the UI irrespective of the MIF settings.
On this device Get News & info is used only for the browser.
Below is a list matching Applet Type to Get It Now category.
Tool = Get Tunes & Tones (Menu -> Get It Now -> Get Tunes & Tones -> Get New)
PIM = Get Pix & Flix (Menu -> Get It Now -> Get Pix & Flix -> Get New)
Game = Get Fun & Games (Menu -> Get It Now -> Get Fun & Games)
Web = App will be displayed in the Message menu ("Message" Soft Key -> Mobile IM)
If the "Phone " Flag is set in the MIF (MIF Editor 2.1 onwards) the application will show up under Get Going (Menu -> Get It Now -> Get Going). When submitting the application for TBT, however, please ensure the "Phone" flag is not set.

I don't belive this device uses icons for the Get It Now menus, but you will need to check the manual for available configuration options to be sure.
The category in which an application will be found is determined by the carrier when building the catalog. When the application is downloaded over the air it will be placed in the appropriate category in the UI irrespective of the MIF settings.
On this device Get News & info is used only for the browser.
Below is a list matching Applet Type to Get It Now category.
Tool = Get Tunes & Tones (Menu -> Get It Now -> Get Tunes & Tones -> Get New)
PIM = Get Pix & Flix (Menu -> Get It Now -> Get Pix & Flix -> Get New)
Game = Get Fun & Games (Menu -> Get It Now -> Get Fun & Games)
Web = App will be displayed in the Message menu ("Message" Soft Key -> Mobile IM)
If the "Phone " Flag is set in the MIF (MIF Editor 2.1 onwards) the application will show up under Get Going (Menu -> Get It Now -> Get Going). When submitting the application for TBT, however, please ensure the "Phone" flag is not set.

Hi,
Sorry for the off-topic post. Does the LG VX6000 USB data cable work for the LG VX7000? If not, where can I get the LG VX7000 data cable? Verizon does not have it yet.
Thanks,
Mamata

Hi,
Sorry for the off-topic post. Does the LG VX6000 USB data cable work for the LG VX7000? If not, where can I get the LG VX7000 data cable? Verizon does not have it yet.
Thanks,
Mamata

No, they have different plugs.

No, they have different plugs.

This website claims they sell one single USB data cable for both phones. Phony?
http://store.yahoo.com/mynetdeals/lg-vx-6000-usb-data-cable.html
--Mamata

This website claims they sell one single USB data cable for both phones. Phony?
http://store.yahoo.com/mynetdeals/lg-vx-6000-usb-data-cable.html
--Mamata

Most likely. Like Max said, the plug into the 7000 is a different shape than for the 6000. So unless they've got a cable with two heads (and judging by the picture, they don't), its phony.

Most likely. Like Max said, the plug into the 7000 is a different shape than for the 6000. So unless they've got a cable with two heads (and judging by the picture, they don't), its phony.

Found the serial cable for LG 7000 at:
http://www.buywirelessnow.com/lg/PhoneAccessories.asp?phone=LG+VX7000
Thanks,
Mamata

Found the serial cable for LG 7000 at:
http://www.buywirelessnow.com/lg/PhoneAccessories.asp?phone=LG+VX7000
Thanks,
Mamata

Oh, these guys are back-ordered till August end!!
Can anyone please tell me where they got their LG 7000 data cable from??
Thanks in advance :-)
--Mamata

Oh, these guys are back-ordered till August end!!
Can anyone please tell me where they got their LG 7000 data cable from??
Thanks in advance :-)
--Mamata

We just use the SE47 serial cable (which doesn't help if you don't have it, but...)

We just use the SE47 serial cable (which doesn't help if you don't have it, but...)

Erm I just found and ordered it on Verizon's website. I had the SE47 :(
Thanks anyways.
--Mamata

Erm I just found and ordered it on Verizon's website. I had the SE47 :(
Thanks anyways.
--Mamata

Mamata, I am looking for the same cable for vx7000. Are you saying that Kyocera's SE47 cable will fit LG's vx7000? Is it serial or USB?
Thanks for help

Mamata, I am looking for the same cable for vx7000. Are you saying that Kyocera's SE47 cable will fit LG's vx7000? Is it serial or USB?
Thanks for help

No, it will not fit.

No, it will not fit.

Is there a way to get a connector and pinout to build it ourselves?
--Rogi

Is there a way to get a connector and pinout to build it ourselves?
--Rogi

I'm not aware of any way that you would be able to obtain the required materials, and such a contraption would definitely not be supported by Qualcomm.

I'm not aware of any way that you would be able to obtain the required materials, and such a contraption would definitely not be supported by Qualcomm.

mohlendo wrote:No, it will not fit.
Oddly enough, it seems to for ours. Don't have it with me, but we might have a non-production model that isn't standard, i suppose.
Edit: Er, assuming that it's the vx7000 that we're talking about-it seems to have always just been the lg7000, so i'll clarify.

mohlendo wrote:No, it will not fit.
Oddly enough, it seems to for ours. Don't have it with me, but we might have a non-production model that isn't standard, i suppose.
Edit: Er, assuming that it's the vx7000 that we're talking about-it seems to have always just been the lg7000, so i'll clarify.

Hi,
I've got a production model VX7000 right here, and the SE47 cable (which uses the same connector as the VX6000/4500/4600 cable) definately does NOT fit.
As far as I know, no cable will fit the VX7000/8000 except cables made for the VX7000/8000.

Hi,
I've got a production model VX7000 right here, and the SE47 cable (which uses the same connector as the VX6000/4500/4600 cable) definately does NOT fit.
As far as I know, no cable will fit the VX7000/8000 except cables made for the VX7000/8000.

Guess ours is one of the early/prototype-ish ones then.

Guess ours is one of the early/prototype-ish ones then.

the se47 cables do work on the lg7000, i'm using one right now, with the 7000s i've had for months and the ones from the store (same interface)
yes with apploader too

the se47 cables do work on the lg7000, i'm using one right now, with the 7000s i've had for months and the ones from the store (same interface)
yes with apploader too

It appears that the data pinouts for the 7000 data cable are the same as the 6000. I think the connector was changed because of differences in charging current. The only physical change was to the bumps on one side of the cable housing that prevent it from fitting.

It appears that the data pinouts for the 7000 data cable are the same as the 6000. I think the connector was changed because of differences in charging current. The only physical change was to the bumps on one side of the cable housing that prevent it from fitting.

Yeah, I guess if you jam the cable in there it seems to work...I've always been reticent to force things into places they don't fit. :o
Just to be safe, I can't recommend using this cable.

Yeah, I guess if you jam the cable in there it seems to work...I've always been reticent to force things into places they don't fit. :o
Just to be safe, I can't recommend using this cable.

you'd be a lot less reluctant if you had products to ship while trying to find cables ;)
its usb so its the same specifications for the electrical connection, charging also works, the voltage is the same, usb draw current is fixed anyway.
i rarely use the wall chargers anyway, so i can't say one way or the other.

you'd be a lot less reluctant if you had products to ship while trying to find cables ;)
its usb so its the same specifications for the electrical connection, charging also works, the voltage is the same, usb draw current is fixed anyway.
i rarely use the wall chargers anyway, so i can't say one way or the other.

Verizon has "Mobile Office Kits" with cables + drivers: http://www.verizonwireless.com/b2b/ewelcome

Verizon has "Mobile Office Kits" with cables + drivers: http://www.verizonwireless.com/b2b/ewelcome

nparrish wrote:Hi,
I've got a production model VX7000 right here, and the SE47 cable (which uses the same connector as the VX6000/4500/4600 cable) definately does NOT fit.
As far as I know, no cable will fit the VX7000/8000 except cables made for the VX7000/8000.
FWIW,
I download into the VX7000 using the same USB cable I use for the VX4400, VX4500, VX4600, and VX6000. The fit is on the snug side, but it does fit and it does definitely work.

nparrish wrote:Hi,
I've got a production model VX7000 right here, and the SE47 cable (which uses the same connector as the VX6000/4500/4600 cable) definately does NOT fit.
As far as I know, no cable will fit the VX7000/8000 except cables made for the VX7000/8000.
FWIW,
I download into the VX7000 using the same USB cable I use for the VX4400, VX4500, VX4600, and VX6000. The fit is on the snug side, but it does fit and it does definitely work.

mohlendo wrote:Yeah, I guess if you jam the cable in there it seems to work...I've always been reticent to force things into places they don't fit. :o
"If it doesn't fit, force it. If it still doesn't fit, use a bigger hammer." -Anonymous
-Erik

mohlendo wrote:Yeah, I guess if you jam the cable in there it seems to work...I've always been reticent to force things into places they don't fit. :o
"If it doesn't fit, force it. If it still doesn't fit, use a bigger hammer." -Anonymous
-Erik

Hey Rob,
I saw you used a serial cable for LG 7000. Where did you get the cable? Do you know if any of the existing cables work with this handset?
Thanks
Vasanth

Hey Rob,
I saw you used a serial cable for LG 7000. Where did you get the cable? Do you know if any of the existing cables work with this handset?
Thanks
Vasanth

Never Mind.
Lucky me! LG 6000 serial cable actually works with 7000.
Someone at LG must have forgotten that that particaulr cable combo is already used! :p
-Vasanth

Never Mind.
Lucky me! LG 6000 serial cable actually works with 7000.
Someone at LG must have forgotten that that particaulr cable combo is already used! :p
-Vasanth

BryanCoe wrote:If the "Phone " Flag is set in the MIF (MIF Editor 2.1 onwards) the application will show up under Get Going (Menu -> Get It Now -> Get Going). When submitting the application for TBT, however, please ensure the "Phone" flag is not set.
Do I need to do anything else specific to make the application appear under "Get Going" apart from setting the Phone flag? My application type has been set as "Tools" with a Phone flag, and it shows up under "Get Fun & Games". Please help...
Thanks,
Mamata

BryanCoe wrote:If the "Phone " Flag is set in the MIF (MIF Editor 2.1 onwards) the application will show up under Get Going (Menu -> Get It Now -> Get Going). When submitting the application for TBT, however, please ensure the "Phone" flag is not set.
Do I need to do anything else specific to make the application appear under "Get Going" apart from setting the Phone flag? My application type has been set as "Tools" with a Phone flag, and it shows up under "Get Fun & Games". Please help...
Thanks,
Mamata

BryanCoe wrote:
The category in which an application will be found is determined by the carrier when building the catalog. When the application is downloaded over the air it will be placed in the appropriate category in the UI irrespective of the MIF settings.
These settings will only apply to cable-loaded apps for local testing. I don't see how it matters where the apps show up for testing purposes.

BryanCoe wrote:
The category in which an application will be found is determined by the carrier when building the catalog. When the application is downloaded over the air it will be placed in the appropriate category in the UI irrespective of the MIF settings.
These settings will only apply to cable-loaded apps for local testing. I don't see how it matters where the apps show up for testing purposes.

Max,
Mamata's question is very valid.
First of all, there was no documentation about this abnormality. If we used the normal procedures to load our app to the handset, we could not see our app in the normal place.
Also, we don’t know that these settings will only apply to the cable-loaded apps for local testing. At least its not documented.
We trust what you are saying here. But NSTL is probably going to fail us if set wrong settings. We are not sure what kind of settings we need to have in the MIF files. It would be good to have such information available and documented.
so to answer you question, it matters duing NSTL testing.
I could not set the "Phone" flag as you and Ruben suggested. When I did that, while saving the MIF file, I got the following error message saying
[INDENT]One or more applets in this module have enabled "phone applet" Option. This option is useless the module has ALL privilege levels. Please go to "Advanced Applet" dialog and disable the "Phone Applet" option for the applets.[/INDENT]
I am guessing that it talking about the privilege levels in the General tab. So, I set all privilege levels but continued to get above error.
In my case, I finally got my application to see in the Get it now catalog by setting Applet Type as "Game" in the Applets tab. But, I know that this is not the right thing to do. But at least I can see my app for now.
Now that all my rant is out of my chest :mad: , I feel much better! :D
Thanks for your thought and help in advance.
Regards,
Vasanth

Max,
Mamata's question is very valid.
First of all, there was no documentation about this abnormality. If we used the normal procedures to load our app to the handset, we could not see our app in the normal place.
Also, we don’t know that these settings will only apply to the cable-loaded apps for local testing. At least its not documented.
We trust what you are saying here. But NSTL is probably going to fail us if set wrong settings. We are not sure what kind of settings we need to have in the MIF files. It would be good to have such information available and documented.
so to answer you question, it matters duing NSTL testing.
I could not set the "Phone" flag as you and Ruben suggested. When I did that, while saving the MIF file, I got the following error message saying
[INDENT]One or more applets in this module have enabled "phone applet" Option. This option is useless the module has ALL privilege levels. Please go to "Advanced Applet" dialog and disable the "Phone Applet" option for the applets.[/INDENT]
I am guessing that it talking about the privilege levels in the General tab. So, I set all privilege levels but continued to get above error.
In my case, I finally got my application to see in the Get it now catalog by setting Applet Type as "Game" in the Applets tab. But, I know that this is not the right thing to do. But at least I can see my app for now.
Now that all my rant is out of my chest :mad: , I feel much better! :D
Thanks for your thought and help in advance.
Regards,
Vasanth

mohlendo wrote:These settings will only apply to cable-loaded apps for local testing. I don't see how it matters where the apps show up for testing purposes.
Hi,
It matters to our client that the apps show up in the "Get Going" channel, now during initial testing. Also, I am cable loading. Can you specify how to get my app to show up under "Get Going"?
Thanks,
Mamata

mohlendo wrote:These settings will only apply to cable-loaded apps for local testing. I don't see how it matters where the apps show up for testing purposes.
Hi,
It matters to our client that the apps show up in the "Get Going" channel, now during initial testing. Also, I am cable loading. Can you specify how to get my app to show up under "Get Going"?
Thanks,
Mamata

mohlendo wrote:These settings will only apply to cable-loaded apps for local testing. I don't see how it matters where the apps show up for testing purposes.
You can't set the shortcut key to Get Fun & Games on a VX7000. Having my app show up in Get Going would save me a keystroke every time I launch it.
:D
-Erik

mohlendo wrote:These settings will only apply to cable-loaded apps for local testing. I don't see how it matters where the apps show up for testing purposes.
You can't set the shortcut key to Get Fun & Games on a VX7000. Having my app show up in Get Going would save me a keystroke every time I launch it.
:D
-Erik

Hi all,
To answer all of your question, I have both LG VX6000 and VX7000.
Out of curiousity, I took my risk and plug in my USB cable from my VX6000 to my VX7000 and guess what? IT WORK!!
You will need to force fit it a bit since the shaped on the bottom of the connector are a bit different but once it's connected, you are good to go!
I was able to use it to sync up the cell with my PC and transfered over files from one phone to another. Ring tones, games, etc.
The trick to get the connector in: Start inserting the connector from the top to get the bottom portion of the connector in the slot first then put a bit of a force to get the rest of the connector in to the slot. If you have the one USB cable which include charger on it, it will gave you an error that wrong charger is connected to the phone. Click the ok button and it will work just fine!
I took my chance since my phone was still under warranty anyway. And I guess it was a good one!

Hi all,
To answer all of your question, I have both LG VX6000 and VX7000.
Out of curiousity, I took my risk and plug in my USB cable from my VX6000 to my VX7000 and guess what? IT WORK!!
You will need to force fit it a bit since the shaped on the bottom of the connector are a bit different but once it's connected, you are good to go!
I was able to use it to sync up the cell with my PC and transfered over files from one phone to another. Ring tones, games, etc.
The trick to get the connector in: Start inserting the connector from the top to get the bottom portion of the connector in the slot first then put a bit of a force to get the rest of the connector in to the slot. If you have the one USB cable which include charger on it, it will gave you an error that wrong charger is connected to the phone. Click the ok button and it will work just fine!
I took my chance since my phone was still under warranty anyway. And I guess it was a good one!

The GET IT NOW menu items on the VX7000 correlate directly to categories in the Verizon catalog for this device. When your application is made available for download it's category determines where it will show in the UI, not the "Type" setting in the MIF.
vasanths wrote:
First of all, there was no documentation about this abnormality. If we used the normal procedures to load our app to the handset, we could not see our app in the normal place.
Also, we don?t know that these settings will only apply to the cable-loaded apps for local testing. At least its not documented.
This is now documented under the Known Issues for the VX7000. Please see the following link.
https://brewx.qualcomm.com/brew/sdk/authdownload.jsp?page=devices/vzw
Quote:
We trust what you are saying here. But NSTL is probably going to fail us if set wrong settings. We are not sure what kind of settings we need to have in the MIF files. It would be good to have such information available and documented.
so to answer you question, it matters during NSTL testing.
I have spoken with NSTL and this issue does not apply to their testing. NSTL will not fail your application for where it shows up in the UI.
Quote:
I could not set the "Phone" flag as you and Ruben suggested. When I did that, while saving the MIF file, I got the following error message saying
[INDENT]One or more applets in this module have enabled "phone applet" Option. This option is useless the module has ALL privilege levels. Please go to "Advanced Applet" dialog and disable the "Phone Applet" option for the applets.[/INDENT]
I am guessing that it talking about the privilege levels in the General tab. So, I set all privilege levels but continued to get above error.
You will need to use the "All" checkbox found through the "Advanced..." button in the 2.1 MIF Editor or the "Advanced Privileges..." button in the 3.0 MIF Editor.
I do not recommend setting "All" permissions for the sole purpose of having your app show up under Get Going. Adding permissions to your MIF can cause problems during development and submission of your application. For instance, if you use an API that requires the use of a permission level you did not initially intend to support you may not be aware of it until you remove the additional permissions and submit your application to NSTL. Even during development you should only use permissions needed in your final product.
-Bryan

The GET IT NOW menu items on the VX7000 correlate directly to categories in the Verizon catalog for this device. When your application is made available for download it's category determines where it will show in the UI, not the "Type" setting in the MIF.
vasanths wrote:
First of all, there was no documentation about this abnormality. If we used the normal procedures to load our app to the handset, we could not see our app in the normal place.
Also, we don?t know that these settings will only apply to the cable-loaded apps for local testing. At least its not documented.
This is now documented under the Known Issues for the VX7000. Please see the following link.
https://brewx.qualcomm.com/brew/sdk/authdownload.jsp?page=devices/vzw
Quote:
We trust what you are saying here. But NSTL is probably going to fail us if set wrong settings. We are not sure what kind of settings we need to have in the MIF files. It would be good to have such information available and documented.
so to answer you question, it matters during NSTL testing.
I have spoken with NSTL and this issue does not apply to their testing. NSTL will not fail your application for where it shows up in the UI.
Quote:
I could not set the "Phone" flag as you and Ruben suggested. When I did that, while saving the MIF file, I got the following error message saying
[INDENT]One or more applets in this module have enabled "phone applet" Option. This option is useless the module has ALL privilege levels. Please go to "Advanced Applet" dialog and disable the "Phone Applet" option for the applets.[/INDENT]
I am guessing that it talking about the privilege levels in the General tab. So, I set all privilege levels but continued to get above error.
You will need to use the "All" checkbox found through the "Advanced..." button in the 2.1 MIF Editor or the "Advanced Privileges..." button in the 3.0 MIF Editor.
I do not recommend setting "All" permissions for the sole purpose of having your app show up under Get Going. Adding permissions to your MIF can cause problems during development and submission of your application. For instance, if you use an API that requires the use of a permission level you did not initially intend to support you may not be aware of it until you remove the additional permissions and submit your application to NSTL. Even during development you should only use permissions needed in your final product.
-Bryan