Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

HI All,

There were two simple issues.

1. although the mif(3.0) image for icon is getting displayed in simulator, its not getting displayed on device

2. there is one more device related issue. when I press a button for current dialog, it gets consumed by two consecutive dialogs in motoraze v3c. it seems the evt buffer is not getting cleared up.

any suggestions

1. I don't seem to be able to find an icon view with a RAZR. Without icon view, you can't display icons.
2. I have not encountered this problem.

1. I don't seem to be able to find an icon view with a RAZR. Without icon view, you can't display icons.
2. I have not encountered this problem.

rishabh wrote:HI All,
There were two simple issues.
1. although the mif(3.0) image for icon is getting displayed in simulator, its not getting displayed on device
2. there is one more device related issue. when I press a button for current dialog, it gets consumed by two consecutive dialogs in motoraze v3c. it seems the evt buffer is not getting cleared up.
any suggestions
1) Yes. As the previous poster points out, there are no icons for any of the native apps (like mobile shop) either. It's simply a feature of the device.
2) There are a lot of people out there developing happily on the V3, so it seems a little hasty to blame the event loop!
If this is EVT_KEY handling we're talking about, then if you take too long to process it, you will be sent another EVT_KEY. If that is the problem, then you will need to speed up your processing, for example by sending yourself a user event in your EVT_KEY handler code, and doing the rest of your processing in the user event handler.

rishabh wrote:HI All,
There were two simple issues.
1. although the mif(3.0) image for icon is getting displayed in simulator, its not getting displayed on device
2. there is one more device related issue. when I press a button for current dialog, it gets consumed by two consecutive dialogs in motoraze v3c. it seems the evt buffer is not getting cleared up.
any suggestions
1) Yes. As the previous poster points out, there are no icons for any of the native apps (like mobile shop) either. It's simply a feature of the device.
2) There are a lot of people out there developing happily on the V3, so it seems a little hasty to blame the event loop!
If this is EVT_KEY handling we're talking about, then if you take too long to process it, you will be sent another EVT_KEY. If that is the problem, then you will need to speed up your processing, for example by sending yourself a user event in your EVT_KEY handler code, and doing the rest of your processing in the user event handler.

Hi.,
I have also faced some problems with Motorazr V3C handset.
I pointed out the issues in the following threads..but nobody has replied.... :confused:
http://brewforums.qualcomm.com/showthread.php?t=15177
http://brewforums.qualcomm.com/showthread.php?t=15469
Did anybody face this kinda issues???
The same code runs fine on other handsets like Motorola A840 and Samsung SMagic.
Looking forward a reply this time :o

Hi.,
I have also faced some problems with Motorazr V3C handset.
I pointed out the issues in the following threads..but nobody has replied.... :confused:
http://brewforums.qualcomm.com/showthread.php?t=15177
http://brewforums.qualcomm.com/showthread.php?t=15469
Did anybody face this kinda issues???
The same code runs fine on other handsets like Motorola A840 and Samsung SMagic.
Looking forward a reply this time :o

Thanks Ben
Hi Abhimanyu,
Ben is correct. Previously I was doing lots of processing in my EVT_KEY handler. As a result the return true was getting delayed. Hence another event gets generated which gets consumed by subsequent dialog
Now I have put that code in a callback, so that the return true thing occurs instantly.
Try this, I believe this will also solve your problem

Thanks Ben
Hi Abhimanyu,
Ben is correct. Previously I was doing lots of processing in my EVT_KEY handler. As a result the return true was getting delayed. Hence another event gets generated which gets consumed by subsequent dialog
Now I have put that code in a callback, so that the return true thing occurs instantly.
Try this, I believe this will also solve your problem

Hi All,
There is one more V3C issue
http://brewforums.qualcomm.com/showthread.php?t=15246
Any solution

Hi All,
There is one more V3C issue
http://brewforums.qualcomm.com/showthread.php?t=15246
Any solution

Thanks.,
Any solution for the first thread.
http://brewforums.qualcomm.com/showthread.php?t=15177

Thanks.,
Any solution for the first thread.
http://brewforums.qualcomm.com/showthread.php?t=15177

Sorry Abhimanyu,
till date I haven't worked on address books. If you mail the code snippet, probably I can try

Sorry Abhimanyu,
till date I haven't worked on address books. If you mail the code snippet, probably I can try

Hi Rishabh,
You pointed out one issue in the starting of the thread.
although the mif(3.0) image for icon is getting displayed in simulator, its not getting displayed on device
Have u fixed this issue???
My guess is u are not using the exact dimensions for the .mif images.
For Motorazr handset you should use
small 16x16
medium 26x26
large 65x42.

Hi Rishabh,
You pointed out one issue in the starting of the thread.
although the mif(3.0) image for icon is getting displayed in simulator, its not getting displayed on device
Have u fixed this issue???
My guess is u are not using the exact dimensions for the .mif images.
For Motorazr handset you should use
small 16x16
medium 26x26
large 65x42.

In certain device OEM doesn't parse image icon and that's why you don't see MIF file icon. It is complete dependent upon OEM to show ICON or not. At that is the response I got from Motorola engineers.

In certain device OEM doesn't parse image icon and that's why you don't see MIF file icon. It is complete dependent upon OEM to show ICON or not. At that is the response I got from Motorola engineers.

Hi Abhimanyu,
I am using the same size.
MIME type is image/bmp
Bit/Pix is 8
Can u send me ur razr mif file

Hi Abhimanyu,
I am using the same size.
MIME type is image/bmp
Bit/Pix is 8
Can u send me ur razr mif file

rishabh wrote:Hi All,
There is one more V3C issue
http://brewforums.qualcomm.com/showthread.php?t=15246
Any solution
Workaround for this issue
http://brewforums.qualcomm.com/showthread.php?p=56468#post56468

rishabh wrote:Hi All,
There is one more V3C issue
http://brewforums.qualcomm.com/showthread.php?t=15246
Any solution
Workaround for this issue
http://brewforums.qualcomm.com/showthread.php?p=56468#post56468

Thanks Abhimanyu,
It seems this workaround will work. There is one more issue I have noticed with V3C. I have three text boxes, and when the control navigates from 1st text box to second the data entered in the first box disappears. It's there but not visible.
Has anybody encountered that?

Thanks Abhimanyu,
It seems this workaround will work. There is one more issue I have noticed with V3C. I have three text boxes, and when the control navigates from 1st text box to second the data entered in the first box disappears. It's there but not visible.
Has anybody encountered that?

Yes Rishabh,
This is another issue in MotoRazr V3C.
http://brewforums.qualcomm.com/showthread.php?p=55762#post55762
Nobody was responded to my thread.
Again anybody from Motorola team :confused: :confused:

Yes Rishabh,
This is another issue in MotoRazr V3C.
http://brewforums.qualcomm.com/showthread.php?p=55762#post55762
Nobody was responded to my thread.
Again anybody from Motorola team :confused: :confused:

Hi All,
There is one more issue that I have found with V3C.
If the number of text entered in a text box is more than the defined limit, the device hangs.
Any workarounds for it. :confused:

Hi All,
There is one more issue that I have found with V3C.
If the number of text entered in a text box is more than the defined limit, the device hangs.
Any workarounds for it. :confused:

Hi Rishabh.,
It is working fine on my handset.
I think there may be some problem in your code.

Hi Rishabh.,
It is working fine on my handset.
I think there may be some problem in your code.

Hi Abhimanyu,
u r correct
Well it works fine for small text limit say 10, I set it to 60 and it failed

Hi Abhimanyu,
u r correct
Well it works fine for small text limit say 10, I set it to 60 and it failed

Hi Abhimanyu,
I have found a workaround for textctl problem.
While u navigate through the textctl, u may do itextctl_gettext for previous ctl's.
then reset the textctl, set the properties again and set the text retrieved using itextctl_settext

Hi Abhimanyu,
I have found a workaround for textctl problem.
While u navigate through the textctl, u may do itextctl_gettext for previous ctl's.
then reset the textctl, set the properties again and set the text retrieved using itextctl_settext

rishabh wrote:Hi Abhimanyu,
u r correct
Well it works fine for small text limit say 10, I set it to 60 and it failed
No Rishabh,
I tried with max size 60, 70, 100 and it worked fine.
There may be some problem in your code itself.
In the SDK documentation It is given for the ITEXTCTL_SetMaxSize()
"The implementation of this function may vary between devices. Some devices may allow text to be entered beyond the maximum size set by this function. "
But there is no limit for text control maximum size for Motoroazr V3C as no information in the device DDS.

rishabh wrote:Hi Abhimanyu,
u r correct
Well it works fine for small text limit say 10, I set it to 60 and it failed
No Rishabh,
I tried with max size 60, 70, 100 and it worked fine.
There may be some problem in your code itself.
In the SDK documentation It is given for the ITEXTCTL_SetMaxSize()
"The implementation of this function may vary between devices. Some devices may allow text to be entered beyond the maximum size set by this function. "
But there is no limit for text control maximum size for Motoroazr V3C as no information in the device DDS.

1)on V3 (3.1.2) whther its possible to have scalable fonts with/without using ttf
2)Iam actually tapping the *, 0, # key on ItextCtl to behave as i want like * to switch between available modes, 0 between case, and # as space, would this cause a tbt issue
Thnks

1)on V3 (3.1.2) whther its possible to have scalable fonts with/without using ttf
2)Iam actually tapping the *, 0, # key on ItextCtl to behave as i want like * to switch between available modes, 0 between case, and # as space, would this cause a tbt issue
Thnks

Although I haven't tried. You can have scalable fonts using TTF, but it requires quite a lot of space.
Another option would be to have images of each font in your resource file and use them as and when required.

Although I haven't tried. You can have scalable fonts using TTF, but it requires quite a lot of space.
Another option would be to have images of each font in your resource file and use them as and when required.