Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

Hi
I want to know how to use IWeb interface to connect to a web server. Is there any need of running the application containing IWeb interface on a actual device. Right now i am running the application on emulator provided with the SDK and the application is raising an exception when i 'm using IWeb_Getresponse() function.

I have attached a document regarding the usage of IWeb interface. This may probably be of some help to you.
Regards,
Shashi Kant

I have attached a document regarding the usage of IWeb interface. This may probably be of some help to you.
Regards,
Shashi Kant

success_anil wrote:Hi
I want to know how to use IWeb interface to connect to a web server. Is there any need of running the application containing IWeb interface on a actual device. Right now i am running the application on emulator provided with the SDK and the application is raising an exception when i 'm using IWeb_Getresponse() function.
Your query is not clear what exception you are getting.
There are lot of posts regarding how to use IWEB interface....search in forums
Good Luck...!

success_anil wrote:Hi
I want to know how to use IWeb interface to connect to a web server. Is there any need of running the application containing IWeb interface on a actual device. Right now i am running the application on emulator provided with the SDK and the application is raising an exception when i 'm using IWeb_Getresponse() function.
Your query is not clear what exception you are getting.
There are lot of posts regarding how to use IWEB interface....search in forums
Good Luck...!

can u share ur code at which point ur facing the above problem?

can u share ur code at which point ur facing the above problem?

abhimanyu wrote:Your query is not clear what exception you are getting.
There are lot of posts regarding how to use IWEB interface....search in forums
Good Luck...!
Thanks For guiding me. I 've searched in the forums. and i got the following code to connect to a webserver.
void HelloWorld_HttpPost(BookMyShow4 *pMe)
{
char* url="http://brewforums.qualcomm.com/";
if(!pMe->m_pIWeb && ISHELL_CreateInstance( pMe->a.m_pIShell, AEECLSID_WEB, (void **)(&pMe->m_pIWeb))!= SUCCESS)
{
pMe->m_pIWeb=NULL;
return;
}
CALLBACK_Init(&pMe->m_Callback,HelloWorld_OnBrewPostResult,pMe);
IWEB_GetResponse(pMe->m_pIWeb,(pMe->m_pIWeb,&pMe->m_pIWebResp,&pMe->m_Callback,url,WEBOPT_STATUSHANDLER, WebAction_Status,WEBOPT_END));

Thanks once more.

abhimanyu wrote:Your query is not clear what exception you are getting.
There are lot of posts regarding how to use IWEB interface....search in forums
Good Luck...!
Thanks For guiding me. I 've searched in the forums. and i got the following code to connect to a webserver.
void HelloWorld_HttpPost(BookMyShow4 *pMe)
{
char* url="http://brewforums.qualcomm.com/";
if(!pMe->m_pIWeb && ISHELL_CreateInstance( pMe->a.m_pIShell, AEECLSID_WEB, (void **)(&pMe->m_pIWeb))!= SUCCESS)
{
pMe->m_pIWeb=NULL;
return;
}
CALLBACK_Init(&pMe->m_Callback,HelloWorld_OnBrewPostResult,pMe);
IWEB_GetResponse(pMe->m_pIWeb,(pMe->m_pIWeb,&pMe->m_pIWebResp,&pMe->m_Callback,url,WEBOPT_STATUSHANDLER, WebAction_Status,WEBOPT_END));

Thanks once more.

mk.manju wrote:can u share ur code at which point ur facing the above problem?
Hi Manju
Now my problem has got solved. This the code that i have written.
void HelloWorld_HttpPost(BookMyShow4 *pMe)
{
char* url="http://brewforums.qualcomm.com/";
if(!pMe->m_pIWeb && ISHELL_CreateInstance( pMe->a.m_pIShell, AEECLSID_WEB, (void **)(&pMe->m_pIWeb))!= SUCCESS)
{
pMe->m_pIWeb=NULL;
return;
}
CALLBACK_Init(&pMe->m_Callback,HelloWorld_OnBrewPostResult,pMe);
IWEB_GetResponse(pMe->m_pIWeb,(pMe->m_pIWeb,&pMe->m_pIWebResp,&pMe->m_Callback,url,WEBOPT_STATUSHANDLER, WebAction_Status,WEBOPT_END));
}
Thanks

mk.manju wrote:can u share ur code at which point ur facing the above problem?
Hi Manju
Now my problem has got solved. This the code that i have written.
void HelloWorld_HttpPost(BookMyShow4 *pMe)
{
char* url="http://brewforums.qualcomm.com/";
if(!pMe->m_pIWeb && ISHELL_CreateInstance( pMe->a.m_pIShell, AEECLSID_WEB, (void **)(&pMe->m_pIWeb))!= SUCCESS)
{
pMe->m_pIWeb=NULL;
return;
}
CALLBACK_Init(&pMe->m_Callback,HelloWorld_OnBrewPostResult,pMe);
IWEB_GetResponse(pMe->m_pIWeb,(pMe->m_pIWeb,&pMe->m_pIWebResp,&pMe->m_Callback,url,WEBOPT_STATUSHANDLER, WebAction_Status,WEBOPT_END));
}
Thanks

mk.manju wrote:can u share ur code at which point ur facing the above problem?
Hi
Now i 've managed to connect to a web server now what should i do to read html pages on the server?

mk.manju wrote:can u share ur code at which point ur facing the above problem?
Hi
Now i 've managed to connect to a web server now what should i do to read html pages on the server?

Assuming that your data returning from the Server is HTML, you can use the IHTMLVIEWER class. Check out the roadwarrior example.

Assuming that your data returning from the Server is HTML, you can use the IHTMLVIEWER class. Check out the roadwarrior example.

Hi
Thanks
Now i can view the html page on the server.

Hi
Thanks
Now i can view the html page on the server.

Shashi Kant wrote:I have attached a document regarding the usage of IWeb interface. This may probably be of some help to you.
Regards,
Shashi Kant
Thanks ShashiNow i 've managed to connect to wap site at http://www.wapdevelopment.org/index.jsp

Shashi Kant wrote:I have attached a document regarding the usage of IWeb interface. This may probably be of some help to you.
Regards,
Shashi Kant
Thanks ShashiNow i 've managed to connect to wap site at http://www.wapdevelopment.org/index.jsp

hi,
using IHTMLVIEWER iam not able to display webpages consisting hindi.
device has got hindi font support.
i have seen some other Apps in same phone are cpable of displaying hindi text.
do IHTMLVIEWER requires any special support from OEM side

hi,
using IHTMLVIEWER iam not able to display webpages consisting hindi.
device has got hindi font support.
i have seen some other Apps in same phone are cpable of displaying hindi text.
do IHTMLVIEWER requires any special support from OEM side