Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

Hello

I have sending some files to the server using POST.

Everything works fine when the body is smaller than 1536 bytes. If there is more than 1536 bytes in the body then BREW is just sending first 1536 bytes, attaching 0x0d 0x0a at the end and that's it!

The problem occurs on the emulator, and I am using ISOURCEUTIL_PeekFromMemory() to create body buffer....

Is there any known problem with this interface???
Any workarounds?

Zim

There is a known bug with BREW 1.x/ 2.0 that is causing this problem. Please use ISOCKET_Write() instead.
---tamoghna

There is a known bug with BREW 1.x/ 2.0 that is causing this problem. Please use ISOCKET_Write() instead.
---tamoghna

Thank you very much, but could you give me some more details?
Is it emulator's problem only? Unfortunately I haven't tried it on the phone yet. I would like to know what is the status of this bug on LGE VX6000
I have checked this issue on two version of the Emulator:
2.0.0.38 - seems to have this bug
2.0.1.5 - bug seems to be fixed
As far as I know LGE VX6000 is based on 2.0.2 version of BREW, so if the emulator version has something to do with BREW version it would suggest the bug has been fixed...
Zim

Thank you very much, but could you give me some more details?
Is it emulator's problem only? Unfortunately I haven't tried it on the phone yet. I would like to know what is the status of this bug on LGE VX6000
I have checked this issue on two version of the Emulator:
2.0.0.38 - seems to have this bug
2.0.1.5 - bug seems to be fixed
As far as I know LGE VX6000 is based on 2.0.2 version of BREW, so if the emulator version has something to do with BREW version it would suggest the bug has been fixed...
Zim

Hello, I need some help with posting data to a server.
I don´t understand very well how the data is sent and what you recieve in the server.
Anybody can help me??
Thanks

Hello, I need some help with posting data to a server.
I don´t understand very well how the data is sent and what you recieve in the server.
Anybody can help me??
Thanks

Maybe I can help, but could you give some more details about what you data you want to post and what kind of server are you using. PHP?
Zim

Maybe I can help, but could you give some more details about what you data you want to post and what kind of server are you using. PHP?
Zim

I have to collect data un a CHAR var and send it to a server, to store it in a database.
The server is not defined, but could be ASP, ASP.Net or Java
Is this clear?
thanks

I have to collect data un a CHAR var and send it to a server, to store it in a database.
The server is not defined, but could be ASP, ASP.Net or Java
Is this clear?
thanks

see the netdiagnostics example in SDK.
ruben

see the netdiagnostics example in SDK.
ruben

tamoghna wrote:There is a known bug with BREW 1.x/ 2.0 that is causing this problem. Please use ISOCKET_Write() instead.
---tamoghna
Does this mean that I cant post any data above 1536 using the IWeb interface?
No workarounds?
I am also facing another problem. I have written a code which works fine on Brew 2.0 emulator but when running on Brew 2.1 emulator I am getting a connect error?
can u explain why this might be occuring?
I have heard some people mention the sniffer to see netwrok traffic. Can u guys suggest me some soft. etc

tamoghna wrote:There is a known bug with BREW 1.x/ 2.0 that is causing this problem. Please use ISOCKET_Write() instead.
---tamoghna
Does this mean that I cant post any data above 1536 using the IWeb interface?
No workarounds?
I am also facing another problem. I have written a code which works fine on Brew 2.0 emulator but when running on Brew 2.1 emulator I am getting a connect error?
can u explain why this might be occuring?
I have heard some people mention the sniffer to see netwrok traffic. Can u guys suggest me some soft. etc