Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

Hello,

I have written a camera application thru which i capture an image.
After capturing the image, i open the jpeg file created with the Ifilemgr_openfile and read the jpeg file with ifile_read and then copy the read byte to a buffer.
but jpeg files contains unicode chars and a few of these chars are read as blank string "" so the size of my jpeg file and the size of buffer donot match.

some chars go missing in the buffer....

how do i read these unicode chars.... has any1 come across this problem??

pls urgent help need....

Thanks in advance.
Pribhi.

You can try with WSTRTOSTR()

You can try with WSTRTOSTR()

In the JPEG image you have unicode characters? How are you getting those characters on the image, are you sure they are not JPEG image data?

In the JPEG image you have unicode characters? How are you getting those characters on the image, are you sure they are not JPEG image data?

pribhi wrote:Hello,
I have written a camera application thru which i capture an image.
After capturing the image, i open the jpeg file created with the Ifilemgr_openfile and read the jpeg file with ifile_read and then copy the read byte to a buffer.
but jpeg files contains unicode chars and a few of these chars are read as blank string "" so the size of my jpeg file and the size of buffer donot match.
some chars go missing in the buffer....
how do i read these unicode chars.... has any1 come across this problem??
pls urgent help need....
Thanks in advance.
Pribhi.
As far as I understood your prob statement.. I don't think that the problem is unicode characters. Sometimes size differs (in actual image size and buffer size) because of the file headers.. as buffer wouldn't contain the file header... although the JPEG image headers will be there in buffer...
Pl let us know if JPEG image buffer corrupted ??
SoftEast

pribhi wrote:Hello,
I have written a camera application thru which i capture an image.
After capturing the image, i open the jpeg file created with the Ifilemgr_openfile and read the jpeg file with ifile_read and then copy the read byte to a buffer.
but jpeg files contains unicode chars and a few of these chars are read as blank string "" so the size of my jpeg file and the size of buffer donot match.
some chars go missing in the buffer....
how do i read these unicode chars.... has any1 come across this problem??
pls urgent help need....
Thanks in advance.
Pribhi.
As far as I understood your prob statement.. I don't think that the problem is unicode characters. Sometimes size differs (in actual image size and buffer size) because of the file headers.. as buffer wouldn't contain the file header... although the JPEG image headers will be there in buffer...
Pl let us know if JPEG image buffer corrupted ??
SoftEast

After capturing the image on the handset, i read each byte from the JPEG file and store it in a buffer using the IFIle interface. but all the bytes from are the file are not read.
what could be the reason for this?
when i open the jpeg file thru IFIle interface and read each byte, the header also gets read into the buffer or not??
After i read the whole jpeg file , i have to send the read buffer to the server using the http post request?
is there something wrong in my approach to read the jpeg file into the buffer?
or is there any other approach to transfer the jpeg image file from the handset to the server??
pls help.
Thanks in Advance.
Pribhi.

After capturing the image on the handset, i read each byte from the JPEG file and store it in a buffer using the IFIle interface. but all the bytes from are the file are not read.
what could be the reason for this?
when i open the jpeg file thru IFIle interface and read each byte, the header also gets read into the buffer or not??
After i read the whole jpeg file , i have to send the read buffer to the server using the http post request?
is there something wrong in my approach to read the jpeg file into the buffer?
or is there any other approach to transfer the jpeg image file from the handset to the server??
pls help.
Thanks in Advance.
Pribhi.