Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

We're seeing problems with the 3.1.1 qcomoem.dll packaged with the most recent versions of Apploader when connecting to certain devices. This seems to be due to an incomplete/erroneous implementation of EFS2 commands on particular devices, causing connectivity or read/write failures when using Apploader.

This was only exposed in the 3.1.1.x releases because prior releases used EFS1 commands to communicate with all devices, even those that responded to EFS2 commands.

We're aware of the problem and working to provide a resolution in the form of a patch allowing the ability to force EFS1 communication mode. In the meantime, you should be able to manually downgrade your qcomoem.dll file if you have another installation of BREW Tools Suite/BTIL on your device.

A patch has been posted at https://brewx.qualcomm.com/bws/content/docx/products/btil/1.0/1.0.1.10/u... to address this problem.
BE SURE TO REFER TO THE README, IT CONTAINS NECESSARY INSTRUCTIONS.
https://brewx.qualcomm.com/bws/content/docx/products/btil/1.0/1.0.1.10/u...

A patch has been posted at https://brewx.qualcomm.com/bws/content/docx/products/btil/1.0/1.0.1.10/u... to address this problem.
BE SURE TO REFER TO THE README, IT CONTAINS NECESSARY INSTRUCTIONS.
https://brewx.qualcomm.com/bws/content/docx/products/btil/1.0/1.0.1.10/u...