Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

Hello,

I had this problem on Motorola A840 when I use ITEXTCTL APIs in my application. The problem is that sometimes after use of a left arrow to back over text in the input string, the last character can get stuck in the string. Until the application is restarted, every subsequent input string will have the stray character. For example, if I enter the string “adg” and use the left arrow to place the text cursor between “d” and “g”, then I'll never be able to move the cursor back to the end of the string. After that, I can continue to input or delete the characters as normal, except that I can't move the cursor to pass the last character, 'g' in this example. And either can I delete it. So whatever string I input later will contain this 'g' as its last character.
It doesn't happen all the time. Sometimes, if I restart the application, the problem is gone. But usually it will happen after I power cycle the phone. I am suspecting that it may be a device issue since this applciation runs very well on many other handsets. But I can't verify it. And anyway I have to make it work. Does anyone have any suggestion about how to solve this problem?
Thanks a lot!

gdw

You might want to email brew-support with some code that replicates this problem.

You might want to email brew-support with some code that replicates this problem.

I am having the same problem. Did you ever find a solution for this or is it a known device issue with no workaround?
Thanks

I am having the same problem. Did you ever find a solution for this or is it a known device issue with no workaround?
Thanks