Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Hi,

I'm experiencing this issue with Resource Manager: each time I try to start it, after some seconds on the initial splash screen, I get a Window error popup telling that there was an error in ResourceMgrSA.

Digging into the error details, here's what I've got:
Quote:
EventType : clr20r3 P1 : resourcemgrsa.exe P2 : 0.0.3272.21319
P3 : 4948068e P4 : presentationframework P5 : 3.0.0.0 P6 : 488f142e
P7 : 6259 P8 : e1 P9 : system.windows.markup.xamlparse

Has anyone experienced (and hopefully solved) the same issue?

Thanks in advance,
Pit

SOME MORE INFOS: the SDK was freshly installed, and I do not remember if the Resource Manager crashed always or if it started at least once. In any case, could this be an issue related to some temporary files used by Resource Manager itself? I've tried uninstalling/reinstalling but without luck :(

EDIT2: tried digging and tweaking some Register settings, but still no luck.

EDIT3: tried all the installation process on another machine, with the very same result. After installing .Net framework 3.5 SP1, I have installed the Brew MP SDK. Done that, I launched the Resource Manager, and it started correctly. Then, I closed it and I tried to start it again: it just crashes as on the other machine, and there's no way to start it again! :(

Are you on XP or Vista?

Are you on XP or Vista?

Hi John,
I'm on Windows XP.
Please tell me if you need any additional details..
Pit

Hi John,
I'm on Windows XP.
Please tell me if you need any additional details..
Pit

Do you have MSVC on your machine? It is possible we have some environment dependencies on that development environment, which we shouldn't.

Do you have MSVC on your machine? It is possible we have some environment dependencies on that development environment, which we shouldn't.

On one machine there's not MSVC, while on the other it is there (installed with Visual Studio 8 ). There are some tests I could do to check if this is a dependency issue?
Pit

On one machine there's not MSVC, while on the other it is there (installed with Visual Studio 8 ). There are some tests I could do to check if this is a dependency issue?
Pit

If you check, it may provide an answer. I will ask QA to ensure testing is done on clean machines.

If you check, it may provide an answer. I will ask QA to ensure testing is done on clean machines.

Ok, please let me know which tests I have to perform, and I'll give you the results asap.
Thanks for your support!
Pit

Ok, please let me know which tests I have to perform, and I'll give you the results asap.
Thanks for your support!
Pit

I was hoping you would see if it ran on machine without VS Studio and associated dll's.

I was hoping you would see if it ran on machine without VS Studio and associated dll's.

FYI, I just installed a brand new version of XP. On this machine I have Windows XP Service Pack 3. Additionally, I installed .Net Framework 3.5.1.
Resource Manager runs fine on Dec 19th release of Brew MP 1.0 SDK rev 2.2. As a simple test I was able to load .brx file from the c_application sample provide in the kit.

FYI, I just installed a brand new version of XP. On this machine I have Windows XP Service Pack 3. Additionally, I installed .Net Framework 3.5.1.
Resource Manager runs fine on Dec 19th release of Brew MP 1.0 SDK rev 2.2. As a simple test I was able to load .brx file from the c_application sample provide in the kit.

Hi, I have the same issue on Brew MP rev 3.2
I have updated up to XP SP3 and installed .Net Framework 3.5.1. Then I reinstalled the platform. But it didn't help. It continues failing with the same error. Any ideas?
I saw ResourceMgr only once running, after the first installation. But all the subsequent launchs result in failure even If I install all the additional env. software and reinstall the BrewMP
FYI - I have no MSVS on my PC

Hi, I have the same issue on Brew MP rev 3.2
I have updated up to XP SP3 and installed .Net Framework 3.5.1. Then I reinstalled the platform. But it didn't help. It continues failing with the same error. Any ideas?
I saw ResourceMgr only once running, after the first installation. But all the subsequent launchs result in failure even If I install all the additional env. software and reinstall the BrewMP
FYI - I have no MSVS on my PC

Got the same problem on Vista Home Premium with 3.5 .Net framework installed
Does anybody from BrewMP vendors look at this forum !!!???
P.S. this time I installed the most recent Brew MP. ResMgr ran only once and then fails always

Got the same problem on Vista Home Premium with 3.5 .Net framework installed
Does anybody from BrewMP vendors look at this forum !!!???
P.S. this time I installed the most recent Brew MP. ResMgr ran only once and then fails always

I am not sure why you have failures. Are you just launching or are you trying to load a specific resource file?
We do have new resource file formats cif and car, they replace mfx and brx respectively. Resource Editor and MIF Editor are still in the deprecate folder, if you prefer to use those for the short term.

I am not sure why you have failures. Are you just launching or are you trying to load a specific resource file?
We do have new resource file formats cif and car, they replace mfx and brx respectively. Resource Editor and MIF Editor are still in the deprecate folder, if you prefer to use those for the short term.

I just start it for the blank app in the eclipse. i was able to change hello world string in the res file to hi. Saved, deployed and the string was changed in fact. The second and all the subsequent launchs of the ResMgr resulted with failure.

I just start it for the blank app in the eclipse. i was able to change hello world string in the res file to hi. Saved, deployed and the string was changed in fact. The second and all the subsequent launchs of the ResMgr resulted with failure.

a standalone launch also fails

a standalone launch also fails

I tried what you said. I created a C Application using the wizard. Change the resource back and forth using Resource Manager. Come back to Eclipse, press F5 to see updates. Repeat the process. All seems OK.
There must be something unique about your environment or tools. I am unable to replicate.

I tried what you said. I created a C Application using the wizard. Change the resource back and forth using Resource Manager. Come back to Eclipse, press F5 to see updates. Repeat the process. All seems OK.
There must be something unique about your environment or tools. I am unable to replicate.

I guess there's nothing special on my machine except the language. I have licensed Vista with Russian language. Also I have installed .Net framework v 3.5. Maybe this tool has internationalization problems.
But fact is fact - It fails on startup and this is a major bug what is very bad for such type of software.
P.S. Same story I had on XP

I guess there's nothing special on my machine except the language. I have licensed Vista with Russian language. Also I have installed .Net framework v 3.5. Maybe this tool has internationalization problems.
But fact is fact - It fails on startup and this is a major bug what is very bad for such type of software.
P.S. Same story I had on XP

BTW did you have MSVS installed during the test?

BTW did you have MSVS installed during the test?

Russian language and vista are probably the key issues.

Russian language and vista are probably the key issues.

I have confirmed that the Resource Manager installed with Brew MP 1.0 SDK Rev 3.2 will not run on a Russian Vista machine.
But I have also confirmed that the Resource Manager installed with Brew MP 1.0 Rev 4.3 will run on a Russian Vista machine.
However, if you previously had Rev 3.2 installed you need to delete it and remove all references to it from the system registry before installing Rev 4.3 or higher. If you don't clean the registry the Resource Manager will still crash.
Additionally, to use any Brew MP SDK tool on a Vista machine, it is recommended that you turn User Account Controls off.

I have confirmed that the Resource Manager installed with Brew MP 1.0 SDK Rev 3.2 will not run on a Russian Vista machine.
But I have also confirmed that the Resource Manager installed with Brew MP 1.0 Rev 4.3 will run on a Russian Vista machine.
However, if you previously had Rev 3.2 installed you need to delete it and remove all references to it from the system registry before installing Rev 4.3 or higher. If you don't clean the registry the Resource Manager will still crash.
Additionally, to use any Brew MP SDK tool on a Vista machine, it is recommended that you turn User Account Controls off.

Thanks. Hope these procedures will help me to avoid this issue.
Also, the account control switch off was first what I did to prevent any issues on Vista but that was an XML err.

Thanks. Hope these procedures will help me to avoid this issue.
Also, the account control switch off was first what I did to prevent any issues on Vista but that was an XML err.

Hi, I am very new to BMP. Just installed BMP 1.0 Rev 4.3 and BMP VS Plugin 1.0 on XP Pro SP3. I have VS 2005 Pro installed on my machine. All in English.
On clicking BMP Launcher -> "Developer Tools" -> Application -> "Resource Manager", Windows immediately reports crash "ResourceMgrSA has encountered a problem...".
I saw previous posts but cannot see a solution for my situation. Can someone help?
Thanks very much,

Hi, I am very new to BMP. Just installed BMP 1.0 Rev 4.3 and BMP VS Plugin 1.0 on XP Pro SP3. I have VS 2005 Pro installed on my machine. All in English.
On clicking BMP Launcher -> "Developer Tools" -> Application -> "Resource Manager", Windows immediately reports crash "ResourceMgrSA has encountered a problem...".
I saw previous posts but cannot see a solution for my situation. Can someone help?
Thanks very much,

The Visual Studio Just-In-Time Debugger displayed the following error message:
An unhandled exception ('System.Windows.Markup.XamlParseException') occured in ResourceMgrSA.exe[3080].
ZX wrote:Hi, I am very new to BMP. Just installed BMP 1.0 Rev 4.3 and BMP VS Plugin 1.0 on XP Pro SP3. I have VS 2005 Pro installed on my machine. All in English.
On clicking BMP Launcher -> "Developer Tools" -> Application -> "Resource Manager", Windows immediately reports crash "ResourceMgrSA has encountered a problem...".
I saw previous posts but cannot see a solution for my situation. Can someone help?
Thanks very much,

The Visual Studio Just-In-Time Debugger displayed the following error message:
An unhandled exception ('System.Windows.Markup.XamlParseException') occured in ResourceMgrSA.exe[3080].
ZX wrote:Hi, I am very new to BMP. Just installed BMP 1.0 Rev 4.3 and BMP VS Plugin 1.0 on XP Pro SP3. I have VS 2005 Pro installed on my machine. All in English.
On clicking BMP Launcher -> "Developer Tools" -> Application -> "Resource Manager", Windows immediately reports crash "ResourceMgrSA has encountered a problem...".
I saw previous posts but cannot see a solution for my situation. Can someone help?
Thanks very much,

Hi Jappit and J2medev,
I actually saw a similar scenario today and it turned out to be related to permissions on the user account. Even though it was an administrator account, it couldn't run regedit. One thing you can try is running App Creator, and if you see errors with saving registry items, etc, then this could be related issue.
What solved the issue was to create a new user then re-install the SDK. Resource Manager launched OK with this new user.
Please let me know if this resolves the issue.
Thanks,
Karina

Hi Jappit and J2medev,
I actually saw a similar scenario today and it turned out to be related to permissions on the user account. Even though it was an administrator account, it couldn't run regedit. One thing you can try is running App Creator, and if you see errors with saving registry items, etc, then this could be related issue.
What solved the issue was to create a new user then re-install the SDK. Resource Manager launched OK with this new user.
Please let me know if this resolves the issue.
Thanks,
Karina

Both I and my collegue are having this problem, manifesting in an error when starting the Resource manager.
The error information is:
Quote:An unhandled exception of type 'System.Windows.Markup.XamlParseException' occurred in PresentationFramework.dll
Additional information: Cannot create instance of 'Window1' defined in assembly 'ResourceMgrSA, Version=1.0.7.605, Culture=neutral, PublicKeyToken=null'. Exception has been thrown by the target of an invocation. Error in markup file 'ResourceMgrSA;component/Window1.xaml'.
I have tried cleaning the registry from all references to brew and qualcomm that I could find, then reinstalling both Visual Studio and the Brew MP SDK, the error still persists.
We run Windows XP Professional (English) and Visual Studio 2005.
Update:
I tried cleaning registry entries related to qualcomm and brew and reinstalled the SDK. I was now able to start the resource manager once. I closed the resource manager and tried starting it again, and the error from before was back. Obvously something is set when the resource manager is first opened and this causes the crash in subsequent attempts.
Update:
I have now managed to locate the registry entry that causes the crash. The villain is HKEY_CURRENT_USER\Software\Qualcomm\ResourceManager\WindowState
Deleting this entry will allow you to start the resource manager. However, the entry is recreated when the manager is closed, causing the error to reappear.

Both I and my collegue are having this problem, manifesting in an error when starting the Resource manager.
The error information is:
Quote:An unhandled exception of type 'System.Windows.Markup.XamlParseException' occurred in PresentationFramework.dll
Additional information: Cannot create instance of 'Window1' defined in assembly 'ResourceMgrSA, Version=1.0.7.605, Culture=neutral, PublicKeyToken=null'. Exception has been thrown by the target of an invocation. Error in markup file 'ResourceMgrSA;component/Window1.xaml'.
I have tried cleaning the registry from all references to brew and qualcomm that I could find, then reinstalling both Visual Studio and the Brew MP SDK, the error still persists.
We run Windows XP Professional (English) and Visual Studio 2005.
Update:
I tried cleaning registry entries related to qualcomm and brew and reinstalled the SDK. I was now able to start the resource manager once. I closed the resource manager and tried starting it again, and the error from before was back. Obvously something is set when the resource manager is first opened and this causes the crash in subsequent attempts.
Update:
I have now managed to locate the registry entry that causes the crash. The villain is HKEY_CURRENT_USER\Software\Qualcomm\ResourceManager\WindowState
Deleting this entry will allow you to start the resource manager. However, the entry is recreated when the manager is closed, causing the error to reappear.

Hello,
Can you please tell me what version of the BMP SDK you currently have installed? If you're still experiencing issues, one helpful tip here is to make sure that Resource Manager wasn't closed while it was in a minimized state. The executable name is ResourceMgrSA.exe and may still be running in task manager. Let me know if you have any luck with above. I can ask our test team to try and replicate on our side.
Thanks,
Brian
-------------------
Brian A. Perrotta
BMP Developer Evangelist
Qualcomm Incorporated
5775 Morehouse Drive R-243C
San Diego, CA. 92121

Hello,
Can you please tell me what version of the BMP SDK you currently have installed? If you're still experiencing issues, one helpful tip here is to make sure that Resource Manager wasn't closed while it was in a minimized state. The executable name is ResourceMgrSA.exe and may still be running in task manager. Let me know if you have any luck with above. I can ask our test team to try and replicate on our side.
Thanks,
Brian
-------------------
Brian A. Perrotta
BMP Developer Evangelist
Qualcomm Incorporated
5775 Morehouse Drive R-243C
San Diego, CA. 92121

I´m using Brew MP 1.0 rev 4.5
ResourceMgrSA.exe is not running.
The problematic registry entry has the following keys:
(Default) REG_SZ (value not set)
position REG_SZ 40;40;800;600
Deleting only the position key does not solve the problem, the entire WindowState entry must be deleted.
Regards
David

I´m using Brew MP 1.0 rev 4.5
ResourceMgrSA.exe is not running.
The problematic registry entry has the following keys:
(Default) REG_SZ (value not set)
position REG_SZ 40;40;800;600
Deleting only the position key does not solve the problem, the entire WindowState entry must be deleted.
Regards
David

Karinag wrote:Hi Jappit and J2medev,
I actually saw a similar scenario today and it turned out to be related to permissions on the user account. Even though it was an administrator account, it couldn't run regedit. One thing you can try is running App Creator, and if you see errors with saving registry items, etc, then this could be related issue.
What solved the issue was to create a new user then re-install the SDK. Resource Manager launched OK with this new user.
Please let me know if this resolves the issue.
Thanks,
Karina
The problem seems to be that the HKCU/Software/Qualcomm key is sometimes created as volitile. This cuases problems since apps cannot then create a subkey. I solved it on my machine by renaming the Qualcomm key and allowing the software to re-create it. Now the app comes up fine.

Karinag wrote:Hi Jappit and J2medev,
I actually saw a similar scenario today and it turned out to be related to permissions on the user account. Even though it was an administrator account, it couldn't run regedit. One thing you can try is running App Creator, and if you see errors with saving registry items, etc, then this could be related issue.
What solved the issue was to create a new user then re-install the SDK. Resource Manager launched OK with this new user.
Please let me know if this resolves the issue.
Thanks,
Karina
The problem seems to be that the HKCU/Software/Qualcomm key is sometimes created as volitile. This cuases problems since apps cannot then create a subkey. I solved it on my machine by renaming the Qualcomm key and allowing the software to re-create it. Now the app comes up fine.

Thanks for the info, I've forwarded it to development
Karina

Thanks for the info, I've forwarded it to development
Karina

nothing to worry... from Brew MP luncher select setup tab then install IsCurrent from Environment. then restart you PC. these steps solved my problem...

nothing to worry... from Brew MP luncher select setup tab then install IsCurrent from Environment. then restart you PC. these steps solved my problem...

Update (9/24): This crash occurred when the project I had created was open in VS. Several reboots had no effect. However, the RM does run OK from the Launcher or from within VS with no project open. Now that it has launched successfully in those two scenarios, it starts up with the project open and I can't reproduce the crash again. So far so good...
-----
Resource Manager 1.0.7.605 crashes on my new installation of SDK 4.5 on Win XP. I'm using Visual Studio 2008.
----
An unhandled exception of type 'System.Windows.Markup.XamlParseException' occurred in PresentationFramework.dll
Additional information: Cannot create instance of 'Window1' defined in assembly 'ResourceMgrSA, Version=1.0.7.605, Culture=neutral, PublicKeyToken=null'. Exception has been thrown by the target of an invocation. Error in markup file 'ResourceMgrSA;component/Window1.xaml'.
----
Error Signature:
EventType : clr20r3 P1 : resourcemgrsa.exe P2 : 1.0.7.605
P3 : 4a284238 P4 : presentationframework P5 : 3.0.0.0 P6 : 4938d608
P7 : 625a P8 : e1 P9 : system.windows.markup.xamlparse

Update (9/24): This crash occurred when the project I had created was open in VS. Several reboots had no effect. However, the RM does run OK from the Launcher or from within VS with no project open. Now that it has launched successfully in those two scenarios, it starts up with the project open and I can't reproduce the crash again. So far so good...
-----
Resource Manager 1.0.7.605 crashes on my new installation of SDK 4.5 on Win XP. I'm using Visual Studio 2008.
----
An unhandled exception of type 'System.Windows.Markup.XamlParseException' occurred in PresentationFramework.dll
Additional information: Cannot create instance of 'Window1' defined in assembly 'ResourceMgrSA, Version=1.0.7.605, Culture=neutral, PublicKeyToken=null'. Exception has been thrown by the target of an invocation. Error in markup file 'ResourceMgrSA;component/Window1.xaml'.
----
Error Signature:
EventType : clr20r3 P1 : resourcemgrsa.exe P2 : 1.0.7.605
P3 : 4a284238 P4 : presentationframework P5 : 3.0.0.0 P6 : 4938d608
P7 : 625a P8 : e1 P9 : system.windows.markup.xamlparse