Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

Hi

The same MOD and BAR file on two different LG VX6000. After ringtones are downloaded, and application exists, one phone plays ringtones, one doesn't.

I was wondering if anyone had similar experience, or have an idea what's going on. On one VX6000: I can download with my appication, store and then play ringtones (through My Media | Sounds). Also set particular ringtone for callerID, etc..

On another VX6000 my downloaded ringtones are in the list in My Media | Music. I can set it up as paritcular ringtone (callerID, etc...), but nothing is heard. It's completely silent (like the file is empty).

... Thanks again ...

I ran into the same problem with the T730. Mine was the file size. If it was over 16k it would play through the app, but not throught the device UI.
I am also developing for the vx6000, and I ran into a similar situation, where the total file name length was too long, and it created a 0 byte file. When I say total file name length, I mean the url to my server where the file was stored.
Hope that helps

I ran into the same problem with the T730. Mine was the file size. If it was over 16k it would play through the app, but not throught the device UI.
I am also developing for the vx6000, and I ran into a similar situation, where the total file name length was too long, and it created a 0 byte file. When I say total file name length, I mean the url to my server where the file was stored.
Hope that helps

Maybe one is in "manner mode" and the other isn't.
on the VX6000, go to the main phone screen (not brew), and press the up/down buttons on the left side of the device.. make sure ringer is not "vibrate" or "off".. if it is either, ringtones will not play.. however, pressing keys still makes beeps, its a separate volume setting.
-Tyndal

Maybe one is in "manner mode" and the other isn't.
on the VX6000, go to the main phone screen (not brew), and press the up/down buttons on the left side of the device.. make sure ringer is not "vibrate" or "off".. if it is either, ringtones will not play.. however, pressing keys still makes beeps, its a separate volume setting.
-Tyndal

Just verified - it's Med Low. I could hear other ringers (which were orininally on the phone), while I can only see my ringetones in the list, but they are silent on that one LG phone.
weespeed, it's kind of odd that one VX6000 wouldn't correctly accept rintone's file name which other VX6000 accepts. It's the same MOD and BAR file on two different VX6000... I'm still trying to figure this out.
Thank you guys for your replies.

Just verified - it's Med Low. I could hear other ringers (which were orininally on the phone), while I can only see my ringetones in the list, but they are silent on that one LG phone.
weespeed, it's kind of odd that one VX6000 wouldn't correctly accept rintone's file name which other VX6000 accepts. It's the same MOD and BAR file on two different VX6000... I'm still trying to figure this out.
Thank you guys for your replies.

Is the MIF file the same? Are the phone build versions the same?
I would assume it is, and it shouldnt make a diff, but maybe permissions are different or something..
just a wild guess.
-Tyndal

Is the MIF file the same? Are the phone build versions the same?
I would assume it is, and it shouldnt make a diff, but maybe permissions are different or something..
just a wild guess.
-Tyndal

MIF files were not exactly the same (images were a bit different). I upload the same MIF file. Permissions to write ringer directory they both have, besides both phones actually save ringers and ringers appear in the list of ringers ("My Media" | "Music" and "Settings" | "Sounds" | "Ringers" | "Caller ID", for example). I just cant hear them on one of the VX6000s.
There is one difference, I can see, but don't know if that's relevant: PRL version is different. One is PRL 50113, another one PRL 42014. All other numbers (like S/W version, ERI version, "Get It Now ver.") are the same.
Don't know what's that "PRL" ... But I don't know what else to look for.
Is there a setting on available size for ringers? Mabye there is no space to save anymore ringers natively? However RingerCreate() returns success.

MIF files were not exactly the same (images were a bit different). I upload the same MIF file. Permissions to write ringer directory they both have, besides both phones actually save ringers and ringers appear in the list of ringers ("My Media" | "Music" and "Settings" | "Sounds" | "Ringers" | "Caller ID", for example). I just cant hear them on one of the VX6000s.
There is one difference, I can see, but don't know if that's relevant: PRL version is different. One is PRL 50113, another one PRL 42014. All other numbers (like S/W version, ERI version, "Get It Now ver.") are the same.
Don't know what's that "PRL" ... But I don't know what else to look for.
Is there a setting on available size for ringers? Mabye there is no space to save anymore ringers natively? However RingerCreate() returns success.

Maybe I have something wrong in my code, but still this is odd. I have downloaded "Modtones", downloaded one tone and set it as ringer. Went out from "GetIt Now". In "My Media | Music" found that ringtone (downloaded through Modtones). It worked! Then, I selected one of my ringtones and - IT PLAYED the ringtone. Now, I can hear all my ringtones on both VX6000.
But how? What setting got set, so that I was able to hear *previously* stored my own ringers after listening to Modtone ringer? Also I can download NEW ringers form my server and listen to them, after exiting my application (nothing changed, except I played Modtone ringtone through My Media | Music).
Also this troubled phone was not purchased from Verizon, but from some third party, and it wasn't programmed (I did that by dialing *228 after sending ESN # to Verizon). However, maybe that's not relevant...
Thanks again for your replies!

Maybe I have something wrong in my code, but still this is odd. I have downloaded "Modtones", downloaded one tone and set it as ringer. Went out from "GetIt Now". In "My Media | Music" found that ringtone (downloaded through Modtones). It worked! Then, I selected one of my ringtones and - IT PLAYED the ringtone. Now, I can hear all my ringtones on both VX6000.
But how? What setting got set, so that I was able to hear *previously* stored my own ringers after listening to Modtone ringer? Also I can download NEW ringers form my server and listen to them, after exiting my application (nothing changed, except I played Modtone ringtone through My Media | Music).
Also this troubled phone was not purchased from Verizon, but from some third party, and it wasn't programmed (I did that by dialing *228 after sending ESN # to Verizon). However, maybe that's not relevant...
Thanks again for your replies!