Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Hi,

I've just got a test enabled SCH A561 from Qualcomm and when it arrived it already had one or two apps already on it (I presume as standard).

I generated a sig file and loaded the app onto the handset using apploader.

The icon appears on the handset and files are present in the apploader window as you'd expect.

When I select the app, I get this message:

Quote:Application Digital Signature Failure (1028)

Any ideas?

Thanks

Sam

Check with sig file. You need to have valid sig file for each of the module. Sig file can be generated using ESN number of the phone usually found at the back of your device.
ruben

Check with sig file. You need to have valid sig file for each of the module. Sig file can be generated using ESN number of the phone usually found at the back of your device.
ruben

Yep, done that. Twice in fact :D

Yep, done that. Twice in fact :D

.

.

Is there a CDMA network where you are? If not, you'll need to manually set the date in your phone.

Is there a CDMA network where you are? If not, you'll need to manually set the date in your phone.

No there isn't.
I have manually set the date on the handset. Same result. :confused:

No there isn't.
I have manually set the date on the handset. Same result. :confused:

Howdy,
We're having very similar problems with our SCHa530.
Test bit is enabled (verified with ###3) and we should have a good SIG (we've recreated it several times in case we had a typo in our ESN).
However, upon running the app, we still get the error
Application Digital Signature Failure (1029).
Been banging on this for many hours, read just about all the forum posts we can find. Finally sent a message to Qualcomm's tech support.
Any clues out there?
-j

Howdy,
We're having very similar problems with our SCHa530.
Test bit is enabled (verified with ###3) and we should have a good SIG (we've recreated it several times in case we had a typo in our ESN).
However, upon running the app, we still get the error
Application Digital Signature Failure (1029).
Been banging on this for many hours, read just about all the forum posts we can find. Finally sent a message to Qualcomm's tech support.
Any clues out there?
-j

Did this today:
Check date correct on handset
Check sig file correct
Connect cable to computer
Power up phone
Connect cable to phone
Open apploader
Connect to device
Module > New (and apps inserted fine)
Power off phone for several seconds
Power on
Brewshop > Select app >
"Application Digital Signature Failure 1028"
I have noticed in the apploader window that the dates of the files appear as
01/05/80 23:59:47
On my computer, the dates on the files are correct.
Could the signature failure have something to do with the dates on the files? How can I correct this and find out.
Any other suggestions welcome, I'm about to attempt to load an app while standing on my head - just in case I've missed anything.
:confused:
Sam

Did this today:
Check date correct on handset
Check sig file correct
Connect cable to computer
Power up phone
Connect cable to phone
Open apploader
Connect to device
Module > New (and apps inserted fine)
Power off phone for several seconds
Power on
Brewshop > Select app >
"Application Digital Signature Failure 1028"
I have noticed in the apploader window that the dates of the files appear as
01/05/80 23:59:47
On my computer, the dates on the files are correct.
Could the signature failure have something to do with the dates on the files? How can I correct this and find out.
Any other suggestions welcome, I'm about to attempt to load an app while standing on my head - just in case I've missed anything.
:confused:
Sam

If you look at aeeerror.h file, an error code of 1028 ie., 0x404 means an expired signature file.
I feel this might be because the date on your handset is in 80s. Just change the date to today's date and try it again.
Regards,
- RR.

If you look at aeeerror.h file, an error code of 1028 ie., 0x404 means an expired signature file.
I feel this might be because the date on your handset is in 80s. Just change the date to today's date and try it again.
Regards,
- RR.

joe,
An error of 1029 ie., 0x405 means "No valid permission". I dunno what causes this error.
It will take some time to get a reply from Qualcomm or if you got it already then pl. post their reply.
Thanks & Regards,
- RR.

joe,
An error of 1029 ie., 0x405 means "No valid permission". I dunno what causes this error.
It will take some time to get a reply from Qualcomm or if you got it already then pl. post their reply.
Thanks & Regards,
- RR.

Quote:Originally posted by Raghavendra
If you look at aeeerror.h file, an error code of 1028 ie., 0x404 means an expired signature file.
I feel this might be because the date on your handset is in 80s. Just change the date to today's date and try it again.
Regards,
- RR.
OK thanks, I'll try that :D :D worth getting another sig file just in case? I will anyway. And double-check the ESN.
Sam

Quote:Originally posted by Raghavendra
If you look at aeeerror.h file, an error code of 1028 ie., 0x404 means an expired signature file.
I feel this might be because the date on your handset is in 80s. Just change the date to today's date and try it again.
Regards,
- RR.
OK thanks, I'll try that :D :D worth getting another sig file just in case? I will anyway. And double-check the ESN.
Sam

Hahaha (hysterical)
Ok, checked the date was correct on the handset, generated a new sig file, did it all again.
When I power cycle the phone it resets the time and date back to 04/01/1981 11:59 P and so when I select the app from brewshop I get the 1028 error again.
So I've got no chance have I since power-cycling is necessary to re-boot the phone :confused: :confused:

Hahaha (hysterical)
Ok, checked the date was correct on the handset, generated a new sig file, did it all again.
When I power cycle the phone it resets the time and date back to 04/01/1981 11:59 P and so when I select the app from brewshop I get the 1028 error again.
So I've got no chance have I since power-cycling is necessary to re-boot the phone :confused: :confused:

Try using AppLoader to reset the phone.

Try using AppLoader to reset the phone.

Just tried that. 1028 error again.
Incidentally, after resetting the phone I go to 'planner' and select 'today' and I get the message "please set time first" - so this indicates that every time I power-cycle the phone, the date reverts which is most likely to be the reason I get the 1028 error.
Does anyone know how to set the date and time on the phone and have it permanent - even if you powercycle the phone? I have a hunch that's going to be the answer.,
Thanks,
Sam

Just tried that. 1028 error again.
Incidentally, after resetting the phone I go to 'planner' and select 'today' and I get the message "please set time first" - so this indicates that every time I power-cycle the phone, the date reverts which is most likely to be the reason I get the 1028 error.
Does anyone know how to set the date and time on the phone and have it permanent - even if you powercycle the phone? I have a hunch that's going to be the answer.,
Thanks,
Sam

Did you just try running the app soon after loading and without resetting the phone ?
It might work sometimes. ;)
- RR.

Did you just try running the app soon after loading and without resetting the phone ?
It might work sometimes. ;)
- RR.

Every time, and no, the icon doesn't appear in brewshop.
Sam

Every time, and no, the icon doesn't appear in brewshop.
Sam

Im working from Japan where there is a CDMA network, but not one that a US Verizon phone can access. I have a a530, and everytime I reset the phone I have to manually set the clock, otherwise I will get a 1028 error for all applications..
So maybe you just need to set the clock after power cycling the phone, but before running the brew app.
Otherwise, maybe it is a result of no CDMA network...
-Tyndal

Im working from Japan where there is a CDMA network, but not one that a US Verizon phone can access. I have a a530, and everytime I reset the phone I have to manually set the clock, otherwise I will get a 1028 error for all applications..
So maybe you just need to set the clock after power cycling the phone, but before running the brew app.
Otherwise, maybe it is a result of no CDMA network...
-Tyndal

Yep! that's the answer - it works anyway. Thanks for everyone's help on this.
Sam:D

Yep! that's the answer - it works anyway. Thanks for everyone's help on this.
Sam:D