Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Hi guys!

I have an ActorModel_SendEvent function which is very similar to the CircleActor_SendEvent function but unfortunately I can't receive the event i'm throwing from my actor to my trigml?
Is there any settings i have to make in my trigml to receive this event?

Hope you have some ideas regarding this matter. please enlighten me up.

From my earlier experiences there might be 3 possbile causes of your problem:
1. The TrigML has not been fully loaded (or the listener hasn't been loaded yet)when you sent your event to your trigML.
2. The event you sent was unable to reach the layer to which your trigML was loaded into.
3. The Function you have been using to send events does not work properly.
Could you send code snippets of your trigML and the function you've been using to send events to your trigML please? So that we could maybe have more of an idea on what's happening. Thank You.

From my earlier experiences there might be 3 possbile causes of your problem:
1. The TrigML has not been fully loaded (or the listener hasn't been loaded yet)when you sent your event to your trigML.
2. The event you sent was unable to reach the layer to which your trigML was loaded into.
3. The Function you have been using to send events does not work properly.
Could you send code snippets of your trigML and the function you've been using to send events to your trigML please? So that we could maybe have more of an idea on what's happening. Thank You.

Hi,
I am also facing the same kind of problem..
Can anybody help in this issue.
please check this post
http://brewforums.qualcomm.com/showthread.php?t=15438

Hi,
I am also facing the same kind of problem..
Can anybody help in this issue.
please check this post
http://brewforums.qualcomm.com/showthread.php?t=15438

Quote:From my earlier experiences there might be 3 possbile causes of your problem:
1. The TrigML has not been fully loaded (or the listener hasn't been loaded yet)when you sent your event to your trigML.
2. The event you sent was unable to reach the layer to which your trigML was loaded into.
3. The Function you have been using to send events does not work properly.
Add to the list: the group that receives the event must be focusable and have the focus. This might be another way of saying #1. Add hasfocus="_true" canfocus="_true" to the tag.
Unless you need to pass event parameters, I believe node notifying is better because a trig object can't receive an event unless it has the focus.

Quote:From my earlier experiences there might be 3 possbile causes of your problem:
1. The TrigML has not been fully loaded (or the listener hasn't been loaded yet)when you sent your event to your trigML.
2. The event you sent was unable to reach the layer to which your trigML was loaded into.
3. The Function you have been using to send events does not work properly.
Add to the list: the group that receives the event must be focusable and have the focus. This might be another way of saying #1. Add hasfocus="_true" canfocus="_true" to the tag.
Unless you need to pass event parameters, I believe node notifying is better because a trig object can't receive an event unless it has the focus.