Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

Is this code is enougth to make my app run network via proxy?

// turn off HTTP over HTTP proxying
awo[i].nId = WEBOPT_PROXYSPEC;
awo[i].pVal = (void *)"http:///";
i++;
// turn on ALL proxying. Proxyspecs are examined in WebOpt
// order, so in this list, with the above and below PROXYSPECs,
// everything except HTTP will be proxied through
// http://webproxy.yourdomain.com:8080, (which you'll have to
// set up to test, sorry
awo[i].nId = WEBOPT_PROXYSPEC;
awo[i].pVal = (void *)"*:///http://127.0.0.1:80";

Should i give some additional params in GetResponce? Or I can't give proxy name as IP and should give something like "http://webproxy.yourdomain.com" ?

Hello Friends..
I am also facing the same problem. If anyone has any solution for getting the internet connected through a application with proxy settings then pls help me.
Thanks
Abhilasha

Hello Friends..
I am also facing the same problem. If anyone has any solution for getting the internet connected through a application with proxy settings then pls help me.
Thanks
Abhilasha

well, I've found the way...
all you need is to set IWEB options after creating IWEB interface:
int i = 0;
WebOpt awo[1];
awo[i].nId = WEBOPT_PROXYSPEC;
awo[i].pVal = (void *)"http:///http://0.0.0.0:80";
// 0.0.0.0:80 - put here your proxy
i++;
IWEB_AddOpt(m_pIWeb,awo);
So, all your requests will go through http proxy...
Good luck!

well, I've found the way...
all you need is to set IWEB options after creating IWEB interface:
int i = 0;
WebOpt awo[1];
awo[i].nId = WEBOPT_PROXYSPEC;
awo[i].pVal = (void *)"http:///http://0.0.0.0:80";
// 0.0.0.0:80 - put here your proxy
i++;
IWEB_AddOpt(m_pIWeb,awo);
So, all your requests will go through http proxy...
Good luck!

I have implemented the same but I get error code 400(Bad Request) while I am trying to connect yahoo.com.
So what next should I try to resolve the issue?

I have implemented the same but I get error code 400(Bad Request) while I am trying to connect yahoo.com.
So what next should I try to resolve the issue?

Check if your proxy visible outside your network, and proxy, by idea, should be "transparent". Check if request runs successfully without proxy, to be shure you using correct adress ;) ( try: http://yahoo.com )
I suppose, prefix "http://" should be in request...

Check if your proxy visible outside your network, and proxy, by idea, should be "transparent". Check if request runs successfully without proxy, to be shure you using correct adress ;) ( try: http://yahoo.com )
I suppose, prefix "http://" should be in request...

I am trying to connect with google or some other server but i didn't find the way to set prosy settings for TCP conection by using ISockPort . like in IWeb interface has structure
WebOpt awo[10]; //where we can set the options for proxy.
pls hlp me

I am trying to connect with google or some other server but i didn't find the way to set prosy settings for TCP conection by using ISockPort . like in IWeb interface has structure
WebOpt awo[10]; //where we can set the options for proxy.
pls hlp me