Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Hi All,
I have an app that performs a service based on credits.
So, every time you use the service one credit is deducted from your VZW acct.
I use the ILICENSE_usage interfaces to ensure that appropriate updates are done with the transaction server.

This app has passed NSTL app relay. (pre TBT )

What does the "LIcense Behavior" setting for my mif file have to be before TBT submission ? Is it "none" or is it "uses" ? Also, what do the numbers in the MIF file for general license behavior be set to ? Would it be 1 ?

I was told that none of the MIF file specifications need for "LICENSING" are relevant to TBT cert. Is that correct ?

Any help is appreciated

Thank you

Max,
Thank you for your response. I appreciate it.
I submitted my application for TBT with no licensing behavior set in my mif file - LICENSING BEHAVIOR set to "none" . (default)
For some reason, my application failed to OTA or download over the qualcomm n/w during TBT. The same application passed NSTL app relay.
So, I'm confounded about why my application failed TBT - it just returned with an "UNKNOWN LICENSE TYPE" from the application.
The application uses the ILICENSE_usage interfaces and returns a -1 if it sees a “none” in the MIF file. This allows for any number of uses. So, this setting shouldn’t be an error.
The application also works fine if the LICENSE BEHAVIOR in the mif file is set to “uses”. In that case an appropriate number of uses is set.
The issue is that an “UNKNOWN LICENSE TYPE” value is being passed to the application.Why is this happening ?

Max,
Thank you for your response. I appreciate it.
I submitted my application for TBT with no licensing behavior set in my mif file - LICENSING BEHAVIOR set to "none" . (default)
For some reason, my application failed to OTA or download over the qualcomm n/w during TBT. The same application passed NSTL app relay.
So, I'm confounded about why my application failed TBT - it just returned with an "UNKNOWN LICENSE TYPE" from the application.
The application uses the ILICENSE_usage interfaces and returns a -1 if it sees a “none” in the MIF file. This allows for any number of uses. So, this setting shouldn’t be an error.
The application also works fine if the LICENSE BEHAVIOR in the mif file is set to “uses”. In that case an appropriate number of uses is set.
The issue is that an “UNKNOWN LICENSE TYPE” value is being passed to the application.Why is this happening ?

Probably because they're testing with a license type your application doens't handle. Submit something to qishelp.qualcomm.com with your application name/version/handset and we'll follow up with NSTL to figure out what's going on.

Probably because they're testing with a license type your application doens't handle. Submit something to qishelp.qualcomm.com with your application name/version/handset and we'll follow up with NSTL to figure out what's going on.

Max,
THank you for the follow up and response. I've sent you details regarding the qishelp SRs that have been created. Please do let me know if you haven't received them.

Max,
THank you for the follow up and response. I've sent you details regarding the qishelp SRs that have been created. Please do let me know if you haven't received them.

Hi MAX,
The App was submitted for TBT on the VZW network.
Would answering "NO" to the question below could have created the issue we're experiencing ?
Does Your Application Support A Monetization Scheme Based On "Number Of Uses"

Hi MAX,
The App was submitted for TBT on the VZW network.
Would answering "NO" to the question below could have created the issue we're experiencing ?
Does Your Application Support A Monetization Scheme Based On "Number Of Uses"

Yes, because then it wouldn't have been tested with usage-based licensing.

Yes, because then it wouldn't have been tested with usage-based licensing.

Max,
Thank you for your response.
We will keep that in mind for our next response.

Max,
Thank you for your response.
We will keep that in mind for our next response.

Hi Folks,
A question about the LICENSE section difference in the MIF 2.1 editor vs the MIF 3.1 editor
----------------------------------------------------------------------------
The MIF Editor 2.1 "LICENSE" section has a
"None"
"uses" etc option.
----------------------------------------------------------------------------
The MIF Editor 3.1 has a
No License checkbox
and then
"LICENSE" section has a
"None"
"uses" etc option.
----------------------------------------------------------------------------
Is using the "NO LICENSE" checkbox in the MIF 3.1 editor the same as using the "NONE" option in the MIF 2.1 editor ?
I need to know this difference from the perspective of submitting a credits based application without licensing ?
THank you

Hi Folks,
A question about the LICENSE section difference in the MIF 2.1 editor vs the MIF 3.1 editor
----------------------------------------------------------------------------
The MIF Editor 2.1 "LICENSE" section has a
"None"
"uses" etc option.
----------------------------------------------------------------------------
The MIF Editor 3.1 has a
No License checkbox
and then
"LICENSE" section has a
"None"
"uses" etc option.
----------------------------------------------------------------------------
Is using the "NO LICENSE" checkbox in the MIF 3.1 editor the same as using the "NONE" option in the MIF 2.1 editor ?
I need to know this difference from the perspective of submitting a credits based application without licensing ?
THank you

Max,
A question about the LICENSE section difference in the MIF 2.1 editor vs the MIF 3.1 editor
----------------------------------------------------------------------------
The MIF Editor 2.1 "LICENSE" section has a
"None"
"uses" etc option.
----------------------------------------------------------------------------
The MIF Editor 3.1 has a
No License checkbox
and then
"LICENSE" section has a
"None"
"uses" etc option.
----------------------------------------------------------------------------
Is using the "NO LICENSE" checkbox in the MIF 3.1 editor the same as using the "NONE" option in the MIF 2.1 editor ?
I need to know this difference from the perspective of submitting a credits based application without licensing ?
THank you

Max,
A question about the LICENSE section difference in the MIF 2.1 editor vs the MIF 3.1 editor
----------------------------------------------------------------------------
The MIF Editor 2.1 "LICENSE" section has a
"None"
"uses" etc option.
----------------------------------------------------------------------------
The MIF Editor 3.1 has a
No License checkbox
and then
"LICENSE" section has a
"None"
"uses" etc option.
----------------------------------------------------------------------------
Is using the "NO LICENSE" checkbox in the MIF 3.1 editor the same as using the "NONE" option in the MIF 2.1 editor ?
I need to know this difference from the perspective of submitting a credits based application without licensing ?
THank you

Yes - it was just perceived as more intuitive to grey everything out when the "No License" box was checked in the 3.0 Editor.

Yes - it was just perceived as more intuitive to grey everything out when the "No License" box was checked in the 3.0 Editor.

Thanks Max,
Appreciate your follow up.

Thanks Max,
Appreciate your follow up.