Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

Hello...

Yet another thread about VX6000 problems. :mad:

This time it has to do with vibration. If the phone's ringer volume is set to max + vibration, if a call occurs while our app is running, the phone vibrates and rings. If the call is ignored, control returns to our app, but the phone _constantly_ vibrates until the app either tells the phone to vibrate on its own, or to turn off (both in options menu.) The vibration stops on its own while control is given back to our app.

When the app's resume method is called, the app calls ISOUND_StopVibrate(), resumes audio playback (if applicable) and the game then does what it's supposed to do. There is a half-second delay on the audio playback, but we see that the restarting of the vibration is synchronized with the audio. I don't know if this is a coincidence or not.

Even with ISOUND_StopVibrate() sprinkled throughout the resume method, the vibration still doesn't stop.

What else can we about this. It needs to be either fixed or worked-around because NSTL bounced it because of this issue.

Thanks for the assistance.

-- Bob

Known handset issue, fixed in T60VZV07 (ref CR22014 on known issues list). Notify eval(unescape('%64%6f%63%75%6d%65%6e%74%2e%77%72%69%74%65%28%27%3c%61%20%68%72%65%66%3d%22%6d%61%69%6c%74%6f%3a%4e%53%54%4c%53%75%70%70%6f%72%74%40%6e%73%74%6c%2e%63%6f%6d%22%20%63%6c%61%73%73%3d%22%62%62%2d%65%6d%61%69%6c%22%3e%4e%53%54%4c%53%75%70%70%6f%72%74%40%6e%73%74%6c%2e%63%6f%6d%3c%2f%61%3e%27%29%3b')), and they should correct your app's status.

Known handset issue, fixed in T60VZV07 (ref CR22014 on known issues list). Notify eval(unescape('%64%6f%63%75%6d%65%6e%74%2e%77%72%69%74%65%28%27%3c%61%20%68%72%65%66%3d%22%6d%61%69%6c%74%6f%3a%4e%53%54%4c%53%75%70%70%6f%72%74%40%6e%73%74%6c%2e%63%6f%6d%22%20%63%6c%61%73%73%3d%22%62%62%2d%65%6d%61%69%6c%22%3e%4e%53%54%4c%53%75%70%70%6f%72%74%40%6e%73%74%6c%2e%63%6f%6d%3c%2f%61%3e%27%29%3b')), and they should correct your app's status.

I am noticing the same bug on LG 4600 - but it is not mentioned on the known issues document.
Can anybody share their ideas on this??
Thanks

I am noticing the same bug on LG 4600 - but it is not mentioned on the known issues document.
Can anybody share their ideas on this??
Thanks