Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

Hello BREWers,
my application compiles and links without errors on ARM RVCT 1.2, but it won't link on Visual Studio 2005. I keep getting this error:

error LNK2001: unresolved external symbol _g_pvtAEEStdLibEntry

It's the only error i get, but i get it multiple times, once for each .obj file.
The AEE_SIMULATOR definition is set, and i also made sure i #included the headers from BREWDIR\inc.

Any suggestions ? Thanks alot for your time !

ponx

Are you sure you're linking in AEEModGen.c? Or are you sure AEE_SIMULATOR is defined for that file?

Are you sure you're linking in AEEModGen.c? Or are you sure AEE_SIMULATOR is defined for that file?

hi rabidcow, thanks for your reply !
Yes, the AEEModGen.c is linked. The AEE_SIMULATOR is included in the preprocessor definitions of my project file. Does it have to be set for single files ? I'm not sure how to do that, since i can't write it as a #define in the source code as that would propably mess up my ARM build, which is running fine at the moment. Or is there another way ?
cheers,
ponx

hi rabidcow, thanks for your reply !
Yes, the AEEModGen.c is linked. The AEE_SIMULATOR is included in the preprocessor definitions of my project file. Does it have to be set for single files ? I'm not sure how to do that, since i can't write it as a #define in the source code as that would propably mess up my ARM build, which is running fine at the moment. Or is there another way ?
cheers,
ponx

we got it !!
The problem was, that the header files were from BREW SDK 2.1.3, and the .c files from 3.1.5. Somehow the BREWDIR was changed.
party time ! :D
ponx

we got it !!
The problem was, that the header files were from BREW SDK 2.1.3, and the .c files from 3.1.5. Somehow the BREWDIR was changed.
party time ! :D
ponx