Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

I have a Moto V710 and the Verizon Mobile Office Kit that
includes a USB<->PC connection cable. Can I use AppLoader to
download an Applet to the phone? It appears AppLoader only supports
serial connections. Such a waste to have to buy yet another
cable, though I'll go that route if that's the only viable download
path.

thanks,
brian.

Yes, you can use a usb cable, you just need a modem driver for it.
Read this thread:
http://brewforums.qualcomm.com/showthread.php?t=5789&highlight=modem+port

Yes, you can use a usb cable, you just need a modem driver for it.
Read this thread:
http://brewforums.qualcomm.com/showthread.php?t=5789&highlight=modem+port

Tyndal,
Yes, I read the referred to thread, thanks.
Though it appears this may be a phone specific issue. Having installed
the Verizon software for my USB cable, only COM1 and COM3 show up under
the AppLoader device pop-up.
Doesn't appear there is a method to reconfigure as a modem. Though
because my Thinkpad T42 does not have a serial port, so it appears
I need to get the USB connector going...
Any other information regarding where I might get a driver that
makes the cable appear as a modem would be appreciated. As stated,
I have loaded the verizon software which should have loaded all
included drivers - so this must be outside their offerings.
brian.

Tyndal,
Yes, I read the referred to thread, thanks.
Though it appears this may be a phone specific issue. Having installed
the Verizon software for my USB cable, only COM1 and COM3 show up under
the AppLoader device pop-up.
Doesn't appear there is a method to reconfigure as a modem. Though
because my Thinkpad T42 does not have a serial port, so it appears
I need to get the USB connector going...
Any other information regarding where I might get a driver that
makes the cable appear as a modem would be appreciated. As stated,
I have loaded the verizon software which should have loaded all
included drivers - so this must be outside their offerings.
brian.

Dont have a v710, but for the t720, the mobile office kit came with 2 cds. one having
usb drivers and the other having "quicklink mobile" ..
the only thing i installed from those cds was the usb driver.. no other software was necessarry (i am not sure what you are referring to as the "verizon software")
if the usb driver is installed, and the device is on and connected before starting up apploader it should show up as a com port (possibly com3 if you only have com ports 1 and 2 show up without the device connected.)
Other options might be to check the drivers from futuredial, or wait for help from someone that has a v710 handset.
-Tyndal
edit:
Fyi: I have a program listed as "Motorola Handset USB Driver" listed under my windows add/remove programs.
another option might be to see if it works on a different machine

Dont have a v710, but for the t720, the mobile office kit came with 2 cds. one having
usb drivers and the other having "quicklink mobile" ..
the only thing i installed from those cds was the usb driver.. no other software was necessarry (i am not sure what you are referring to as the "verizon software")
if the usb driver is installed, and the device is on and connected before starting up apploader it should show up as a com port (possibly com3 if you only have com ports 1 and 2 show up without the device connected.)
Other options might be to check the drivers from futuredial, or wait for help from someone that has a v710 handset.
-Tyndal
edit:
Fyi: I have a program listed as "Motorola Handset USB Driver" listed under my windows add/remove programs.
another option might be to see if it works on a different machine

Tyndal,
I reinstalled the drivers from Verizon disc 1. Then
launched AppLoader; devices COM1 and COM3 appear
as before, and no communication occurs with the V710.
If i pull the USB cable from the Thinkpad, and plug back in
I receive a message saying new hardware was detected and
the Found New Hardware Wizard is launched. Though I
suspect I should not run this...
when do you see the Green Connected indication on the bottom
of the AppLoader window. I never see this.
thanks again,
brian.

Tyndal,
I reinstalled the drivers from Verizon disc 1. Then
launched AppLoader; devices COM1 and COM3 appear
as before, and no communication occurs with the V710.
If i pull the USB cable from the Thinkpad, and plug back in
I receive a message saying new hardware was detected and
the Found New Hardware Wizard is launched. Though I
suspect I should not run this...
when do you see the Green Connected indication on the bottom
of the AppLoader window. I never see this.
thanks again,
brian.

yes, you need to run the new hardware wizard.. it will "register" the com port or something..
every time I plug a new device or the same device into a different port (as in on a hub) i have to re-run the wizard before the device will show up on the apploader..
therefore my port numbers constantly are increasing (im up to 22 or so now)..
btw, im using winXP.
note: if anyone knows how to reset the usb registry please post or pm me. Thanks
-Tyndal

yes, you need to run the new hardware wizard.. it will "register" the com port or something..
every time I plug a new device or the same device into a different port (as in on a hub) i have to re-run the wizard before the device will show up on the apploader..
therefore my port numbers constantly are increasing (im up to 22 or so now)..
btw, im using winXP.
note: if anyone knows how to reset the usb registry please post or pm me. Thanks
-Tyndal

Tyndal,
I ran the Wizard (disregarding the warning messages it emits about
how it may produce irreparable harm to the machine...) and all
appears to work fine.
Now when launching AppLoader I see a COM4 port, and when
hitting the OK button to connect, the phone's filesystem
is loaded.
It's important to note for others, there are USB to serial drivers
which can be downloaded at futuredial.com, though I
did not use these. Rather, the drivers on the Verizon Mobile
Office Kit were used, though this might be the more expensive option.
Others might want to check out the futuredial drivers, but
that being said. The MOK drivers work for the V710.
thanks again for the assistance.
brian.

Tyndal,
I ran the Wizard (disregarding the warning messages it emits about
how it may produce irreparable harm to the machine...) and all
appears to work fine.
Now when launching AppLoader I see a COM4 port, and when
hitting the OK button to connect, the phone's filesystem
is loaded.
It's important to note for others, there are USB to serial drivers
which can be downloaded at futuredial.com, though I
did not use these. Rather, the drivers on the Verizon Mobile
Office Kit were used, though this might be the more expensive option.
Others might want to check out the futuredial drivers, but
that being said. The MOK drivers work for the V710.
thanks again for the assistance.
brian.

Anyone have a good suggestion for a driver for the v710. I do not have the MOK and the futuredial driver doesn't seem to be working. At least the hardware wizard doesn't recognize it as a v710 driver and thus disables the device.... and I'm getting tired of wasting more time on this, after trying for 4 hours.
If anyone has a driver for this phone please let me know where I could get it or please feel free to email it to me.
Thanks, guys!

Anyone have a good suggestion for a driver for the v710. I do not have the MOK and the futuredial driver doesn't seem to be working. At least the hardware wizard doesn't recognize it as a v710 driver and thus disables the device.... and I'm getting tired of wasting more time on this, after trying for 4 hours.
If anyone has a driver for this phone please let me know where I could get it or please feel free to email it to me.
Thanks, guys!

Use a USB-to-serial adapter. I have been using one made by SIIG for a while now, and it makes my life so much easier knowing I'll never have to deal with all those USB driver problems everyone seems to run into.
-Erik

Use a USB-to-serial adapter. I have been using one made by SIIG for a while now, and it makes my life so much easier knowing I'll never have to deal with all those USB driver problems everyone seems to run into.
-Erik

Thanks, but that's not the answer I've been looking for. I am looking for a USB driver for the v710.

Thanks, but that's not the answer I've been looking for. I am looking for a USB driver for the v710.

So, I take it that NO ONE has been able to obtain a driver for the v710 for USB at this time????
un-:cool:

So, I take it that NO ONE has been able to obtain a driver for the v710 for USB at this time????
un-:cool:

still nobody knows?

still nobody knows?

When I worked on V710, I had problems with USB cable, then I switched to serial cable and worked fine.

When I worked on V710, I had problems with USB cable, then I switched to serial cable and worked fine.

A friendly soul sent me the USB drivers for the v710 from the Mobile Office Kit, and after installing that it worked like a charm using the good old t720 cable.

A friendly soul sent me the USB drivers for the v710 from the Mobile Office Kit, and after installing that it worked like a charm using the good old t720 cable.

Would it be possible for you to share the V710 USB driver with me?

Would it be possible for you to share the V710 USB driver with me?