Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Hi,

Where can I get a valid sig file for HTC Smart? I need one to enable Developer Mode according to https://brewmobileplatform.qualcomm.com/devnet/resources/devEx/library/techguides/c/tools/connect/html_out_dev/frameset.html

BR,
Ida

Hello Ida,
Please take a look at our Connect Technology Guide here https://brewmobileplatform.qualcomm.com/devnet/docviewer.jsp?method=show... for enabling Developer Mode. Let me know if you have any questions.
Regards,
Brian

Hello Ida,
Please take a look at our Connect Technology Guide here https://brewmobileplatform.qualcomm.com/devnet/docviewer.jsp?method=show... for enabling Developer Mode. Let me know if you have any questions.
Regards,
Brian

That's exactly what I did but I need a sig file to be able to follow the guide "Developer Mode enable using SystemTask application". So where can I receive a Signature file?

That's exactly what I did but I need a sig file to be able to follow the guide "Developer Mode enable using SystemTask application". So where can I receive a Signature file?

If you connect your device and launch a Brew MP Tool such as Loader or Logger (noted in section Development Enable Service (DES)) you should be able to supply your credentials and a device enablement signature will be pushed automatically to your device. If you are doing this procedure and getting an error message, can you please provide?
Regards,
Brian

If you connect your device and launch a Brew MP Tool such as Loader or Logger (noted in section Development Enable Service (DES)) you should be able to supply your credentials and a device enablement signature will be pushed automatically to your device. If you are doing this procedure and getting an error message, can you please provide?
Regards,
Brian

Hi,
I can connect the phone with the Loader if I choose BMP Tragets [COM/BLIT] or BMP Device [COM/DIAG]. If I choose the second one I can see the file system. If I choose BMP Tragets I get a pop up that says "Developer Mode Locked - ..." There are two options, enable Developer Mode via Brew MP Account or Signature File. The first one is grayed out and can't be chosen.
I can also tell you that I couldn't use the drivers that came with the SDK.
Thanks,
Ida

Hi,
I can connect the phone with the Loader if I choose BMP Tragets [COM/BLIT] or BMP Device [COM/DIAG]. If I choose the second one I can see the file system. If I choose BMP Tragets I get a pop up that says "Developer Mode Locked - ..." There are two options, enable Developer Mode via Brew MP Account or Signature File. The first one is grayed out and can't be chosen.
I can also tell you that I couldn't use the drivers that came with the SDK.
Thanks,
Ida

Ok. Can I ask what version of firmware is running on the device? 1.0.2+ supports developer mode on the unit. If this is the case, you can go into "USB to PC" under Settings and within Developer mode menu, select an option for Gateway connection. This will allow you to connect over USB and access the authentication server. If your device is <1.0.2, then we will have to produce you a sig and send off (just send me your IMEI via PM). Let me know status and I'll get you up and running.
Regards,
Brian

Ok. Can I ask what version of firmware is running on the device? 1.0.2+ supports developer mode on the unit. If this is the case, you can go into "USB to PC" under Settings and within Developer mode menu, select an option for Gateway connection. This will allow you to connect over USB and access the authentication server. If your device is <1.0.2, then we will have to produce you a sig and send off (just send me your IMEI via PM). Let me know status and I'll get you up and running.
Regards,
Brian

Quote:you can go into "USB to PC" under Settings and within Developer mode menu, select an option for Gateway connection.
May I know where can i find that settings?
Thank you

Quote:you can go into "USB to PC" under Settings and within Developer mode menu, select an option for Gateway connection.
May I know where can i find that settings?
Thank you

Go under "Settings" and scroll down to bottom of screen until you see "About Phone" select this and scroll down to "Operating System". It should say something like Brew MP 1.0.n.nnn". If it is above 1.0.2 then you can use what I've sent previously to enable the device for development, if its not, then you may have to either have it reflashed (which means that you'll either have to return it to where you purchased it or wait for HTC to release the 1.0.2 firmware patch). Please let me know the data you find.
Regards,
Brian

Go under "Settings" and scroll down to bottom of screen until you see "About Phone" select this and scroll down to "Operating System". It should say something like Brew MP 1.0.n.nnn". If it is above 1.0.2 then you can use what I've sent previously to enable the device for development, if its not, then you may have to either have it reflashed (which means that you'll either have to return it to where you purchased it or wait for HTC to release the 1.0.2 firmware patch). Please let me know the data you find.
Regards,
Brian

Hi Brian,
Thank you so much for your reply.
I am using Brew MP 1.0.3.
I was able to input the username and password in the "Development Mode Locked" dialog box, but it gives me the ff. error.
"Connect is unable to contact the Portal Server. Try again later, or if the problem persists, download the latest version of the SDK."
I think it is because we are connecting to the internet via proxy. Is there a way to set this is BMP?
Thanks

Hi Brian,
Thank you so much for your reply.
I am using Brew MP 1.0.3.
I was able to input the username and password in the "Development Mode Locked" dialog box, but it gives me the ff. error.
"Connect is unable to contact the Portal Server. Try again later, or if the problem persists, download the latest version of the SDK."
I think it is because we are connecting to the internet via proxy. Is there a way to set this is BMP?
Thanks

Hi Brian,
I've also tried to connect via sig file, but it gives me "GTES has failed by returning 1039" error. Would you know what have caused it?
Thanks.

Hi Brian,
I've also tried to connect via sig file, but it gives me "GTES has failed by returning 1039" error. Would you know what have caused it?
Thanks.