Forums | developer.brewmp.com Forums | developer.brewmp.com

Developer

Forums

Forums:

I need to connect LG AD 6335 have brew 2.1.3 with Brew Apploader but apploader's connection manager is not showing selection for sdk2, so apploader fails to load file system.

How to select sdk 2 in this case in order to view file system?

Attached is image for apploader.

I think you installed the BMP SDK.
But it should work & auto-detect, if you select the "use legacy qualcomm dll".
Are the correct COM ports visible on the App Loader.
thanks.

I think you installed the BMP SDK.
But it should work & auto-detect, if you select the "use legacy qualcomm dll".
Are the correct COM ports visible on the App Loader.
thanks.

Hi shivendra,
Yes correct com port is visible on apploader, and its getting connected for devices having 3.x sdk by default, but,
since there is no option to select sdk 2 , connection with devices having 2.x sdk fails!!! While connection i use option "use legacy qualcomm dll" but no success.
:confused: :confused: :confused:

Hi shivendra,
Yes correct com port is visible on apploader, and its getting connected for devices having 3.x sdk by default, but,
since there is no option to select sdk 2 , connection with devices having 2.x sdk fails!!! While connection i use option "use legacy qualcomm dll" but no success.
:confused: :confused: :confused:

I also have encountered this little issue.
If anyone has information or links on what has or might be done to resolve this, please share.
Guess I will start uninstalling things for now.

I also have encountered this little issue.
If anyone has information or links on what has or might be done to resolve this, please share.
Guess I will start uninstalling things for now.

Is this with Brew MP or Brew tool suite?

Is this with Brew MP or Brew tool suite?

This is going from using Brew tools suite (3.1.1 SP02), and trying out Brew MP SDK - the 'connection manager' component gets updated by Brew MP, and the older tools suite sees the updated manager, i.e. gets a new style connection window.
With this I cannot connect to Brew 2, Brew 3 devices any more :( (dont know about Brew mp ;) )
Anyway, I uninstalled the Brew Mp sdk (multiplatform one) and Apploader etc then would not start, citing missing 'connection manager' component (guess that got uninstalled at that point). I re-installed the Brew tools suite, and things are back to working OK.
So for now I cannot use the brew mp sdk it seems. However if using brew mp sdk as well as older brew 3 tools is tested and supposed to work, then I could experiment more and try to find a way to get it going?

This is going from using Brew tools suite (3.1.1 SP02), and trying out Brew MP SDK - the 'connection manager' component gets updated by Brew MP, and the older tools suite sees the updated manager, i.e. gets a new style connection window.
With this I cannot connect to Brew 2, Brew 3 devices any more :( (dont know about Brew mp ;) )
Anyway, I uninstalled the Brew Mp sdk (multiplatform one) and Apploader etc then would not start, citing missing 'connection manager' component (guess that got uninstalled at that point). I re-installed the Brew tools suite, and things are back to working OK.
So for now I cannot use the brew mp sdk it seems. However if using brew mp sdk as well as older brew 3 tools is tested and supposed to work, then I could experiment more and try to find a way to get it going?

Hi,
I had the same trouble with BREW and BREWMP.
Quote:the 'connection manager' component gets updated by Brew MP, and the older tools suite sees the updated manager, i.e. gets a new style connection window.
With this I cannot connect to Brew 2, Brew 3 devices any more (dont know about Brew mp )
My other post is https://brewmobileplatform.qualcomm.com/devnet/forum.jsp?forumUrl=/bmpfo...
I have not been able to connect to ANY 3.1 devices since installing and uninstalling BREWMP. BREWMP seems to have changed something with the "Connection Manager" such that there is no option for using the QCOMOEM.dll option.
Again, this change (no QCOMOEM.dll option) persists after uninstalling BREWMP. The new "Connection Manager" will not revert to a previously working instance (I'm not even sure where the "Connection Manager" resides, it's not a clearly delineated program).
I few more points:

I've tried changing the environment variable BTILDIR to point to an older version of BTIL installation (version BTIL_1.0.2_SP01 and BTIL_1.0.2_SP04).
The "Connection Manager" will give the error "Error OEM Library BTILOEM.dll could not be loaded".
I also looked at the registry settings for all things Qualcomm. There was nothing related to the "Connection Manager"
After uninstalling everything and then installing everything, the "Connection Manager" will give the error "Error OEM Library BTILOEM.dll could not be loaded". (I've seen the posts saying install while a handset is connected, this has not fixed this problem; yes I have rebooted several times).

:mad:
Update:
After installing and reinstalling programs for too many hours, this combination of installations works (works = allows use of QCOMOEM.dll)

BREW_SDK_3.1.5_SP02 (probably not relevant)
BTIL_1.0.2SP01
SDK_Tools_v1.1.1_SP06
Tools_Suite_3.1.1SP02
Utilities_Pack_2007 (probably not relevant)

I think BREWMP must be entirely removed and then the workstation rebooted.. maybe... I suspect BREWMP holds onto any instances of BTILOEM.dll causing the loading to fail. However, a search for BTILOEM.dll using Process Explorer did not find anything...
blah! BREW 3.x and 2.x handsets can connect to the BREW Logger now. I recommend installing BREWMP in a virtual machine.
-J_Tom_Moon_79

Hi,
I had the same trouble with BREW and BREWMP.
Quote:the 'connection manager' component gets updated by Brew MP, and the older tools suite sees the updated manager, i.e. gets a new style connection window.
With this I cannot connect to Brew 2, Brew 3 devices any more (dont know about Brew mp )
My other post is https://brewmobileplatform.qualcomm.com/devnet/forum.jsp?forumUrl=/bmpfo...
I have not been able to connect to ANY 3.1 devices since installing and uninstalling BREWMP. BREWMP seems to have changed something with the "Connection Manager" such that there is no option for using the QCOMOEM.dll option.
Again, this change (no QCOMOEM.dll option) persists after uninstalling BREWMP. The new "Connection Manager" will not revert to a previously working instance (I'm not even sure where the "Connection Manager" resides, it's not a clearly delineated program).
I few more points:

I've tried changing the environment variable BTILDIR to point to an older version of BTIL installation (version BTIL_1.0.2_SP01 and BTIL_1.0.2_SP04).
The "Connection Manager" will give the error "Error OEM Library BTILOEM.dll could not be loaded".
I also looked at the registry settings for all things Qualcomm. There was nothing related to the "Connection Manager"
After uninstalling everything and then installing everything, the "Connection Manager" will give the error "Error OEM Library BTILOEM.dll could not be loaded". (I've seen the posts saying install while a handset is connected, this has not fixed this problem; yes I have rebooted several times).

:mad:
Update:
After installing and reinstalling programs for too many hours, this combination of installations works (works = allows use of QCOMOEM.dll)

BREW_SDK_3.1.5_SP02 (probably not relevant)
BTIL_1.0.2SP01
SDK_Tools_v1.1.1_SP06
Tools_Suite_3.1.1SP02
Utilities_Pack_2007 (probably not relevant)

I think BREWMP must be entirely removed and then the workstation rebooted.. maybe... I suspect BREWMP holds onto any instances of BTILOEM.dll causing the loading to fail. However, a search for BTILOEM.dll using Process Explorer did not find anything...
blah! BREW 3.x and 2.x handsets can connect to the BREW Logger now. I recommend installing BREWMP in a virtual machine.
-J_Tom_Moon_79

Hi,
A workaround method is possible. The workaround requires BREWMP SDK revision 7.2 and greater.
https://brewmobileplatform.qualcomm.com/devnet/multiplatform_sdk.jsp
The reason this workaround method works is because of a fix in BREWMP SDK revision 7.2
From the Known Issues document:
https://brewmobileplatform.qualcomm.com/devnet/docviewer.jsp?method=show...
Quote:
SDK Manager Can't switch from legacy to multi-platform SDKs and back easily. For the most part, the user is able to make current from the Launcher/SDK Manager to switch between already installed legacy and multi-platform SDKs and back. However there is one BTIL registry entry that is not updated.
User has issues switching environments from Legacy to Multiplatform Brew MP SDK.
High
To switch from legacy SDK to multi-platfor
SDK:
- In CMD window, cd to BrewMP Multi-plat SDK installation folder
- cd Launcher\
- type "ToolsMgr.exe sc " (e.g "ToolsMgr.exe sc 1.0.7.2.1129217")
- In SDK Launcher, make sure that correct toolset and platform are current, set to def necessary
To switch between multi-platform SDK and legacy SDK:
- In CMD window, cd to BrewMP SDK installation directory
- cd tools\EnvtMgr\
- type "EnvironmentManager.exe set"
I use a simpler workaround method of manually changing the BTILDIR environment variable and then running old BREW programs.
[=1]
Open a cmd window
Change the environment variable BTILDIR to the directory of the old BTIL installation. For me this looks like
[="Courier New"]set BTILDIR=C:\BREW\BTIL_1.0.2SP04\[/]
run the old BREW programs from the cmd window. For me this looks like
[="Courier New"]"C:\BREW\Tools_Suite_3.1.1SP02\BREW AppLoader\BREWAppLoader.exe"[/]
[/]
Also posted here https://brewmobileplatform.qualcomm.com/bmpforum/posts/list/847.page#3554

Hi,
A workaround method is possible. The workaround requires BREWMP SDK revision 7.2 and greater.
https://brewmobileplatform.qualcomm.com/devnet/multiplatform_sdk.jsp
The reason this workaround method works is because of a fix in BREWMP SDK revision 7.2
From the Known Issues document:
https://brewmobileplatform.qualcomm.com/devnet/docviewer.jsp?method=show...
Quote:
SDK Manager Can't switch from legacy to multi-platform SDKs and back easily. For the most part, the user is able to make current from the Launcher/SDK Manager to switch between already installed legacy and multi-platform SDKs and back. However there is one BTIL registry entry that is not updated.
User has issues switching environments from Legacy to Multiplatform Brew MP SDK.
High
To switch from legacy SDK to multi-platfor
SDK:
- In CMD window, cd to BrewMP Multi-plat SDK installation folder
- cd Launcher\
- type "ToolsMgr.exe sc " (e.g "ToolsMgr.exe sc 1.0.7.2.1129217")
- In SDK Launcher, make sure that correct toolset and platform are current, set to def necessary
To switch between multi-platform SDK and legacy SDK:
- In CMD window, cd to BrewMP SDK installation directory
- cd tools\EnvtMgr\
- type "EnvironmentManager.exe set"
I use a simpler workaround method of manually changing the BTILDIR environment variable and then running old BREW programs.
[=1]
Open a cmd window
Change the environment variable BTILDIR to the directory of the old BTIL installation. For me this looks like
[="Courier New"]set BTILDIR=C:\BREW\BTIL_1.0.2SP04\[/]
run the old BREW programs from the cmd window. For me this looks like
[="Courier New"]"C:\BREW\Tools_Suite_3.1.1SP02\BREW AppLoader\BREWAppLoader.exe"[/]
[/]
Also posted here https://brewmobileplatform.qualcomm.com/bmpforum/posts/list/847.page#3554